summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-27 09:18:14 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-27 10:29:14 +0200
commitaf7b2693e70e3d0805dd6e3b24488379e4ec2b6f (patch)
tree0bd8d0e1ffbc49fc42911867310948e02fc2f4f8 /dev-python/suds
parentdev-python/tzlocal: Bump to 4.0.2 (diff)
downloadgentoo-af7b2693e70e3d0805dd6e3b24488379e4ec2b6f.tar.gz
gentoo-af7b2693e70e3d0805dd6e3b24488379e4ec2b6f.tar.bz2
gentoo-af7b2693e70e3d0805dd6e3b24488379e4ec2b6f.zip
dev-python/suds: Bump to 1.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/suds')
-rw-r--r--dev-python/suds/Manifest1
-rw-r--r--dev-python/suds/suds-1.0.0.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/suds/Manifest b/dev-python/suds/Manifest
index 5cdab4d0f7f4..04ffc68d94a9 100644
--- a/dev-python/suds/Manifest
+++ b/dev-python/suds/Manifest
@@ -1 +1,2 @@
DIST suds-community-0.8.4.tar.gz 279775 BLAKE2B 985dbe386219d7a5cf8b9edb5a30eea2bc974fce5158a1f6e9c7ad3b437efdf0e4d8ff2bddeaf5b5ebc7f0a594adaea3b2db3e47b6dab8143f6cefae248dd061 SHA512 316e67fb2b87ac31cb9397a1620b279e608dc0abead61fa548730fce5b5e29fb2da937c6213f3de6bd06f1e97031f27351938da686fa2f9ce9f4399b9944e0d2
+DIST suds-community-1.0.0.tar.gz 282894 BLAKE2B 06b1d96c13b0e7f3259b550718d653979e4d7cf5d094c881fb2a4c56f6fd47aa0d204c960d1ec617d3d85fe18b1a86f468e9bbeab6695cde73330e2e97462103 SHA512 77f26df229a93ac0efbc4245180f4eb630bd565624cd5e3e92e82af3545c7ce63802eacfe616cc138e8dfcceb8d9007a88c911c654ca7ba77c82d6e9bcf75d77
diff --git a/dev-python/suds/suds-1.0.0.ebuild b/dev-python/suds/suds-1.0.0.ebuild
new file mode 100644
index 000000000000..ab07dddb98e6
--- /dev/null
+++ b/dev-python/suds/suds-1.0.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_REQ_USE="xml(+)"
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_PN="${PN}-community"
+DESCRIPTION="Lightweight SOAP client"
+HOMEPAGE="https://github.com/suds-community/suds"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+DOCS=( README.md notes/. )
+
+distutils_enable_tests pytest