summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-27 10:46:04 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-27 11:02:18 +0100
commitb621a0462b0ebf16cd728bff7f4e969978b32beb (patch)
tree34b3e98108fcd1642b051a5fdc10a8667ddcf57e /dev-python/tikzplotlib
parentdev-python/threadpoolctl: Switch to PEP 517 build (diff)
downloadgentoo-b621a0462b0ebf16cd728bff7f4e969978b32beb.tar.gz
gentoo-b621a0462b0ebf16cd728bff7f4e969978b32beb.tar.bz2
gentoo-b621a0462b0ebf16cd728bff7f4e969978b32beb.zip
dev-python/tikzplotlib: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tikzplotlib')
-rw-r--r--dev-python/tikzplotlib/tikzplotlib-0.9.17-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/tikzplotlib/tikzplotlib-0.9.17-r1.ebuild b/dev-python/tikzplotlib/tikzplotlib-0.9.17-r1.ebuild
new file mode 100644
index 000000000000..dcf0697f072b
--- /dev/null
+++ b/dev-python/tikzplotlib/tikzplotlib-0.9.17-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Convert matplotlib figures into TikZ/PGFPlots"
+HOMEPAGE="https://github.com/nschloe/tikzplotlib"
+SRC_URI="https://github.com/nschloe/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ app-text/texlive[extra]
+ <dev-python/matplotlib-3.5[latex,${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/pytest-codeblocks[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc dev-python/mock
+
+python_test() {
+ local -x MPLBACKEND=Agg
+ virtx epytest
+}