summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-18 22:25:51 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-18 22:40:29 +0200
commitcf57ae8d9cff009830dc8623c98d53eb4901f98f (patch)
tree6972b39bc6fa9e43edc406e2b8914e0f2255fdf9 /dev-python/tikzplotlib
parentdev-python/python-ironicclient: Bump to 4.9.0 (diff)
downloadgentoo-cf57ae8d9cff009830dc8623c98d53eb4901f98f.tar.gz
gentoo-cf57ae8d9cff009830dc8623c98d53eb4901f98f.tar.bz2
gentoo-cf57ae8d9cff009830dc8623c98d53eb4901f98f.zip
dev-python/tikzplotlib: Bump to 0.9.15
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tikzplotlib')
-rw-r--r--dev-python/tikzplotlib/Manifest1
-rw-r--r--dev-python/tikzplotlib/tikzplotlib-0.9.15.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/tikzplotlib/Manifest b/dev-python/tikzplotlib/Manifest
index ed6dab908996..8ce7f83e867e 100644
--- a/dev-python/tikzplotlib/Manifest
+++ b/dev-python/tikzplotlib/Manifest
@@ -1 +1,2 @@
DIST tikzplotlib-0.9.13.gh.tar.gz 97787 BLAKE2B ef767737b8d222773f2d5e02dbf80ac8a48ea8a00077eb245e5817337805deb5b9be27e7ed76354808647ea1ed6b17d3bbca9b33799d294bd924c18b224e3621 SHA512 f9b4c46b3179626222713dd771dccfa6b0c34ff55658838aba74867c7cd5b91dddfaefdcd2c41824c9f13a795cadd6720240beaf3d504a7f735a2169c441b449
+DIST tikzplotlib-0.9.15.gh.tar.gz 97906 BLAKE2B 6ceac71ff62eea1990ed1820c1c6b2bc7891787fb6604e2e32c4a512a6ca6ddb66800a0208145eaa36c3c8c646a84907b08e747b1d081189a49fde25649419e5 SHA512 cf42bca0be45e6e79e425d0e2da4ffd42868f081186d91dfbec8de20fbff9ab4a071267bb290240b080f9d86bab15e08d757e905690c37f43c0dac7e724ab609
diff --git a/dev-python/tikzplotlib/tikzplotlib-0.9.15.ebuild b/dev-python/tikzplotlib/tikzplotlib-0.9.15.ebuild
new file mode 100644
index 000000000000..adfccd0097b4
--- /dev/null
+++ b/dev-python/tikzplotlib/tikzplotlib-0.9.15.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Convert matplotlib figures into TikZ/PGFPlots"
+HOMEPAGE="https://github.com/nschloe/tikzplotlib"
+SRC_URI="
+ https://github.com/nschloe/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ app-text/texlive[extra]
+ dev-python/matplotlib[latex,${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/exdown[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+)"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc dev-python/mock
+
+python_test() {
+ local -x MPLBACKEND=Agg
+ virtx epytest
+}