summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-31 15:50:33 +0100
committerMichał Górny <mgorny@gentoo.org>2024-10-31 16:49:48 +0100
commit7cd708a658e135277f5c9ad1e42776ec76e47aae (patch)
treed36f78378634523a162a9ee8a42580401cb15b04 /dev-python/toml-fmt-common
parentapp-shells/zsh: drop 5.9-r3, 5.9-r4, 5.9-r5 (diff)
downloadgentoo-7cd708a658e135277f5c9ad1e42776ec76e47aae.tar.gz
gentoo-7cd708a658e135277f5c9ad1e42776ec76e47aae.tar.bz2
gentoo-7cd708a658e135277f5c9ad1e42776ec76e47aae.zip
dev-python/toml-fmt-common: New package, v1.0.1
New dep of dev-python/pyproject-fmt. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/toml-fmt-common')
-rw-r--r--dev-python/toml-fmt-common/Manifest1
-rw-r--r--dev-python/toml-fmt-common/metadata.xml12
-rw-r--r--dev-python/toml-fmt-common/toml-fmt-common-1.0.1.ebuild33
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/toml-fmt-common/Manifest b/dev-python/toml-fmt-common/Manifest
new file mode 100644
index 000000000000..9c7350d79dda
--- /dev/null
+++ b/dev-python/toml-fmt-common/Manifest
@@ -0,0 +1 @@
+DIST toml_fmt_common-1.0.1.tar.gz 9626 BLAKE2B 460e7849dea995bbb1eedbbe2f65bd6401b31d19cfc20bebd8a82c6b4877b64174e1623c4cf649f499b7138141914078a4e0f595374eb4bb3ef423da3f0f934a SHA512 d4e693dd9f3ec0124de6f0006a209bb6f9f62365c16f71033a374a837636f2f744e359aaaed4b42e05a27d8a5e674712b7db2c07a8e93b899b5cd51005d7c525
diff --git a/dev-python/toml-fmt-common/metadata.xml b/dev-python/toml-fmt-common/metadata.xml
new file mode 100644
index 000000000000..c86b212cd313
--- /dev/null
+++ b/dev-python/toml-fmt-common/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">tox-dev/toml-fmt-common</remote-id>
+ <remote-id type="pypi">toml-fmt-common</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/toml-fmt-common/toml-fmt-common-1.0.1.ebuild b/dev-python/toml-fmt-common/toml-fmt-common-1.0.1.ebuild
new file mode 100644
index 000000000000..a97a7bdd0f30
--- /dev/null
+++ b/dev-python/toml-fmt-common/toml-fmt-common-1.0.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Common logic to the TOML formatter"
+HOMEPAGE="
+ https://github.com/tox-dev/toml-fmt-common/
+ https://pypi.org/project/toml-fmt-common/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-2.0.2[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest