summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/unidecode
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/unidecode')
-rw-r--r--dev-python/unidecode/Manifest2
-rw-r--r--dev-python/unidecode/metadata.xml14
-rw-r--r--dev-python/unidecode/unidecode-0.04.17.ebuild27
-rw-r--r--dev-python/unidecode/unidecode-0.04.18.ebuild27
4 files changed, 70 insertions, 0 deletions
diff --git a/dev-python/unidecode/Manifest b/dev-python/unidecode/Manifest
new file mode 100644
index 000000000000..00296f3e6f93
--- /dev/null
+++ b/dev-python/unidecode/Manifest
@@ -0,0 +1,2 @@
+DIST Unidecode-0.04.17.tar.gz 201090 SHA256 f0f8d53d39877da4849293d548eecb5e79364b573643296869dbc7f5b86709ef SHA512 297f411ab09f42cfb455279bb0accafe278d480acf6087b6596dbf4b4d4de89d45d389c5418a2dc4fe8c8f61026c92b3036e08f625e7f434abce9db335682be2 WHIRLPOOL f6fd10531da0e3b6eb14bfbeb07109490523d63151d8a26fd131506d7ead1a7b5570756ec7fa943c25e5a8ede6cbab1c9548cafbbca89301e52781621b41e513
+DIST Unidecode-0.04.18.tar.gz 206191 SHA256 f19150c74de2fe6847b13efeeaee402f2bd2c309a446346a8b5baae0315d108a SHA512 4434b147662c605829a599cb227b10599e70b9a40669b6bce490156c6679d22b49e1768667e10851eaf8d6a142a2c22df4800f0382ed74e781c247708021acd7 WHIRLPOOL 84f07583ba19f6c029128699629dc5709343520b94ea0fd3c8924d7e44910481f5b1574449eb78c2fa4dd884de4fa8b646593623dcae28b809f423c343163aa1
diff --git a/dev-python/unidecode/metadata.xml b/dev-python/unidecode/metadata.xml
new file mode 100644
index 000000000000..f84012a4838f
--- /dev/null
+++ b/dev-python/unidecode/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>jer@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+This is a Python port of the Text::Unidecode Perl (<pkg>dev-perl/Text-Unidecode</pkg> module
+</longdescription>
+ <upstream>
+ <remote-id type="pypi">Unidecode</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/unidecode/unidecode-0.04.17.ebuild b/dev-python/unidecode/unidecode-0.04.17.ebuild
new file mode 100644
index 000000000000..b7c7381ec972
--- /dev/null
+++ b/dev-python/unidecode/unidecode-0.04.17.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+MY_PN=Unidecode
+MY_P=${MY_PN}-${PV}
+
+inherit distutils-r1
+
+DESCRIPTION="Module providing ASCII transliterations of Unicode text"
+HOMEPAGE="http://pypi.python.org/pypi/Unidecode"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ppc sparc x86"
+
+S=${WORKDIR}/${MY_P}
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test || die "Tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/unidecode/unidecode-0.04.18.ebuild b/dev-python/unidecode/unidecode-0.04.18.ebuild
new file mode 100644
index 000000000000..f6a258c9dfaa
--- /dev/null
+++ b/dev-python/unidecode/unidecode-0.04.18.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+MY_PN=Unidecode
+MY_P=${MY_PN}-${PV}
+
+inherit distutils-r1
+
+DESCRIPTION="Module providing ASCII transliterations of Unicode text"
+HOMEPAGE="http://pypi.python.org/pypi/Unidecode"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~sparc ~x86"
+
+S=${WORKDIR}/${MY_P}
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test || die "Tests failed under ${EPYTHON}"
+}