summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-04 04:16:45 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-04 05:13:45 +0200
commit7ccfe075482c313aaba3e059a3467d51e645b902 (patch)
tree79096e18243b5ed13eb144399af6cdd12d23c523 /dev-python/uv
parentdev-python/django: Bump to 5.1.1 (diff)
downloadgentoo-7ccfe075482c313aaba3e059a3467d51e645b902.tar.gz
gentoo-7ccfe075482c313aaba3e059a3467d51e645b902.tar.bz2
gentoo-7ccfe075482c313aaba3e059a3467d51e645b902.zip
dev-python/uv: Bump to 0.4.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/uv')
-rw-r--r--dev-python/uv/Manifest1
-rw-r--r--dev-python/uv/uv-0.4.4.ebuild113
2 files changed, 114 insertions, 0 deletions
diff --git a/dev-python/uv/Manifest b/dev-python/uv/Manifest
index e28c9fa18e62..1cdc974ae11a 100644
--- a/dev-python/uv/Manifest
+++ b/dev-python/uv/Manifest
@@ -4,3 +4,4 @@ DIST rs-async-zip-011b24604fa7bc223daaad7712c0694bac8f0a87.gh.tar.gz 51706 BLAKE
DIST tl-6e25b2ee2513d75385101a8ff9f591ef51f314ec.gh.tar.gz 37106 BLAKE2B c30d1c33f6f52e2bc83823eb6319f8a3e462b7c7408fb6a08f995747857ef234f81db4135a04f9d183095fe473a4087f8f0cb89d8f87ef4400285d2ce034ec22 SHA512 4abbc4240ed129c92da8d616e27a6df0f24cdc85a0803acfdae588ca91f9e5b8d482e3ac88b2e657ff68917b1b43cef1e7ef3c887f624659b231fa5a13fcae68
DIST uv-0.4.2-crates.tar.xz 46277420 BLAKE2B 9f516f586a5e46bbd6c09e116f91e90b563b4de89b2d2dac50f208e4116583ba05418baa998a74f6d31503ec56cb5ff5966cdf579d026c53bcfc500b5e4fb15c SHA512 b30b70225eae9a5970dd18d383d9129b5161cb66942af8796220fe7a58cd3357308111374193d8fc4e1c7fde8a0b62f44e8efd76603411d882df016afecbc69f
DIST uv-0.4.3.gh.tar.gz 2514550 BLAKE2B eae7a625869fe0821abb6c194cb72dc7a3ca2c11d40e731929b886e4b781ab0f7a1099986271c402d64f2eee4582ec57c9443eaecdf18f2d55b2640c8bd9bde9 SHA512 ccb8b125bd32c268cbbeb431fb538d63d700a910392afed8c38470175359dc4153367ba71a5326538e9c7188ddc8b649f23e67f1d2da59ddb17b61c71f33b40f
+DIST uv-0.4.4.gh.tar.gz 2529092 BLAKE2B 89c9aee07f55f2ac7366f66b9355ecbc20d76500b4a8e85a154c9613178bb000c513d3b310750f3d5aba835020797d93deade9e51eb5f742edd750836807a071 SHA512 2b8581b27377256f5ddf6681b7f66acf87454d476330627b76704d76860afbeffcf89e7bdb1a56f60789c0246fdb81d459991f52baa451bbadff5f79df3dad5a
diff --git a/dev-python/uv/uv-0.4.4.ebuild b/dev-python/uv/uv-0.4.4.ebuild
new file mode 100644
index 000000000000..f5da7b7e4913
--- /dev/null
+++ b/dev-python/uv/uv-0.4.4.ebuild
@@ -0,0 +1,113 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CRATES="
+"
+
+declare -A GIT_CRATES=(
+ [async_zip]='https://github.com/charliermarsh/rs-async-zip;011b24604fa7bc223daaad7712c0694bac8f0a87;rs-async-zip-%commit%'
+ [pubgrub]='https://github.com/astral-sh/pubgrub;388685a8711092971930986644cfed152d1a1f6c;pubgrub-%commit%'
+ [reqwest-middleware]='https://github.com/astral-sh/reqwest-middleware;5e3eaf254b5bd481c75d2710eed055f95b756913;reqwest-middleware-%commit%/reqwest-middleware'
+ [reqwest-retry]='https://github.com/astral-sh/reqwest-middleware;5e3eaf254b5bd481c75d2710eed055f95b756913;reqwest-middleware-%commit%/reqwest-retry'
+ [tl]='https://github.com/charliermarsh/tl;6e25b2ee2513d75385101a8ff9f591ef51f314ec;tl-%commit%'
+)
+
+inherit cargo check-reqs
+
+CRATE_PV=0.4.2
+DESCRIPTION="A Python package installer and resolver, written in Rust"
+HOMEPAGE="
+ https://github.com/astral-sh/uv/
+ https://pypi.org/project/uv/
+"
+# pypi sdist misses scripts/, needed for tests
+SRC_URI="
+ https://github.com/astral-sh/uv/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ ${CARGO_CRATE_URIS}
+"
+if [[ ${PKGBUMPING} != ${PVR} ]]; then
+ SRC_URI+="
+ https://dev.gentoo.org/~mgorny/dist/uv-${CRATE_PV}-crates.tar.xz
+ "
+fi
+
+# most of the code
+LICENSE="|| ( Apache-2.0 MIT )"
+# crates/pep508-rs is || ( Apache-2.0 BSD-2 ) which is covered below
+# Dependent crate licenses
+LICENSE+="
+ 0BSD Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD-2 BSD ISC MIT
+ MPL-2.0 Unicode-DFS-2016
+"
+# ring crate
+LICENSE+=" openssl"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="test"
+PROPERTIES="test_network"
+
+BDEPEND="
+ >=virtual/rust-1.80
+ test? (
+ dev-lang/python:3.8
+ dev-lang/python:3.9
+ dev-lang/python:3.10
+ dev-lang/python:3.11
+ dev-lang/python:3.12
+ )
+"
+
+QA_FLAGS_IGNORED="usr/bin/.*"
+
+check_space() {
+ local CHECKREQS_DISK_BUILD=3G
+ use debug && CHECKREQS_DISK_BUILD=9G
+ check-reqs_pkg_setup
+}
+
+pkg_pretend() {
+ check_space
+}
+
+pkg_setup() {
+ check_space
+}
+
+src_prepare() {
+ default
+
+ # remove patch.* that breaks GIT_CRATES
+ local reqmw=${GIT_CRATES[reqwest-middleware]}
+ reqmw=${reqmw#*;}
+ reqmw=${reqmw%;*}
+ sed -i -e "/^\[patch/,\$s@^\(reqwest-middleware = \).*@\1 { path = \"${WORKDIR}/reqwest-middleware-${reqmw}/reqwest-middleware\" }@" Cargo.toml || die
+
+ # https://github.com/vorot93/tokio-tar/pull/23
+ # (fortunately uv already depends on portable-atomic, so we don't
+ # have to fight Cargo.lock)
+ cd "${ECARGO_VENDOR}/tokio-tar-0.3.1" || die
+ eapply "${FILESDIR}/tokio-tar-0.3.1-ppc.patch"
+}
+
+src_compile() {
+ cd crates/uv || die
+ cargo_src_compile
+}
+
+src_test() {
+ # work around https://github.com/astral-sh/uv/issues/4376
+ local -x PATH=${BROOT}/usr/lib/python-exec/python3.12:${PATH}
+ local -x COLUMNS=100
+
+ cd crates/uv || die
+ cargo_src_test --no-fail-fast
+}
+
+src_install() {
+ cd crates/uv || die
+ cargo_src_install
+}