summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-01 23:29:12 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-01 23:29:12 +0200
commit519c7a6f7684b393afe85fef5716e3350afac2f0 (patch)
tree62a942f56ecd3ed1708c705b922fdbfc486d033c /dev-python/uvicorn
parentdev-vcs/reposurgeon: new package (diff)
downloadgentoo-519c7a6f7684b393afe85fef5716e3350afac2f0.tar.gz
gentoo-519c7a6f7684b393afe85fef5716e3350afac2f0.tar.bz2
gentoo-519c7a6f7684b393afe85fef5716e3350afac2f0.zip
dev-python/uvicorn: Bump to 0.14.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/uvicorn')
-rw-r--r--dev-python/uvicorn/Manifest1
-rw-r--r--dev-python/uvicorn/uvicorn-0.14.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/uvicorn/Manifest b/dev-python/uvicorn/Manifest
index ee9b0e8f29cd..91ae5b8f29b2 100644
--- a/dev-python/uvicorn/Manifest
+++ b/dev-python/uvicorn/Manifest
@@ -1 +1,2 @@
DIST uvicorn-0.13.4.tar.gz 505858 BLAKE2B 486436c0b4c717741c11b7da6a979dc9fe977baa2dbc3e2538ce28551d2dee593076b670b16c099056165624c149f96974f64d2847e38234122ec93b65b31cda SHA512 5332494e0b43b4e87f9d6742be679527b1ec2bc4d2e061768594d44b1fd1d6961a2bd1fa23469fca6c530ef36d6123e453306c2bb664cb27b0cd6145b9a70fd7
+DIST uvicorn-0.14.0.tar.gz 511593 BLAKE2B 9f7aee0001874c128e44d31945aaa0ca92237e594debb6fea3c6c6d0f283c96cfad5248578b0e1c170fe2fde96a6b17c56ecf2436783fcae135b8eab1997b701 SHA512 f41a7f01ac6893ceaf4d1f06a4bccd7355e319eee11d6aa290b0d316fb356eb807c926941157ec64f1fc6b7c4601930cfbe271075d6c4cf684bd7e175617390f
diff --git a/dev-python/uvicorn/uvicorn-0.14.0.ebuild b/dev-python/uvicorn/uvicorn-0.14.0.ebuild
new file mode 100644
index 000000000000..f6347568597c
--- /dev/null
+++ b/dev-python/uvicorn/uvicorn-0.14.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Lightning-fast ASGI server implementation"
+HOMEPAGE="https://www.uvicorn.org/"
+SRC_URI="https://github.com/encode/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/asgiref-3.3.4[${PYTHON_USEDEP}]
+ >=dev-python/click-7[${PYTHON_USEDEP}]
+ >=dev-python/h11-0.8[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/typing-extensions[${PYTHON_USEDEP}]' python3_7)
+"
+BDEPEND="
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/httpx[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ >=dev-python/websockets-9.1[${PYTHON_USEDEP}]
+ dev-python/wsproto[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # watchgod is not in the tree
+ sed -e '/^from uvicorn.supervisors.watchgodreload/d' \
+ -e 's/, WatchGodReload//' \
+ -i tests/supervisors/test_reload.py
+ distutils-r1_python_prepare_all
+}