summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-02-13 11:14:23 +0100
committerDavid Seifert <soap@gentoo.org>2021-02-13 11:14:23 +0100
commitfac36d02895ae022131a5f1e0d6fc69390e2ea1a (patch)
tree17c42f3763cec3b4af507db8d99614ec21287d08 /dev-python/xdoctest
parentdev-python/widgetsnbextension: Remove old (diff)
downloadgentoo-fac36d02895ae022131a5f1e0d6fc69390e2ea1a.tar.gz
gentoo-fac36d02895ae022131a5f1e0d6fc69390e2ea1a.tar.bz2
gentoo-fac36d02895ae022131a5f1e0d6fc69390e2ea1a.zip
dev-python/xdoctest: Remove old
Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/xdoctest')
-rw-r--r--dev-python/xdoctest/Manifest3
-rw-r--r--dev-python/xdoctest/xdoctest-0.15.0.ebuild40
-rw-r--r--dev-python/xdoctest/xdoctest-0.15.2.ebuild35
-rw-r--r--dev-python/xdoctest/xdoctest-0.15.3.ebuild37
4 files changed, 0 insertions, 115 deletions
diff --git a/dev-python/xdoctest/Manifest b/dev-python/xdoctest/Manifest
index c0d0eb64237e..df51feee3b3f 100644
--- a/dev-python/xdoctest/Manifest
+++ b/dev-python/xdoctest/Manifest
@@ -1,4 +1 @@
-DIST xdoctest-0.15.0.tar.gz 629125 BLAKE2B f5144365c4d1d58c107ac0603a1d99cd5bc622d3772fc7f2c907193ea863d9ff99bd183cc7fac12e2f85b7647ba25d5ae6878c06d3df9a5cdda9a1f143b43110 SHA512 114add93a75807d787c674b0649f92ff011987705f640912f876c4a4c3103cef90b0fae1959d5a85ef399b80695e9cbfcae6e809950ff5651fa211f54326682d
-DIST xdoctest-0.15.2.tar.gz 883332 BLAKE2B e90364d6096357ff1b5006b289a56a1afd0f3d0e952202d17a1b99c16f867e23ce0214a4f646154d9f6aada9f94ddda47a9c1f669a833bffaa63d99c10837766 SHA512 ca3bfc241e2d137988ee6dda2e9229f74add662fc2fe295c4c006a3d63ac6284f3f623451006acc4a8273729ccc589e1c5bab9d7fc65135582d7fc9fcffea464
-DIST xdoctest-0.15.3.gh.tar.gz 179880 BLAKE2B d35ccfaf4662c91d7b9a7191dc090721b963728312283af44c29614fe8af3d77434b192521bd29f760c7b53dd4e3dc708ccc7dc7c9ba294990a08441cbbda989 SHA512 b5e393246ef3c52481d48bbc9f91ddb0ffce24fd06c914d188f82ba9b7267727d9415fdd9a90f215c82e8bd76a4db2ab23aa99f473fe4901cc443d2196c9d3c9
DIST xdoctest-0.15.4.gh.tar.gz 179295 BLAKE2B 0b44276a219119196543671d8ac24469ecd73b040bbd03ca416320d407f0dd34361dbb2778121621f6efb65835ea421107883277b6e712f03e4c06ea2b03dd6a SHA512 a0a35d5c73a8696266d9be44d11e9dbf05c9ac1165a05e681f7b70ef07ae7d56f4bd179e863b6675e2366f1627015e92092e8250ca592f004680db5ad886ad49
diff --git a/dev-python/xdoctest/xdoctest-0.15.0.ebuild b/dev-python/xdoctest/xdoctest-0.15.0.ebuild
deleted file mode 100644
index 31a5c28a79e7..000000000000
--- a/dev-python/xdoctest/xdoctest-0.15.0.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-DESCRIPTION="A rewrite of Python's builtin doctest module but without all the weirdness"
-HOMEPAGE="https://github.com/Erotemic/xdoctest"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="Apache-2.0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs/source dev-python/sphinx_rtd_theme
-
-python_prepare_all() {
- # fails because the ebuild environment location is not the expected location
- sed -i -e 's:test_xdoc_console_script_location:_&:' \
- testing/test_entry_point.py || die
-
- # xdoctest has to be in PATH for this to work
- sed -i -e 's:test_xdoc_console_script_exec:_&:' \
- testing/test_entry_point.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- PYTHONPATH="${WORKDIR}/${P}"
- pytest -vv || die "Test fail with ${EPYTHON}"
-}
diff --git a/dev-python/xdoctest/xdoctest-0.15.2.ebuild b/dev-python/xdoctest/xdoctest-0.15.2.ebuild
deleted file mode 100644
index 74735ab8e849..000000000000
--- a/dev-python/xdoctest/xdoctest-0.15.2.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-DESCRIPTION="A rewrite of Python's builtin doctest module but without all the weirdness"
-HOMEPAGE="https://github.com/Erotemic/xdoctest"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="Apache-2.0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
-# dev-python/nbformat-5.1.{0..2} did not install package data
-BDEPEND="
- test? (
- || (
- >=dev-python/nbformat-5.1.2-r1[${PYTHON_USEDEP}]
- <dev-python/nbformat-5.1[${PYTHON_USEDEP}]
- )
- )"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs/source dev-python/sphinx_rtd_theme
-
-python_test() {
- local -x PYTHONPATH=.
- pytest -vv || die "Test fail with ${EPYTHON}"
-}
diff --git a/dev-python/xdoctest/xdoctest-0.15.3.ebuild b/dev-python/xdoctest/xdoctest-0.15.3.ebuild
deleted file mode 100644
index 8453e2c4d62f..000000000000
--- a/dev-python/xdoctest/xdoctest-0.15.3.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-DESCRIPTION="A rewrite of Python's builtin doctest module but without all the weirdness"
-HOMEPAGE="https://github.com/Erotemic/xdoctest/"
-SRC_URI="
- https://github.com/Erotemic/xdoctest/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz"
-
-SLOT="0"
-LICENSE="Apache-2.0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
-# dev-python/nbformat-5.1.{0..2} did not install package data
-BDEPEND="
- test? (
- || (
- >=dev-python/nbformat-5.1.2-r1[${PYTHON_USEDEP}]
- <dev-python/nbformat-5.1[${PYTHON_USEDEP}]
- )
- )"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs/source dev-python/sphinx_rtd_theme
-
-python_test() {
- local -x PYTHONPATH=.
- pytest -vv || die "Test fail with ${EPYTHON}"
-}