summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-18 15:04:40 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-18 16:03:43 +0200
commitb8bb26417129c90b6efe4834fb02755e1824a0ad (patch)
tree159488faeec266064c2e40202afcdb669b927b6a /dev-python/zope-hookable
parentdev-python/zope-i18nmessageid: Bump to 7.0 (diff)
downloadgentoo-b8bb26417129c90b6efe4834fb02755e1824a0ad.tar.gz
gentoo-b8bb26417129c90b6efe4834fb02755e1824a0ad.tar.bz2
gentoo-b8bb26417129c90b6efe4834fb02755e1824a0ad.zip
dev-python/zope-hookable: Bump to 7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/zope-hookable')
-rw-r--r--dev-python/zope-hookable/Manifest1
-rw-r--r--dev-python/zope-hookable/zope-hookable-7.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/zope-hookable/Manifest b/dev-python/zope-hookable/Manifest
index 6f399c4e3460..c04aa7de129d 100644
--- a/dev-python/zope-hookable/Manifest
+++ b/dev-python/zope-hookable/Manifest
@@ -1 +1,2 @@
DIST zope.hookable-6.0.tar.gz 24013 BLAKE2B 808005d0993e22967bc7a73a7b8a26f2263dfc9f3f33d840495a233ea8686a5e700ee46cf0dad8e37aeebb0383ec51b15a4f98323daf4d6bb606fc1ab149f39e SHA512 33d1200a24fc664ed9c7942f71b003704fda21ac42f5acc24611838aa4e8096a27a5da01956ec824105d454a0580480ce8a262c8f5c4f24782ab11416d9fdafd
+DIST zope_hookable-7.0.tar.gz 21392 BLAKE2B e6b2921f68be1f5156fede45db2a71e6394785bd5e0a4aff86a5cf943b790e0d26163391bd448739ad074e8b792b37334e48c05086268509d980035bac260066 SHA512 f927a0e15aef9adca72f25c21f2c374d6235d8e3abca9d5d9832e9c8d9b70accebfec2cac339ae360d142e69f69f920c7b2bdbbf230c975fe2c362887380a34d
diff --git a/dev-python/zope-hookable/zope-hookable-7.0.ebuild b/dev-python/zope-hookable/zope-hookable-7.0.ebuild
new file mode 100644
index 000000000000..3704c02ccd78
--- /dev/null
+++ b/dev-python/zope-hookable/zope-hookable-7.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYPI_PN=${PN/-/.}
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Efficient creation of 'hookable' objects"
+HOMEPAGE="
+ https://pypi.org/project/zope.hookable/
+ https://github.com/zopefoundation/zope.hookable/
+"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/zope-testing[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # strip rdep specific to namespaces
+ sed -i -e "/'setuptools'/d" setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ eunittest -s "${BUILD_DIR}/install$(python_get_sitedir)/zope/hookable/tests"
+}