summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-26 04:49:36 +0200
committerMichał Górny <mgorny@gentoo.org>2023-03-26 05:01:59 +0200
commit0f8e269bdcdf28cdb3c7341f21216b1d3f4f9111 (patch)
tree477762b0cf4fe1c87fb39eca79213a1c2b3bba46 /dev-python
parentdev-python/pikepdf: Bump to 7.1.2 (diff)
downloadgentoo-0f8e269bdcdf28cdb3c7341f21216b1d3f4f9111.tar.gz
gentoo-0f8e269bdcdf28cdb3c7341f21216b1d3f4f9111.tar.bz2
gentoo-0f8e269bdcdf28cdb3c7341f21216b1d3f4f9111.zip
dev-python/platformdirs: Bump to 3.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/platformdirs/Manifest1
-rw-r--r--dev-python/platformdirs/platformdirs-3.2.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/platformdirs/Manifest b/dev-python/platformdirs/Manifest
index 461a808cb35f..ce351d78b048 100644
--- a/dev-python/platformdirs/Manifest
+++ b/dev-python/platformdirs/Manifest
@@ -1 +1,2 @@
DIST platformdirs-3.1.1.tar.gz 14712 BLAKE2B ddb070cc3c572b03eaa356599d2a0e408f7f0a650378e60b4a7b4fcd740fb9117c73491451588b26d42a4db9b971dbc690f9ddae34ec03e42248120ff5e4e64e SHA512 537557370a05f78279c88cdda4b5abfbe1d2e6d91d69c4dd4049c6b1a8ac3e44a830d787e2b86af85c346e0244a6ba26233db061d7c8d0a3fbd141962609930d
+DIST platformdirs-3.2.0.tar.gz 15017 BLAKE2B ce9f180965e0736ae83170b3a055dbb58e2ce59b84a414cd212f0f2f27a6a0a194636d315a30e344046ee1da85f2de3d2e7c58c02a329c4a36129fa617d8feb6 SHA512 2e4613f563b7014b526e1f81f561726a0060983b0e998ce46d070b2f4f4ec26ad46d6a3cd242fb14a420e6439207b9c9eeb31daac7ec65005abc3a74131e5cf8
diff --git a/dev-python/platformdirs/platformdirs-3.2.0.ebuild b/dev-python/platformdirs/platformdirs-3.2.0.ebuild
new file mode 100644
index 000000000000..58e26b5de925
--- /dev/null
+++ b/dev-python/platformdirs/platformdirs-3.2.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A small Python module for determining appropriate platform-specific dirs"
+HOMEPAGE="
+ https://pypi.org/project/platformdirs/
+ https://github.com/platformdirs/platformdirs/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos ~x64-solaris"
+
+BDEPEND="
+ test? (
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ grep -q 'build-backend = "hatchling' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "${PN}"
+ version = "${PV}"
+ description = 'A small Python package for determining appropriate platform-specific dirs, e.g. a "user data dir".'
+ EOF
+ # sigh
+ cat > src/platformdirs/version.py <<-EOF || die
+ __version__ = version = '${PV}'
+ __version_tuple__ = version_tuple = (${PV//./, })
+ EOF
+}