summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-25 05:29:14 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-25 06:38:51 +0200
commit509e83b62e32bf489a19cc572624d55a7aaed7ab (patch)
tree84866da8b2ce10bb77d9379f76e9e641892d2ff2 /dev-python
parentdev-python/botocore: Bump to 1.35.26 (diff)
downloadgentoo-509e83b62e32bf489a19cc572624d55a7aaed7ab.tar.gz
gentoo-509e83b62e32bf489a19cc572624d55a7aaed7ab.tar.bz2
gentoo-509e83b62e32bf489a19cc572624d55a7aaed7ab.zip
dev-python/boto3: Bump to 1.35.26
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.35.26.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 5745048fcba5..409221fd52fe 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -2,3 +2,4 @@ DIST boto3-1.35.14.gh.tar.gz 859166 BLAKE2B eb201a319453097068b4711356ea930de739
DIST boto3-1.35.19.gh.tar.gz 861578 BLAKE2B 5011df66763e646768232a65022080ffbe3db08253f1bf3e192cf57be010ccdd08f8add78ec365e1c04d78ba1722cf6ef54fbc170f7f2419fcd370c08d48e3ce SHA512 faabd3ef8eb35a323ed64a711e0a026f8f77974516b05a93d389fb82b84932f69a2c784a1065811699dac4db016549f3756f24b879485b2dfb6ca380e6873670
DIST boto3-1.35.24.gh.tar.gz 864653 BLAKE2B e2327ae352d17f0cfabdcca6d7db07e0212ea740c66d8f36baf44d0617cdbfdcb018388fed1deeea37bef5e44edb360f2cb77b41085e7a3308f7d4045b0a4aa3 SHA512 e34b02cf141bd77d92a34dbef266e07f6d45d46aa924e3941dbe09a9562253f375b79a6a4f1e3df248d711341e00367a8519f816b2200353a6262de72a40fba0
DIST boto3-1.35.25.gh.tar.gz 865483 BLAKE2B 606bff8b084d3b0cd7d773cf840bd817861eed4a832c073f10e90bbfffcc7ca44b05d442131da4b4cc1696bca79e389bc00d78be1d3bc2b593ef3682bea182dd SHA512 71f732bf22ea76f9e364a3a57a1f9b2d7cdbeed28cc951a6a9930d3cfeaeb9086aece0627f34e8223ff100a7607bfd3ea8d97f5a19b504a95bcd4a14153c9878
+DIST boto3-1.35.26.gh.tar.gz 865822 BLAKE2B 72df9bc9f7324ad398ef91385fe5ba3ed0349e0d5f8dac6a0e529c7065d74ea4b2652017cae759005b8a332d9b3f868d78b3ca51df3ba172e3a9cef3d568359d SHA512 8f514e09f4e6f12974ac3b85cafd88e0648760d24245fa6ca382b9cd1283b2d03b7624e50bc05589e66bf3ab076ed53743da129746d2ecd7bf41c7114a91b4e5
diff --git a/dev-python/boto3/boto3-1.35.26.ebuild b/dev-python/boto3/boto3-1.35.26.ebuild
new file mode 100644
index 000000000000..8cba6d95740e
--- /dev/null
+++ b/dev-python/boto3/boto3-1.35.26.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/botocore-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}