summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2022-12-20 15:40:30 +0100
committerJakov Smolić <jsmolic@gentoo.org>2022-12-20 16:06:17 +0100
commit6fc044c77728dca9067551d7b8d84a81c1f5e730 (patch)
tree0005d1baa9a4a3caf4fe7300cfe7e30e544d8fc1 /dev-python
parentdev-python/requests_pkcs12: treeclean (diff)
downloadgentoo-6fc044c77728dca9067551d7b8d84a81c1f5e730.tar.gz
gentoo-6fc044c77728dca9067551d7b8d84a81c1f5e730.tar.bz2
gentoo-6fc044c77728dca9067551d7b8d84a81c1f5e730.zip
dev-python/pytest-salt: treeclean
Closes: https://bugs.gentoo.org/845837 Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pytest-salt/Manifest1
-rw-r--r--dev-python/pytest-salt/files/pytest-salt-2020.1.27-r2.patch14
-rw-r--r--dev-python/pytest-salt/metadata.xml11
-rw-r--r--dev-python/pytest-salt/pytest-salt-2020.1.27-r3.ebuild48
4 files changed, 0 insertions, 74 deletions
diff --git a/dev-python/pytest-salt/Manifest b/dev-python/pytest-salt/Manifest
deleted file mode 100644
index e03d478fdd39..000000000000
--- a/dev-python/pytest-salt/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST pytest-salt-2020.1.27.tar.gz 64141 BLAKE2B 2b9261af2de28f8dce1abcd71b586594075916c8a5dbb27a24f15b9d95a575624be118d1c742f02020d3b968ffa4654cf6cd0dabefffe6876b87a4d1d58c3d60 SHA512 b0632e21f1ea5c3b57eb681cd8b270721cafd270321b708fca65427fc89817ed9e9a4216a520f35988c6866b1ed76ed84838009da9052a11cf8782d4dcf118ba
diff --git a/dev-python/pytest-salt/files/pytest-salt-2020.1.27-r2.patch b/dev-python/pytest-salt/files/pytest-salt-2020.1.27-r2.patch
deleted file mode 100644
index 35dca262478b..000000000000
--- a/dev-python/pytest-salt/files/pytest-salt-2020.1.27-r2.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-Fixes a Doctestitem has no attribute 'fixturenames'
-Fix by David Denoncin based on https://github.com/saltstack/pytest-salt/issues/48
-
---- a/pytestsalt/fixtures/daemons.py 2021-03-02 15:19:40.500254583 +0100
-+++ b/pytestsalt/fixtures/daemons.py 2021-03-02 15:20:40.706920871 +0100
-@@ -1658,7 +1658,6 @@
- Fixtures injection based on markers
- '''
- for fixture in ('salt_master', 'salt_minion', 'salt_call', 'salt', 'salt_key', 'salt_run'):
-- if fixture in item.fixturenames:
-- after_start_fixture = '{}_after_start'.format(fixture)
-+ if fixture in getattr(item, 'fixturenames', ()):
- if after_start_fixture not in item.fixturenames:
- item.fixturenames.append(after_start_fixture)
diff --git a/dev-python/pytest-salt/metadata.xml b/dev-python/pytest-salt/metadata.xml
deleted file mode 100644
index 1c259ca3d683..000000000000
--- a/dev-python/pytest-salt/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>chutzpah@gentoo.org</email>
- <name>Patrick McLean</name>
- </maintainer>
- <upstream>
- <remote-id type="pypi">pytest-salt</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/pytest-salt/pytest-salt-2020.1.27-r3.ebuild b/dev-python/pytest-salt/pytest-salt-2020.1.27-r3.ebuild
deleted file mode 100644
index 3548c336d99d..000000000000
--- a/dev-python/pytest-salt/pytest-salt-2020.1.27-r3.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-inherit distutils-r1
-
-MY_PV="${PV/_p/.post}"
-DESCRIPTION="PyTest Salt Plugin"
-HOMEPAGE="https://github.com/saltstack/pytest-salt"
-SRC_URI="https://github.com/saltstack/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86"
-IUSE="test"
-
-# See bug #740882 re salt/tornado dependency
-RDEPEND="
- >=dev-python/pytest-2.8.1[${PYTHON_USEDEP}]
- >=dev-python/psutil-4.2.0[${PYTHON_USEDEP}]
- dev-python/pytest-helpers-namespace[${PYTHON_USEDEP}]
- dev-python/pytest-tempdir[${PYTHON_USEDEP}]
- dev-python/msgpack[${PYTHON_USEDEP}]
- || (
- app-admin/salt[${PYTHON_USEDEP}]
- dev-python/tornado[${PYTHON_USEDEP}]
- )
-"
-#BDEPEND="
-# test? ( app-admin/salt[${PYTHON_USEDEP}] )
-#"
-
-PATCHES=(
- "${FILESDIR}/${PN}-2020.1.27-r2.patch"
-)
-
-# Tests need network access
-RESTRICT="test"
-
-distutils_enable_tests pytest
-
-python_test() {
- distutils_install_for_testing
- pytest -vv || die "Tests failed with ${EPYTHON}"
-}