summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-20 07:50:11 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-20 09:07:09 +0100
commitd7d6f522147acedf7615b40cefa6c6f0ab7036e1 (patch)
treecbc6f9a79961c6029e1600d5c6c200dd92b987a5 /dev-python
parentdev-python/easy-thumbnails: Bump to 2.8.4 (diff)
downloadgentoo-d7d6f522147acedf7615b40cefa6c6f0ab7036e1.tar.gz
gentoo-d7d6f522147acedf7615b40cefa6c6f0ab7036e1.tar.bz2
gentoo-d7d6f522147acedf7615b40cefa6c6f0ab7036e1.zip
dev-python/python-socks: Bump to 2.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-socks/Manifest1
-rw-r--r--dev-python/python-socks/python-socks-2.1.1.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/python-socks/Manifest b/dev-python/python-socks/Manifest
index 090cccec82f9..b40774a02960 100644
--- a/dev-python/python-socks/Manifest
+++ b/dev-python/python-socks/Manifest
@@ -1,2 +1,3 @@
DIST python-socks-2.0.3.gh.tar.gz 40697 BLAKE2B c1e6f72763d1bd767af78ea1188e411814a6d41f703488dd67165d5a9b9ce1e2f9070b35a46cd72859b65c10519cdb02c91d1702a97c2d82cb5891b46187d02a SHA512 9d51e61d03b4a46e94a66fc037ac759715db2e2c5d631aaf6088a0363ad13140c00da44a513088a40c0f149b9d4ee2bb4165f59f76c3956f0aede8104772fc5d
DIST python-socks-2.1.0.gh.tar.gz 31251 BLAKE2B b32b35c746066c10fa1e52677e42058e6196eb1c19cfc120a670e86daf8f920a4d6be3d1d92f984b68d635496da992b33f196277a1b22b254fe045988a15d2f1 SHA512 66da2da1d8103570e44d0a2ace03c24695b7319c562d7f96242c713b9d03ea693a2ece3cf6869cea686c330a9fb05aa35a443bad5a638d843b4fc7b24a8e6a82
+DIST python-socks-2.1.1.gh.tar.gz 31306 BLAKE2B f42f88089b0438722b076bcbbbe194b6ed621dec34f850861d791418ff453e6f97aa4e2f2ccf69024c5c562f7d1c8e1110e9930360252556bc77dd44b9a20fc0 SHA512 d68c5d0b0975283a8a86f701db5a8037beb9368edef591876abba2524593114fdcc933fa3dc5eca8123afcc6fc0eb3eacfbbf40e54acb87e973fc7b49ed3c8dc
diff --git a/dev-python/python-socks/python-socks-2.1.1.ebuild b/dev-python/python-socks/python-socks-2.1.1.ebuild
new file mode 100644
index 000000000000..ead55902eb67
--- /dev/null
+++ b/dev-python/python-socks/python-socks-2.1.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="SOCKS4, SOCKS5, HTTP tunneling functionality for Python"
+HOMEPAGE="
+ https://github.com/romis2012/python-socks/
+ https://pypi.org/project/python-socks/
+"
+SRC_URI="
+ https://github.com/romis2012/python-socks/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# curio is not packaged
+# asyncio is the only backend we have, so dep on its deps unconditionally
+# TODO: revisit
+RDEPEND="
+ dev-python/async-timeout[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/anyio-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/async-timeout-3.0.1[${PYTHON_USEDEP}]
+ >=dev-python/flask-1.1.2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.18.3[${PYTHON_USEDEP}]
+ >=dev-python/pytest-trio-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/tiny-proxy-0.1.1[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.16.0[${PYTHON_USEDEP}]
+ >=dev-python/trustme-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/yarl-1.4.2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest