summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-09-27 03:08:40 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-09-27 03:25:49 -0400
commit47090c7bb644d25a0c97c7d17747b960f0211fb6 (patch)
tree7d816ad0eafe9a8ae11c5603ed18ed5ab2b3e19f /dev-qt/qtmultimedia
parentdev-qt/qtlocation: add 6.7.3 (diff)
downloadgentoo-47090c7bb644d25a0c97c7d17747b960f0211fb6.tar.gz
gentoo-47090c7bb644d25a0c97c7d17747b960f0211fb6.tar.bz2
gentoo-47090c7bb644d25a0c97c7d17747b960f0211fb6.zip
dev-qt/qtmultimedia: add 6.7.3
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt/qtmultimedia')
-rw-r--r--dev-qt/qtmultimedia/Manifest1
-rw-r--r--dev-qt/qtmultimedia/qtmultimedia-6.7.3.ebuild133
2 files changed, 134 insertions, 0 deletions
diff --git a/dev-qt/qtmultimedia/Manifest b/dev-qt/qtmultimedia/Manifest
index 02ae09a38678..40fe7636e82a 100644
--- a/dev-qt/qtmultimedia/Manifest
+++ b/dev-qt/qtmultimedia/Manifest
@@ -1,4 +1,5 @@
DIST qtmultimedia-5.15.14-gentoo-kde-1.tar.xz 1492 BLAKE2B e2474990d9efc327f35a979c1f317cb213c6121b4e1285294c132a1266eaeb559e7239c7cd58da072e50dc85dd9aa0c1b6aa493f95fe31268171780cd3346883 SHA512 5427c7a5e06f8296b091b2bb3fc67e678ac01bd1179de5a11c38cfe9f87ba8e3ac87a1395c2c3044ad31fc5c040230e35a1e71e173e12109c24cd97da70d9e9d
DIST qtmultimedia-everywhere-opensource-src-5.15.14.tar.xz 3842164 BLAKE2B 0065c95b4f14e566c667e16c4eb264e466174a9548c6a4bd39dbab9cf14ddad444cc3318ecdf18ca9e3999a3f95a669fd121937287d466a6b9a9c14af74ff686 SHA512 6059bd9aec65888ed6f3a1f87506a94ea567f9e064bb4a586859bc8f76ee4dca573eb256623452ddd9daf2305f49c707673425ea08edca9cd2db7b56bf5cab9c
DIST qtmultimedia-everywhere-src-6.7.2.tar.xz 8451800 BLAKE2B 44523ebe4f1b0c910fdad8ff29f24273c1b7872e9f5dd58b2dd779e61fe3b5c1a97ee900009ca693c740a6e578f9dd62995ac101ef70e1cd718af1bd1c355430 SHA512 bfcd04a5ba142e2a3bee3b67a261ffb4f651ac4e043e3dcafc0175bd25409de375041aa6fdda4f6899b00e4bad6c06ae9fd0d6a1e7db0b874f1bcf0a578d3c70
+DIST qtmultimedia-everywhere-src-6.7.3.tar.xz 9360356 BLAKE2B c3ba0c1729b412022959900d4ee7b31f92df5c1b03326ffaea974a59a217be8f39cacf62e03374d63e1d804798ac1bfcfda011a42047ebaa53f5dc1511a44f06 SHA512 6c8c7c18ad71e32507af57456d1c11544f3e6c67c9cd3811a83fd0c20e12d6457ab294d91905e3911bdef1977ec1b535de82e9d92b2a38bd9eef7851e6349b5a
DIST qtmultimedia-everywhere-src-6.8.0-rc.tar.xz 9596792 BLAKE2B 0961eb1acb796311eb9120c69913276e00e3ce335174439d07aff92ca5b5ad2c3decf0f5254080e52a4a4952397798f204a4c8c7c0b9930f91faac4ca0ad834d SHA512 9abc28f994c8d4922eb726fb87c64f079d59bb3b698e3dd9470909b9a03e24a54c89ccd64f946218f0bd915d7a0086e3ebd21e16d6e00380180a475d1015589a
diff --git a/dev-qt/qtmultimedia/qtmultimedia-6.7.3.ebuild b/dev-qt/qtmultimedia/qtmultimedia-6.7.3.ebuild
new file mode 100644
index 000000000000..2921a408326e
--- /dev/null
+++ b/dev-qt/qtmultimedia/qtmultimedia-6.7.3.ebuild
@@ -0,0 +1,133 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic qt6-build
+
+DESCRIPTION="Multimedia (audio, video, radio, camera) library for the Qt6 framework"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~x86"
+fi
+
+IUSE="
+ +X alsa eglfs +ffmpeg gstreamer opengl pulseaudio
+ qml v4l vaapi vulkan wayland
+"
+# tst_qmediaplayerbackend hard requires qml, review in case becomes optional
+REQUIRED_USE="
+ || ( ffmpeg gstreamer )
+ eglfs? ( ffmpeg opengl qml )
+ test? ( qml )
+ vaapi? ( ffmpeg opengl )
+"
+
+# gstreamer[X=] is to avoid broken gst detect if -X w/ gst[X] w/o xorg-proto
+# (*could* be removed if gst-plugins-base[X] RDEPENDs on xorg-proto)
+RDEPEND="
+ ~dev-qt/qtbase-${PV}:6[gui,network,opengl=,vulkan=,widgets]
+ alsa? (
+ !pulseaudio? ( media-libs/alsa-lib )
+ )
+ ffmpeg? (
+ ~dev-qt/qtbase-${PV}:6[X=,concurrent,eglfs=]
+ media-video/ffmpeg:=[vaapi?]
+ X? (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrandr
+ )
+ )
+ gstreamer? (
+ dev-libs/glib:2
+ media-libs/gst-plugins-bad:1.0
+ media-libs/gst-plugins-base:1.0[X=]
+ media-libs/gstreamer:1.0
+ opengl? (
+ ~dev-qt/qtbase-${PV}:6[X?,wayland?]
+ media-libs/gst-plugins-base:1.0[X?,egl,opengl,wayland?]
+ )
+ )
+ opengl? ( media-libs/libglvnd )
+ pulseaudio? ( media-libs/libpulse )
+ qml? (
+ ~dev-qt/qtdeclarative-${PV}:6
+ ~dev-qt/qtquick3d-${PV}:6
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ X? ( x11-base/xorg-proto )
+ v4l? ( sys-kernel/linux-headers )
+ vulkan? ( dev-util/vulkan-headers )
+"
+BDEPEND="~dev-qt/qtshadertools-${PV}:6"
+
+CMAKE_SKIP_TESTS=(
+ # unimportant and expects all backends to be available (bug #928420)
+ tst_backends
+ # tries to use real alsa or pulseaudio and fails in sandbox
+ tst_qaudiosink
+ tst_qaudiosource
+ tst_qmediacapture_gstreamer
+ tst_qmediacapturesession
+ tst_qmediaplayerbackend
+ tst_qsoundeffect
+ # may try to use v4l2 or hardware acceleration depending on availability
+ tst_qscreencapture_integration
+ tst_qscreencapturebackend
+ tst_qvideoframebackend
+ # fails with offscreen rendering
+ tst_qvideoframecolormanagement
+ tst_qwindowcapturebackend
+)
+
+src_configure() {
+ # normally passed by the build system, but needed for 32-on-64 chroots
+ use x86 && append-cppflags -DPFFFT_SIMD_DISABLE
+
+ local mycmakeargs=(
+ $(cmake_use_find_package qml Qt6Qml)
+ $(qt_feature ffmpeg)
+ $(qt_feature gstreamer)
+ $(usev gstreamer "
+ $(qt_feature opengl gstreamer_gl)
+ $(usev opengl "
+ $(qt_feature X gstreamer_gl_x11)
+ $(qt_feature wayland gstreamer_gl_wayland)
+ ")
+ ")
+ $(qt_feature pulseaudio)
+ $(qt_feature v4l linux_v4l)
+ $(qt_feature vaapi)
+ )
+
+ # ALSA backend is experimental off-by-default and can take priority
+ # causing problems (bug #935146), disable if USE=pulseaudio is set
+ # (also do not want unnecessary usage of ALSA plugins -> pulse)
+ if use alsa && use pulseaudio; then
+ # einfo should be enough given pure-ALSA users tend to disable pulse
+ einfo "Warning: USE=alsa is ignored when USE=pulseaudio is set"
+ mycmakeargs+=( -DQT_FEATURE_alsa=OFF )
+ else
+ mycmakeargs+=( $(qt_feature alsa) )
+ fi
+
+ qt6-build_src_configure
+}
+
+src_install() {
+ qt6-build_src_install
+
+ if use test; then
+ local delete=( # sigh
+ "${D}${QT6_LIBDIR}"/cmake/Qt6Multimedia/Qt6MockMultimediaPlugin*.cmake
+ "${D}${QT6_MKSPECSDIR}"/modules/qt_plugin_mockmultimediaplugin.pri
+ "${D}${QT6_PLUGINDIR}"/multimedia/libmockmultimediaplugin.*
+ "${D}${QT6_PLUGINDIR}"/multimedia/objects-*
+ )
+ # using -f given not tracking which tests may be skipped or not
+ rm -rf -- "${delete[@]}" || die
+ fi
+}