summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2023-03-19 13:26:46 +0200
committerJimi Huotari <chiitoo@gentoo.org>2023-03-19 15:06:40 +0200
commit313080689f04514eb810a0001e5d7ff0cc4da0c4 (patch)
treec451a934add098af67d2347d67a549ff4aee4a0d /dev-qt/qtquick3d
parentdev-qt/qtpositioning: add 6.4.3 (diff)
downloadgentoo-313080689f04514eb810a0001e5d7ff0cc4da0c4.tar.gz
gentoo-313080689f04514eb810a0001e5d7ff0cc4da0c4.tar.bz2
gentoo-313080689f04514eb810a0001e5d7ff0cc4da0c4.zip
dev-qt/qtquick3d: add 6.4.3
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Diffstat (limited to 'dev-qt/qtquick3d')
-rw-r--r--dev-qt/qtquick3d/Manifest1
-rw-r--r--dev-qt/qtquick3d/qtquick3d-6.4.3.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-qt/qtquick3d/Manifest b/dev-qt/qtquick3d/Manifest
index 1e9df6318687..2c5b35cf545d 100644
--- a/dev-qt/qtquick3d/Manifest
+++ b/dev-qt/qtquick3d/Manifest
@@ -1 +1,2 @@
DIST qtquick3d-everywhere-src-6.4.2.tar.xz 42804964 BLAKE2B 6634b27675468887bb0f91e48405eb4dcf063f5f64848ce23af1c64a89a2a853666a9627c1f41dc5fad38916600fbefde3ca5fce1268ae6d6c1bf157709cc63d SHA512 286606571f45a0464a57893880f805a2510ebea9a3cfb92e5225eeb3f9435b2c4d4919ce53c45dcea6ed8f7a9e84dd4afa0a5f631dbc26b3723da637260bb6af
+DIST qtquick3d-everywhere-src-6.4.3.tar.xz 44048520 BLAKE2B 1c93fe90c071323ccc77f18893d669c1abf63edaec442f710c61f358ed2440c8f4c54f037ceab232ce2cd6d3f1bc6f10748e8bf99634b422ce3d1b6aaa2e3ef0 SHA512 511c8585ea8686b1e1cf2e3dd47ac5650ba312d583da7e86dc86aaff6769a5751e3d75ff3fd07664098ba6488f75c9dab68d060b0394ad0182c35c44b5306970
diff --git a/dev-qt/qtquick3d/qtquick3d-6.4.3.ebuild b/dev-qt/qtquick3d/qtquick3d-6.4.3.ebuild
new file mode 100644
index 000000000000..92a82e63dc8d
--- /dev/null
+++ b/dev-qt/qtquick3d/qtquick3d-6.4.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="Qt module and API for defining 3D content in Qt QuickTools"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64"
+elif [[ ${QT6_BUILD_TYPE} == live ]]; then
+ # Don't clone qtquick3d-assimp.
+ EGIT_SUBMODULES=()
+fi
+
+DEPEND="
+ =dev-qt/qtbase-${PV}*[concurrent,network,widgets]
+ =dev-qt/qtdeclarative-${PV}*
+ =dev-qt/qtshadertools-${PV}*
+ =dev-qt/qtquicktimeline-${PV}*
+ media-libs/assimp:=
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DQT_FEATURE_system_assimp=ON
+ )
+
+ qt6-build_src_configure
+}