summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-05-09 10:18:51 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-05-09 10:18:51 +0200
commitafd35d48cef2832a1e5db5169d3d0d84d1345a62 (patch)
treee4e8b2bbc796f97a60c8a21b947c14dcc072755d /dev-qt/qtwayland
parentnet-misc/httpie: x86 stable wrt bug #721524 (diff)
downloadgentoo-afd35d48cef2832a1e5db5169d3d0d84d1345a62.tar.gz
gentoo-afd35d48cef2832a1e5db5169d3d0d84d1345a62.tar.bz2
gentoo-afd35d48cef2832a1e5db5169d3d0d84d1345a62.zip
dev-qt: Drop Qt 5.13.2
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/qtwayland')
-rw-r--r--dev-qt/qtwayland/Manifest1
-rw-r--r--dev-qt/qtwayland/files/qtwayland-5.13.2-fix-crash.patch55
-rw-r--r--dev-qt/qtwayland/files/qtwayland-5.13.2-fix-linuxdmabuf-build.patch29
-rw-r--r--dev-qt/qtwayland/files/qtwayland-5.13.2-fix-touch-ignored.patch36
-rw-r--r--dev-qt/qtwayland/metadata.xml1
-rw-r--r--dev-qt/qtwayland/qtwayland-5.13.2-r1.ebuild50
6 files changed, 0 insertions, 172 deletions
diff --git a/dev-qt/qtwayland/Manifest b/dev-qt/qtwayland/Manifest
index 112eeb88432b..fdfc49103e9c 100644
--- a/dev-qt/qtwayland/Manifest
+++ b/dev-qt/qtwayland/Manifest
@@ -1,3 +1,2 @@
-DIST qtwayland-everywhere-src-5.13.2.tar.xz 495536 BLAKE2B eb4352d76caba9ff1d217950b8be40edee1b963a085ca129938ade0d3a68569856bc1a745951d3731c81182b341704568a5036551693cad5926a239587dd506b SHA512 5eb895c2ef8e2e72b71fed027f760913bf754da213e488a6103d9034170a6333f034b3488115a87a5a4e90761425487b9a8ab8e84a68e2e614c159d747408d53
DIST qtwayland-everywhere-src-5.14.1.tar.xz 544744 BLAKE2B cc74e6ac4519484713795169a91f18ed2535684bf604d12ab900a0fb2502d30c1fa4fbdc5899c4a32505e8f4b2be142d3b16540b6797c1624deac097d45ea41d SHA512 6cdfb527ce8160b562343bfb3959dfcd8ccc91a50817756547f4a0559b77372bee7587bc2e4e658e15b58ecb52c6eb0ef2193e30a285d13c4192bb03a1149cfc
DIST qtwayland-everywhere-src-5.14.2.tar.xz 544532 BLAKE2B 13cf07116737ec2fd301f51f517cbc062fdd42b800d6d2739193f3570f1a9552e66e9909de15c22cc530d5284c3be9ff24915ce4b36f529ec6c22faeb0edff58 SHA512 0f396cabace17f099c2f2c0be54317006dc00c5f4be08cd79a4fa4fdc94362f63cc6ce9decc7feb63f566dd2ea52d562257e4bb23332557054418fc16dc7e899
diff --git a/dev-qt/qtwayland/files/qtwayland-5.13.2-fix-crash.patch b/dev-qt/qtwayland/files/qtwayland-5.13.2-fix-crash.patch
deleted file mode 100644
index b4e78684bb61..000000000000
--- a/dev-qt/qtwayland/files/qtwayland-5.13.2-fix-crash.patch
+++ /dev/null
@@ -1,55 +0,0 @@
-From 962b9be7992cef672cb6307af5653c97382c334f Mon Sep 17 00:00:00 2001
-From: Johan Klokkhammer Helsing <johan.helsing@qt.io>
-Date: Fri, 1 Nov 2019 11:24:26 +0100
-Subject: [PATCH] Client: Fix crash when showing a child window with a hidden
- parent
-
-[ChangeLog][QPA plugin] Fixed a crash when showing a window with a hidden
-parent.
-
-Now we just avoid creating the subsurface, so nothing is shown. Seems to be
-the same behavior as on xcb.
-
-Fixes: QTBUG-79674
-Change-Id: Ia46fcd9a0da5aad4704816a41515cb1e128ac65f
-Reviewed-by: Paul Olav Tvete <paul.tvete@qt.io>
----
- src/client/qwaylanddisplay.cpp | 4 ++++
- src/client/qwaylandwindow.cpp | 7 ++++---
- 2 files changed, 8 insertions(+), 3 deletions(-)
-
-diff --git a/src/client/qwaylanddisplay.cpp b/src/client/qwaylanddisplay.cpp
-index 78524f6fc..27e38ccf7 100644
---- a/src/client/qwaylanddisplay.cpp
-+++ b/src/client/qwaylanddisplay.cpp
-@@ -109,6 +109,10 @@ struct ::wl_region *QWaylandDisplay::createRegion(const QRegion &qregion)
- return nullptr;
- }
-
-+ // Make sure we don't pass NULL surfaces to libwayland (crashes)
-+ Q_ASSERT(parent->object());
-+ Q_ASSERT(window->object());
-+
- return mSubCompositor->get_subsurface(window->object(), parent->object());
- }
-
-diff --git a/src/client/qwaylandwindow.cpp b/src/client/qwaylandwindow.cpp
-index 8d34afd1f..7098568b4 100644
---- a/src/client/qwaylandwindow.cpp
-+++ b/src/client/qwaylandwindow.cpp
-@@ -124,9 +124,10 @@ void QWaylandWindow::initWindow()
- if (shouldCreateSubSurface()) {
- Q_ASSERT(!mSubSurfaceWindow);
-
-- QWaylandWindow *p = static_cast<QWaylandWindow *>(QPlatformWindow::parent());
-- if (::wl_subsurface *ss = mDisplay->createSubSurface(this, p)) {
-- mSubSurfaceWindow = new QWaylandSubSurface(this, p, ss);
-+ auto *parent = static_cast<QWaylandWindow *>(QPlatformWindow::parent());
-+ if (parent->object()) {
-+ if (::wl_subsurface *subsurface = mDisplay->createSubSurface(this, parent))
-+ mSubSurfaceWindow = new QWaylandSubSurface(this, parent, subsurface);
- }
- } else if (shouldCreateShellSurface()) {
- Q_ASSERT(!mShellSurface);
---
-2.16.3
diff --git a/dev-qt/qtwayland/files/qtwayland-5.13.2-fix-linuxdmabuf-build.patch b/dev-qt/qtwayland/files/qtwayland-5.13.2-fix-linuxdmabuf-build.patch
deleted file mode 100644
index f9b6b6571182..000000000000
--- a/dev-qt/qtwayland/files/qtwayland-5.13.2-fix-linuxdmabuf-build.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From 23ea5504200ff5f7e40bd264280a78db09c1bc5b Mon Sep 17 00:00:00 2001
-From: Johan Klokkhammer Helsing <johan.helsing@qt.io>
-Date: Fri, 8 Nov 2019 13:58:04 +0100
-Subject: [PATCH] WIP: Fix compilation of linuxdmabuf compositor plugin
-
-WIP, because I'm not sure if this is the way to go, but it fixes
-compilation on my machine.
-
-Fixes: QTBUG-79709
-Change-Id: I3190ef56e0e162636efea440dff7e760cf11fcd0
----
- .../compositor/linux-dmabuf-unstable-v1/linuxdmabuf.h | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/src/hardwareintegration/compositor/linux-dmabuf-unstable-v1/linuxdmabuf.h b/src/hardwareintegration/compositor/linux-dmabuf-unstable-v1/linuxdmabuf.h
-index 2abc2ce6b..d1f4a3039 100644
---- a/src/hardwareintegration/compositor/linux-dmabuf-unstable-v1/linuxdmabuf.h
-+++ b/src/hardwareintegration/compositor/linux-dmabuf-unstable-v1/linuxdmabuf.h
-@@ -53,6 +53,7 @@
-
- #include <EGL/egl.h>
- #include <EGL/eglext.h>
-+#include <EGL/eglmesaext.h>
-
- // compatibility with libdrm <= 2.4.74
- #ifndef DRM_FORMAT_RESERVED
---
-2.16.3
-
diff --git a/dev-qt/qtwayland/files/qtwayland-5.13.2-fix-touch-ignored.patch b/dev-qt/qtwayland/files/qtwayland-5.13.2-fix-touch-ignored.patch
deleted file mode 100644
index 4a33d97bf17e..000000000000
--- a/dev-qt/qtwayland/files/qtwayland-5.13.2-fix-touch-ignored.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From 57c28f461a066c03ef8ae3f823c040fa91876fb8 Mon Sep 17 00:00:00 2001
-From: Johan Klokkhammer Helsing <johan.helsing@qt.io>
-Date: Mon, 4 Nov 2019 14:21:18 +0100
-Subject: [PATCH] Fix touch being ignored when down and motion are in the same
- frame
-
-The Wayland protocol gives no guarantees about which events are part of a
-frame, so handle the case where we receive wl_touch.down and wl_touch.motion
-within the same frame.
-
-Fixes: QTBUG-79744
-Change-Id: I5dd9302576d81da38e003c8e7e74da6a98def603
-Reviewed-by: Paul Olav Tvete <paul.tvete@qt.io>
----
- src/client/qwaylandinputdevice.cpp | 5 ++++-
- 1 file changed, 4 insertions(+), 1 deletion(-)
-
-diff --git a/src/client/qwaylandinputdevice.cpp b/src/client/qwaylandinputdevice.cpp
-index 8f3df8e4d..193ce714b 100644
---- a/src/client/qwaylandinputdevice.cpp
-+++ b/src/client/qwaylandinputdevice.cpp
-@@ -1062,7 +1062,10 @@ void QWaylandInputDevice::handleTouchPoint(int id, Qt::TouchPointState state, co
- tp.area.moveCenter(globalPosition);
- }
-
-- tp.state = state;
-+ // If the touch point was pressed earlier this frame, we don't want to overwrite its state.
-+ if (tp.state != Qt::TouchPointPressed)
-+ tp.state = state;
-+
- tp.pressure = tp.state == Qt::TouchPointReleased ? 0 : 1;
- }
-
---
-2.16.3
-
diff --git a/dev-qt/qtwayland/metadata.xml b/dev-qt/qtwayland/metadata.xml
index db7a41ae479b..85cb4f0e4bfa 100644
--- a/dev-qt/qtwayland/metadata.xml
+++ b/dev-qt/qtwayland/metadata.xml
@@ -6,7 +6,6 @@
<name>Gentoo Qt Project</name>
</maintainer>
<use>
- <flag name="libinput">Enable support for input devices via <pkg>dev-libs/libinput</pkg></flag>
<flag name="vulkan">Enable support for Vulkan-based server buffer integration</flag>
</use>
<upstream>
diff --git a/dev-qt/qtwayland/qtwayland-5.13.2-r1.ebuild b/dev-qt/qtwayland/qtwayland-5.13.2-r1.ebuild
deleted file mode 100644
index c7be17907c21..000000000000
--- a/dev-qt/qtwayland/qtwayland-5.13.2-r1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit qt5-build
-
-DESCRIPTION="Wayland platform plugin for Qt"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="arm"
-fi
-
-IUSE="+libinput xcomposite"
-
-DEPEND="
- >=dev-libs/wayland-1.6.0
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtdeclarative-${PV}
- ~dev-qt/qtgui-${PV}[egl,libinput=]
- media-libs/mesa[egl]
- >=x11-libs/libxkbcommon-0.2.0
- xcomposite? (
- x11-libs/libX11
- x11-libs/libXcomposite
- )
-"
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- "${FILESDIR}/${P}-fix-touch-ignored.patch" # QTBUG-79744
- "${FILESDIR}/${P}-fix-crash.patch" # QTBUG-79674
- # Pending upstream:
- "${FILESDIR}/${P}-fix-linuxdmabuf-build.patch" # bug 699190, QTBUG-79709
-)
-
-src_prepare() {
- qt_use_disable_config libinput xkbcommon-evdev \
- src/client/client.pro \
- src/compositor/wayland_wrapper/wayland_wrapper.pri \
- src/plugins/shellintegration/ivi-shell/ivi-shell.pro \
- src/plugins/shellintegration/wl-shell/wl-shell.pro \
- src/plugins/shellintegration/xdg-shell/xdg-shell.pro \
- src/plugins/shellintegration/xdg-shell-v5/xdg-shell-v5.pro \
- src/plugins/shellintegration/xdg-shell-v6/xdg-shell-v6.pro \
- tests/auto/compositor/compositor/compositor.pro
-
- use xcomposite || rm -r config.tests/xcomposite || die
-
- qt5-build_src_prepare
-}