summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-01-08 22:16:35 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-01-08 22:44:54 +0100
commit6b6ac7137bcf0472d00bc94a3add06b25f94a230 (patch)
tree951497b43e687fd0b9342ca4f2db414e2e641be4 /dev-qt
parentdev-qt/qtplugininfo: 5.15.8 version bump (diff)
downloadgentoo-6b6ac7137bcf0472d00bc94a3add06b25f94a230.tar.gz
gentoo-6b6ac7137bcf0472d00bc94a3add06b25f94a230.tar.bz2
gentoo-6b6ac7137bcf0472d00bc94a3add06b25f94a230.zip
dev-qt/qtpositioning: 5.15.8 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtpositioning/Manifest1
-rw-r--r--dev-qt/qtpositioning/qtpositioning-5.15.8.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-qt/qtpositioning/Manifest b/dev-qt/qtpositioning/Manifest
index 1ca41c5190f0..b2f7b51eee2a 100644
--- a/dev-qt/qtpositioning/Manifest
+++ b/dev-qt/qtpositioning/Manifest
@@ -1,3 +1,4 @@
DIST qtlocation-everywhere-opensource-src-5.15.7.tar.xz 6559220 BLAKE2B 635be1ec133a6dd7dbf071922090b6acfe4c02503275ac2539cd4e099dc518ac43654be54e5fa17d292fcdb9edf88a11a1eeec7e37faa752deb6671bef86abba SHA512 fc4579b14f7f4836ef550d80b867c2655f52da34b0637dce4d83b10f2f7a836530a8f2a6b0f1a41c38e5e391c5d8e2431818e9813fd9d597f67704fcfbfb2f7e
+DIST qtlocation-everywhere-opensource-src-5.15.8.tar.xz 6559180 BLAKE2B 1b8feb5da8d564a6605d9106ec6399aea23a4f0b43f495baf61e14266e90d2d73cd310fb6d8514730867acba1aa26efb3072c213f22f19f72c2f554d76ab281b SHA512 a337fade917150c13fa2ea22ad1949f41541cea4ceb1f732ab53c20c2f19a63dcfc6f9f544ca64fdb5703d3ac8d2ec6e832f1f199a32e73a2f6c51febf53f514
DIST qtpositioning-everywhere-src-6.4.0.tar.xz 1491860 BLAKE2B 07d9ed3a62ea8b91931749fe5064e3556cc5a6de2d38f428a99a4112c726e16ae01a70a769e353110e74287fb1a5d6090dc011e407b5dc2deeda8e0a7fd2a619 SHA512 298c484ed3e5f4d11c0e865005f8c0ddf422c8bbe9ff725fe01a8960403c55cfbc96ded62e77af4b14e549349501b7555f169e7a4b99435cecfc4b57b5a2b5cb
DIST qtpositioning-everywhere-src-6.4.2.tar.xz 1493780 BLAKE2B c3b287cea7c41e77228daffca45fa590abe7b242c02107ec5c2884fa95777c5d8a21cec26bcda9c5ef42b2b9eb5ce014a3ad9116269843499c4e107f65e7fd51 SHA512 3f45416c10b437572167374cf1450d8ff138f16028e2f338ea4458de4cd05ba71b7de286f7ffacd8b1808ee78b41afb975cb168a0d27077c981dc1bef1e4d412
diff --git a/dev-qt/qtpositioning/qtpositioning-5.15.8.ebuild b/dev-qt/qtpositioning/qtpositioning-5.15.8.ebuild
new file mode 100644
index 000000000000..6718de2a8736
--- /dev/null
+++ b/dev-qt/qtpositioning/qtpositioning-5.15.8.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+QT5_MODULE="qtlocation"
+inherit qt5-build
+
+DESCRIPTION="Physical position determination library for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+IUSE="geoclue +qml"
+
+RDEPEND="
+ =dev-qt/qtcore-${QT5_PV}*
+ geoclue? ( =dev-qt/qtdbus-${QT5_PV}* )
+ qml? ( =dev-qt/qtdeclarative-${QT5_PV}* )
+"
+DEPEND="${RDEPEND}"
+PDEPEND="
+ geoclue? ( app-misc/geoclue:2.0 )
+"
+
+QT5_TARGET_SUBDIRS=(
+ src/3rdparty/clipper
+ src/3rdparty/poly2tri
+ src/3rdparty/clip2tri
+ src/positioning
+ src/plugins/position/positionpoll
+)
+
+pkg_setup() {
+ use geoclue && QT5_TARGET_SUBDIRS+=( src/plugins/position/geoclue2 )
+ use qml && QT5_TARGET_SUBDIRS+=(
+ src/positioningquick
+ src/imports/positioning
+ )
+}