summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2025-01-31 02:52:24 -0500
committerIonen Wolkens <ionen@gentoo.org>2025-01-31 03:19:51 -0500
commit83edc0efdb4f5b48260881a1c33ba6cd0be6bb67 (patch)
tree98540196eeb07cd4284d2659933937a770228f17 /dev-qt
parentdev-qt/qtremoteobjects: add 6.8.2 (diff)
downloadgentoo-83edc0efdb4f5b48260881a1c33ba6cd0be6bb67.tar.gz
gentoo-83edc0efdb4f5b48260881a1c33ba6cd0be6bb67.tar.bz2
gentoo-83edc0efdb4f5b48260881a1c33ba6cd0be6bb67.zip
dev-qt/qtscxml: add 6.8.2
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtscxml/Manifest1
-rw-r--r--dev-qt/qtscxml/qtscxml-6.8.2.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-qt/qtscxml/Manifest b/dev-qt/qtscxml/Manifest
index e755ee39d3e1..74d62add46ca 100644
--- a/dev-qt/qtscxml/Manifest
+++ b/dev-qt/qtscxml/Manifest
@@ -1,2 +1,3 @@
DIST qtscxml-everywhere-opensource-src-5.15.16.tar.xz 429268 BLAKE2B 3d3b41eab16da426b8071fe5b95a53469965bbaf056530cef0732d248394c4a889055094ef1716b0d1d7291d4fe986ed159ea7fc06ae9282f36630680d305f01 SHA512 fbfb054e07767975fc44a41cc015fd12aa15cec5abda1fd3f01425eaa1fd191c529f49dd5a97b6bdf9b83e841d069e1b3190f35d396c0ea5e44d5df66337102d
DIST qtscxml-everywhere-src-6.8.1.tar.xz 558424 BLAKE2B 7b0c27288678844d85676f0c8e4126b268f8b94ed229fd1e86282cfe26b4d700c7d89cacaefb17f91c4caec28a32cb4deb002ac129831c85fd3175387a7d5b88 SHA512 294d830569f05450a57fd30741707f7c6d42d07ad9ae03840e41c1382f72f8d3408d9cc1ba16145ede51f5ca510cef87b0ca298991c7697a7c2b58b0db8f8f29
+DIST qtscxml-everywhere-src-6.8.2.tar.xz 558848 BLAKE2B 28d5c898c114bb319208e519dac6488182b97473d8bc245546c6a0df3cc777c517b84db625656b769e63268c78e249300d39e3cb298383a3137c57944ccfcf23 SHA512 9f155f94f8250ac97e1bbaec2034aac300c3fa254ed0b6845f57d521138d43b076c8cec8aa8384891969665d54f5994b5c0a78954406ef620ae23656d739b0ec
diff --git a/dev-qt/qtscxml/qtscxml-6.8.2.ebuild b/dev-qt/qtscxml/qtscxml-6.8.2.ebuild
new file mode 100644
index 000000000000..760530cf36ad
--- /dev/null
+++ b/dev-qt/qtscxml/qtscxml-6.8.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2021-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="State Chart XML (SCXML) support library for the Qt6 framework"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+fi
+
+IUSE="qml"
+
+RDEPEND="
+ ~dev-qt/qtbase-${PV}:6[gui]
+ qml? ( ~dev-qt/qtdeclarative-${PV}:6 )
+"
+DEPEND="${RDEPEND}"
+
+CMAKE_SKIP_TESTS=(
+ # may fail with pid-sandbox, or at least musl/hardened+gcc (exact
+ # conditions unknown but passes without pid, considering this flaky)
+ tst_qstatemachine
+)
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package qml Qt6Qml)
+ )
+
+ qt6-build_src_configure
+}