summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-05-13 06:24:14 +0200
committerHans de Graaff <graaff@gentoo.org>2018-05-13 06:24:14 +0200
commit7842e9d39fb05655acea1f33416d2da16bfabe5d (patch)
treef5a4d882835018725c689166b03ddd61865e4c90 /dev-ruby/atomic/atomic-1.1.101.ebuild
parentdev-ruby/arel-helpers: add 2.7.0 (diff)
downloadgentoo-7842e9d39fb05655acea1f33416d2da16bfabe5d.tar.gz
gentoo-7842e9d39fb05655acea1f33416d2da16bfabe5d.tar.bz2
gentoo-7842e9d39fb05655acea1f33416d2da16bfabe5d.zip
dev-ruby/atomic: add 1.0.101
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-ruby/atomic/atomic-1.1.101.ebuild')
-rw-r--r--dev-ruby/atomic/atomic-1.1.101.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/atomic/atomic-1.1.101.ebuild b/dev-ruby/atomic/atomic-1.1.101.ebuild
new file mode 100644
index 000000000000..f4208b05803a
--- /dev/null
+++ b/dev-ruby/atomic/atomic-1.1.101.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="An atomic reference implementation for JRuby, Rubinius, and MRI"
+HOMEPAGE="https://github.com/headius/ruby-atomic"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ # Avoid compilation dependencies since we compile directly.
+ sed -i -e '/:test => :compile/ s:^:#:' \
+ -e '/extensiontask/,/end/ s:^:#:' Rakefile || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext
+ cp ext/atomic_reference$(get_modname) lib/ || die
+}