summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-09-03 07:43:07 +0200
committerHans de Graaff <graaff@gentoo.org>2017-09-03 08:49:59 +0200
commit84426cf45bed8750b48eca099a41765f33283475 (patch)
treec9aba4a7c7bc59c3e50fb0d64aae45b87420b0a6 /dev-ruby/jwt/jwt-2.0.0.ebuild
parentdev-ruby/jwt: cleanup (diff)
downloadgentoo-84426cf45bed8750b48eca099a41765f33283475.tar.gz
gentoo-84426cf45bed8750b48eca099a41765f33283475.tar.bz2
gentoo-84426cf45bed8750b48eca099a41765f33283475.zip
dev-ruby/jwt: add 2.0.0
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-ruby/jwt/jwt-2.0.0.ebuild')
-rw-r--r--dev-ruby/jwt/jwt-2.0.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/jwt/jwt-2.0.0.ebuild b/dev-ruby/jwt/jwt-2.0.0.ebuild
new file mode 100644
index 000000000000..db473eb2b1f3
--- /dev/null
+++ b/dev-ruby/jwt/jwt-2.0.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby implementation of JSON Web Token draft 06"
+HOMEPAGE="https://github.com/jwt/ruby-jwt"
+SRC_URI="https://github.com/jwt/ruby-jwt/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RUBY_S="ruby-jwt-${PV}"
+
+all_ruby_prepare() {
+ sed -i -e "/simplecov/ s:^:#:" \
+ -e '/^SimpleCov.configure/,/^end/ s:^:#:' \
+ -e '/codeclimate/I s:^:#:' \
+ -e '/codacy/I s:^:#:' \
+ spec/spec_helper.rb || die
+}