summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-04-10 07:43:46 +0200
committerHans de Graaff <graaff@gentoo.org>2022-04-10 07:44:08 +0200
commit73e3277759a9a9f9617de1e21cfd1e78f2ebd6d9 (patch)
treea53f68b2f900d43924a1276a9a27c889681d0242 /dev-ruby/paramesan
parentdev-ruby/rainbow: enable ruby31 (diff)
downloadgentoo-73e3277759a9a9f9617de1e21cfd1e78f2ebd6d9.tar.gz
gentoo-73e3277759a9a9f9617de1e21cfd1e78f2ebd6d9.tar.bz2
gentoo-73e3277759a9a9f9617de1e21cfd1e78f2ebd6d9.zip
dev-ruby/paramesan: update EAPI 7 -> 8, add ruby31
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/paramesan')
-rw-r--r--dev-ruby/paramesan/paramesan-1.0.1-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/paramesan/paramesan-1.0.1-r1.ebuild b/dev-ruby/paramesan/paramesan-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..66f65e8f38cf
--- /dev/null
+++ b/dev-ruby/paramesan/paramesan-1.0.1-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_GEMSPEC="paramesan.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Parameterized tests in Ruby"
+HOMEPAGE="https://github.com/jpace/paramesan"
+
+SRC_URI="https://github.com/jpace/paramesan/archive/v${PV}.tar.gz -> ${P}.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+ sed -i -e '/bundler/ s:^:#:' Rakefile || die
+}