summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-07-05 06:46:08 +0200
committerHans de Graaff <graaff@gentoo.org>2023-07-05 18:36:44 +0200
commit4a483b3d4c2f336a281d8336936e0da771208d70 (patch)
tree14aef41ba3660f4b11cd828618c31c9272897559 /dev-ruby/sshkit
parentdev-perl/HTTP-CookieJar: Keyword 0.14.0 alpha, #909357 (diff)
downloadgentoo-4a483b3d4c2f336a281d8336936e0da771208d70.tar.gz
gentoo-4a483b3d4c2f336a281d8336936e0da771208d70.tar.bz2
gentoo-4a483b3d4c2f336a281d8336936e0da771208d70.zip
dev-ruby/sshkit: add 1.21.5
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/sshkit')
-rw-r--r--dev-ruby/sshkit/Manifest1
-rw-r--r--dev-ruby/sshkit/sshkit-1.21.5.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-ruby/sshkit/Manifest b/dev-ruby/sshkit/Manifest
index 22164caa71fe..b253c3c12af9 100644
--- a/dev-ruby/sshkit/Manifest
+++ b/dev-ruby/sshkit/Manifest
@@ -1 +1,2 @@
DIST sshkit-1.21.4.gem 144896 BLAKE2B a4f7cd2342810422c6dd680370c741136bbe1cc59656333bb8a82ac2edd6eb0e3d5482cf671a3ffdcc38cd2f2a97140623728e213e8fd3098b223b9e601e6ea1 SHA512 c3a56b7dd80334b87d512054e98e8a72d93b036a4fb0adc34fad259c5b851de6a3c69549d1472442a3b822d371e80115849aa767dd7fda215fd0f626a7138173
+DIST sshkit-1.21.5.gem 145408 BLAKE2B 19fa326d30ddae12be84b7cf460d5d44c48fc52cf89f61a775999eae7cbcc985ac7b335dd4aa772e8966decc24a6e5a894621e9873ac133122fb8e18d1c82945 SHA512 e441da155323dd71c235d3ebb4ddccd41987183cffe4e23cb52404ba25a16ae4f3c1f786d7be4db6dc8733013720b99d12c8f3369f1d8841f967407b3edb28b2
diff --git a/dev-ruby/sshkit/sshkit-1.21.5.ebuild b/dev-ruby/sshkit/sshkit-1.21.5.ebuild
new file mode 100644
index 000000000000..0af20a61d7f6
--- /dev/null
+++ b/dev-ruby/sshkit/sshkit-1.21.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby30 ruby31 ruby32"
+
+# There are functional tests that require vagrant boxes to be set up.
+RUBY_FAKEGEM_TASK_TEST="test:units"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md FAQ.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="SSHKit makes it easy to write structured, testable SSH commands in Ruby"
+HOMEPAGE="https://github.com/capistrano/sshkit"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/net-ssh-2.8.0:*
+ >=dev-ruby/net-scp-1.1.2
+"
+
+ruby_add_bdepend "test? ( dev-ruby/minitest dev-ruby/mocha )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/I s:^:#:' Rakefile test/helper.rb || die
+ sed -e '/\(turn\|unindent\|reporters\)/I s:^:#:' \
+ -e '1irequire "pathname"' \
+ -i test/helper.rb || die
+
+ # Fix assumption about parent directory name
+ sed -i -e '/assert_match/ s/sshkit/sshkit.*/' test/unit/test_deprecation_logger.rb || die
+}
+
+each_ruby_test() {
+ # Run tests directly to avoid dependencies in the Rakefile
+ ${RUBY} -Ilib:test:. -e "Dir['test/unit/**/test*.rb'].each{|f| require f}" || die
+}