summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-09-05 08:01:14 +0200
committerHans de Graaff <graaff@gentoo.org>2024-09-05 08:01:14 +0200
commitb56b84161d43be2a73f7d141b9b9ae6c78dabe5a (patch)
treebd67f4b47769299254871054486e753a0076a090 /dev-ruby/yard
parentdev-ruby/rexml: add 3.3.7 (diff)
downloadgentoo-b56b84161d43be2a73f7d141b9b9ae6c78dabe5a.tar.gz
gentoo-b56b84161d43be2a73f7d141b9b9ae6c78dabe5a.tar.bz2
gentoo-b56b84161d43be2a73f7d141b9b9ae6c78dabe5a.zip
dev-ruby/yard: add 0.9.37
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/yard')
-rw-r--r--dev-ruby/yard/Manifest1
-rw-r--r--dev-ruby/yard/yard-0.9.37.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/dev-ruby/yard/Manifest b/dev-ruby/yard/Manifest
index a9a042e008a6..f37d720fc452 100644
--- a/dev-ruby/yard/Manifest
+++ b/dev-ruby/yard/Manifest
@@ -1 +1,2 @@
DIST yard-0.9.36-git.tgz 938567 BLAKE2B 8672b94149b4bbecd3fb80c1d386e3cdfd4013ad88969958269abd480426e41990067df0e5352df1a983a1572129b91a31129a71eae872cc00712e6e992a07c5 SHA512 09639d7ac6fed28906b40e08c16e305f44416206f67947fbdedf4adbb0be92d1e15ade9a04509f2847063b39baaa7a5bcbd585031808baaaf5acf14f06b471d5
+DIST yard-0.9.37-git.tgz 941020 BLAKE2B 40c9ad5be234d00d84fd3187271357691841a2b57fd37ee9fc346e8d8c91c54f751d6ad46df988f6d40e3a1c3c4d644cfdce825579e7294b23ec52f28489e45d SHA512 f48a25df1fba7cdde7388842c6bce63ab149e613921cca8c809adb2a3bd7edce49c573c8867e62a3cb33c8cb3868dd67bd87f34c65ffce1e66c1353a2f93f9ca
diff --git a/dev-ruby/yard/yard-0.9.37.ebuild b/dev-ruby/yard/yard-0.9.37.ebuild
new file mode 100644
index 000000000000..5d1f8575ffe4
--- /dev/null
+++ b/dev-ruby/yard/yard-0.9.37.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC="yard"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_DOCDIR="doc docs"
+
+RUBY_FAKEGEM_EXTRAINSTALL="templates .yardopts"
+
+RUBY_FAKEGEM_GEMSPEC="yard.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Documentation generation tool for the Ruby programming language"
+HOMEPAGE="https://yardoc.org/"
+
+# The gem lacks the gemspec file needed to pass tests.
+SRC_URI="https://github.com/lsegal/yard/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="test"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.9.34-beginless-range.patch"
+)
+
+ruby_add_bdepend "doc? ( || ( dev-ruby/maruku dev-ruby/rdiscount dev-ruby/kramdown ) )"
+
+ruby_add_bdepend "test? ( dev-ruby/rack:2.2 >=dev-ruby/rspec-3.11.0 dev-ruby/webrick )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/ s:^:#:' -e '3igem "rack", "~> 2.2.0"' spec/spec_helper.rb || die
+
+ sed -i -e '/samus/I s:^:#:' Rakefile || die
+
+ sed -i -e 's/git ls-files/find/' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Avoid specs that make assumptions on load ordering that are not
+ # true for us. This may be related to how we install in Gentoo. This
+ # also drops a test requirement on dev-ruby/rack.
+ rm -f spec/cli/server_spec.rb || die
+
+ # Avoid specs that only work with bundler
+ sed -i -e '/#initialize/,/^ end/ s:^:#:' spec/cli/yri_spec.rb || die
+ sed -e '/overwrites options with data in/askip "wrong assumptions on file access"' \
+ -e '/loads any gem plugins starting with/askip "wrong assumptions on file access"' \
+ -i spec/config_spec.rb || die
+
+ # Avoid specs making assumptions about how rubygems works internally
+ sed -i -e '/searches for .gem file/askip "rubygems internals"' spec/cli/diff_spec.rb || die
+
+ # Fix broken spec
+ sed -i -e '/:exist?/aallow(File).to receive(:exist?).and_call_original' spec/i18n/locale_spec.rb || die
+
+ # Avoid ruby31 failure on whitespace-only differences
+ sed -i -e '/shows a list of nodes/askip "Whitespace differences on ruby31"' spec/parser/ruby/ast_node_spec.rb || die
+
+ # Avoid redcarpet-specific spec that is not optional
+ sed -i -e '/autolinks URLs/askip "make redcarpet optional"' spec/templates/helpers/html_helper_spec.rb || die
+
+ # Avoid asciidoc-specific spec that is not optional
+ sed -e '/\(AsciiDoc specific\|AsciiDoc header\)/askip "skipping asciidoc test"' \
+ -i spec/templates/helpers/html_helper_spec.rb || die
+}