summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-04-30 12:06:18 +0200
committerDavid Seifert <soap@gentoo.org>2023-04-30 12:06:18 +0200
commit568b8a8843c91c5b82b92e7c6dd15352c1bf3412 (patch)
tree597e7927ed400cd9912776512241fe1ded651335 /dev-ruby
parentdev-ruby/classifier-reborn: treeclean (diff)
downloadgentoo-568b8a8843c91c5b82b92e7c6dd15352c1bf3412.tar.gz
gentoo-568b8a8843c91c5b82b92e7c6dd15352c1bf3412.tar.bz2
gentoo-568b8a8843c91c5b82b92e7c6dd15352c1bf3412.zip
dev-ruby/rb-gsl: treeclean
Closes: https://bugs.gentoo.org/574742 Closes: https://bugs.gentoo.org/723924 Closes: https://bugs.gentoo.org/828838 Closes: https://bugs.gentoo.org/884297 Closes: https://bugs.gentoo.org/895684 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/rb-gsl/Manifest1
-rw-r--r--dev-ruby/rb-gsl/metadata.xml11
-rw-r--r--dev-ruby/rb-gsl/rb-gsl-2.1.0.2-r1.ebuild49
3 files changed, 0 insertions, 61 deletions
diff --git a/dev-ruby/rb-gsl/Manifest b/dev-ruby/rb-gsl/Manifest
deleted file mode 100644
index cdf1eadc348b..000000000000
--- a/dev-ruby/rb-gsl/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST gsl-2.1.0.2.gem 735232 BLAKE2B bb8aa488b5d3bf7c2f3facf34093c985c63bfe692933b21eb8273af38e6788691593bdcc6fd52b9e22635d1b8195f81d1302edab7c2915a19ce9574cab184d84 SHA512 c07adfb44980ca813e114db2b0917f6b2dcb7d3bbe0ccfd9561519b4e574991f3c72f3e7115218f473154690f9284bf89c968d3c6d52d29fa0a232a1160d2704
diff --git a/dev-ruby/rb-gsl/metadata.xml b/dev-ruby/rb-gsl/metadata.xml
deleted file mode 100644
index 5a476dce6701..000000000000
--- a/dev-ruby/rb-gsl/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>ruby@gentoo.org</email>
- <name>Gentoo Ruby Project</name>
- </maintainer>
- <upstream>
- <remote-id type="github">SciRuby/rb-gsl</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-ruby/rb-gsl/rb-gsl-2.1.0.2-r1.ebuild b/dev-ruby/rb-gsl/rb-gsl-2.1.0.2-r1.ebuild
deleted file mode 100644
index 1b4bd449037d..000000000000
--- a/dev-ruby/rb-gsl/rb-gsl-2.1.0.2-r1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# No >= ruby30 because of https://github.com/SciRuby/rb-gsl/issues/63
-USE_RUBY="ruby26 ruby27"
-
-RUBY_FAKEGEM_NAME="gsl"
-inherit ruby-fakegem multilib
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_EXTRADOC="ChangeLog README.md"
-
-RUBY_FAKEGEM_EXTENSIONS=(ext/gsl_native/extconf.rb)
-
-DESCRIPTION="Ruby interface to GNU Scientific Library"
-HOMEPAGE="https://github.com/SciRuby/rb-gsl"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64"
-IUSE="doc"
-
-DEPEND+=" >=sci-libs/gsl-2.3[deprecated]"
-RDEPEND+=" >=sci-libs/gsl-2.3[deprecated]"
-
-RUBY_S="${PN}-${P}"
-
-ruby_add_bdepend "dev-ruby/narray"
-ruby_add_rdepend "dev-ruby/narray"
-
-all_ruby_prepare() {
- sed -i -e '/LOCAL_LIBS/ s: -l: -L#{path.gsub("ext", "lib")} -l:' ext/gsl_native/extconf.rb || die
- # nmatrix only tests
- rm -r test/gsl/nmatrix_tests || die
-}
-
-each_ruby_configure() {
- NARRAY=1 each_fakegem_configure
-}
-
-each_ruby_compile() {
- NARRAY=1 each_fakegem_compile
-}
-
-each_ruby_test() {
- NARRAY=1 ${RUBY} -Ilib:test:. -e 'Dir["test/**/*_test.rb"].each{|f| require f}' || die
-}