summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-10 12:38:35 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-10 12:54:06 +0100
commit5ad5cd34f875003265337c37866659bf5a1b3bc9 (patch)
tree08dd796e18599140c8c3f25d9cd2f3fc9275d79f /dev-tcltk
parentdev-ruby/rbst: Remove py2 (diff)
downloadgentoo-5ad5cd34f875003265337c37866659bf5a1b3bc9.tar.gz
gentoo-5ad5cd34f875003265337c37866659bf5a1b3bc9.tar.bz2
gentoo-5ad5cd34f875003265337c37866659bf5a1b3bc9.zip
dev-tcltk/tclpython: Remove old (py2)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/tclpython/tclpython-4.1-r4.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/dev-tcltk/tclpython/tclpython-4.1-r4.ebuild b/dev-tcltk/tclpython/tclpython-4.1-r4.ebuild
deleted file mode 100644
index 3508b6c02a13..000000000000
--- a/dev-tcltk/tclpython/tclpython-4.1-r4.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit eutils multilib python-single-r1 toolchain-funcs
-
-DESCRIPTION="Python package for Tcl"
-HOMEPAGE="http://jfontain.free.fr/tclpython.htm"
-SRC_URI="http://jfontain.free.fr/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE=""
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="${PYTHON_DEPS}
- dev-lang/tcl:0="
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/${P}-python-3.patch
-)
-
-src_prepare() {
- epatch "${PATCHES[@]}"
-}
-
-src_compile() {
- local cfile="tclpython tclthread"
- for src in ${cfile}; do
- compile="$(tc-getCC) -shared -fPIC ${CFLAGS} -I$(python_get_includedir) -c ${src}.c"
- einfo "${compile}"
- eval "${compile}" || die
- done
-
- link="$(tc-getCC) -fPIC -shared ${LDFLAGS} -o tclpython.so.${PV} tclpython.o tclthread.o -lpthread -lutil $(python_get_LIBS) -ltcl"
- einfo "${link}"
- eval "${link}" || die
-}
-
-src_install() {
- insinto /usr/$(get_libdir)/tclpython
- doins tclpython.so.${PV} pkgIndex.tcl
- fperms 775 /usr/$(get_libdir)/tclpython/tclpython.so.${PV}
- dosym tclpython.so.${PV} /usr/$(get_libdir)/tclpython/tclpython.so
-
- dodoc CHANGES INSTALL README
- dohtml tclpython.htm
-}