summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <alexey+gentoo@asokolov.org>2024-05-25 16:37:39 +0100
committerJoonas Niilola <juippis@gentoo.org>2024-07-03 08:30:17 +0300
commitf3c5adab6c67daf989716abaa1b716f1458e2e40 (patch)
tree520cd22669d37ba99f215bdbb20f6ba6c0564116 /dev-util/bear
parentvdr-plugin-2.eclass: fix behaviour with LINGUAS="en" (diff)
downloadgentoo-f3c5adab6c67daf989716abaa1b716f1458e2e40.tar.gz
gentoo-f3c5adab6c67daf989716abaa1b716f1458e2e40.tar.bz2
gentoo-f3c5adab6c67daf989716abaa1b716f1458e2e40.zip
dev-util/bear: drop 3.0.20-r1, 3.0.21, 3.1.2
Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-util/bear')
-rw-r--r--dev-util/bear/Manifest3
-rw-r--r--dev-util/bear/bear-3.0.20-r1.ebuild91
-rw-r--r--dev-util/bear/bear-3.0.21.ebuild96
-rw-r--r--dev-util/bear/bear-3.1.2.ebuild95
-rw-r--r--dev-util/bear/files/bear-3.0.21-clang16-tests.patch32
-rw-r--r--dev-util/bear/files/bear-3.0.21-libfmt-10.0.0.patch26
6 files changed, 0 insertions, 343 deletions
diff --git a/dev-util/bear/Manifest b/dev-util/bear/Manifest
index 9425105b679e..7f7b17831dbd 100644
--- a/dev-util/bear/Manifest
+++ b/dev-util/bear/Manifest
@@ -1,4 +1 @@
-DIST bear-3.0.20.tar.gz 125393 BLAKE2B 826a774beeb0596038f69b345a3659fe58f897bdb1a63f5faeac1d4242ae3cf4bf346ab82d2f87934d0786e5c0d4e835837b838a62f5a92c28ffe5e6a3d6a900 SHA512 4cf0e648b73fd4c0ac109c4a853e203efccb34ac7373d6c2f3ee3d5089853b791008990df768871dfd1268324bcce97c44657b4c3a2d1383134cba3eaec40bdd
-DIST bear-3.0.21.tar.gz 125827 BLAKE2B f7dcd383f27c370edb2fa0225e8337b2abe086df25a0272f61051600c017527b4079750328cb811b6967ad6fab51647909333eb1d084e24060fe56ca1036e40d SHA512 9fe43a52fb30b7b413244576c6ea0d493bb720e54d0b6263280224efef4b0432dee46697df160ba7e76bc1a5c8735fe814e0eb686ed797658b563bcb8c5bb7e5
-DIST bear-3.1.2.tar.gz 127197 BLAKE2B b9ef373aab194f0e7330c5f457b88e3c11bb3b202940eff65ecbae79b123254df9629c06f4781570b19675834be80fba041b070820663a6b9a747fc6d269be25 SHA512 02701e8a53b9d776ca838248f5b5d149d7ded6e024ce65bd1ca3b440ab1bf95691dc3d36bb28f043ce24bc1da6e666fb022ff92fa9df7c3142451742de16ca3e
DIST bear-3.1.3.tar.gz 127766 BLAKE2B 8fdb5b9bf8e1e026df2296b0d45f23ce1a9157dda28b2656d36c0799e2f02965711ecdf09780d075e18965afc6a771dbf26501e9e1e3b26f4784d4191e168748 SHA512 34039b51a7cd636bdb7fb716f69d6c70de3e7bfc5e2c83a3040942010fb7effe49b0afa0d29be182eb550d57b024fbe5bea779a7fda5f86201865bf491ba1672
diff --git a/dev-util/bear/bear-3.0.20-r1.ebuild b/dev-util/bear/bear-3.0.20-r1.ebuild
deleted file mode 100644
index 05332355b211..000000000000
--- a/dev-util/bear/bear-3.0.20-r1.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 2020-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit cmake python-any-r1
-
-DESCRIPTION="Build EAR generates a compilation database for clang tooling"
-HOMEPAGE="https://github.com/rizsotto/Bear"
-SRC_URI="https://github.com/rizsotto/Bear/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="amd64 ~ppc64 ~riscv x86"
-IUSE="test"
-
-RDEPEND="
- >=dev-cpp/nlohmann_json-3.7.3:=
- >=dev-db/sqlite-3.14:=
- dev-libs/libfmt:=
- dev-libs/protobuf:=
- >=dev-libs/spdlog-1.5:=
- >=net-libs/grpc-1.26:=
-"
-
-DEPEND="${RDEPEND}
- test? (
- >=dev-cpp/gtest-1.10
- )
-"
-
-BDEPEND="
- virtual/pkgconfig
- test? (
- dev-build/libtool
- $(python_gen_any_dep '
- dev-python/lit[${PYTHON_USEDEP}]
- ')
- )
-"
-
-RESTRICT="!test? ( test )"
-
-S="${WORKDIR}/${P^}"
-
-pkg_setup() {
- use test && python-any-r1_pkg_setup
-}
-
-src_prepare() {
- cmake_src_prepare
- # Turn off testing before installation
- sed -i 's/TEST_BEFORE_INSTALL/TEST_EXCLUDE_FROM_MAIN/g' CMakeLists.txt || die
-}
-
-src_configure() {
- local mycmakeargs=(
- -DENABLE_UNIT_TESTS="$(usex test)"
- -DENABLE_FUNC_TESTS="$(usex test)"
- )
- cmake_src_configure
-}
-
-src_test() {
- if has sandbox ${FEATURES}; then
- ewarn "\'FEATURES=sandbox\' detected"
- ewarn "Bear overrides LD_PRELOAD and conflicts with gentoo sandbox"
- ewarn "Skipping tests"
- elif
- has usersandbox ${FEATURES}; then
- ewarn "\'FEATURES=usersandbox\' detected"
- ewarn "Skipping tests"
- elif
- has network-sandbox ${FEATURES}; then
- ewarn "\'FEATURES=network-sandbox\' detected"
- ewarn "Skipping tests"
- elif
- has_version -b 'sys-devel/gcc-config[-native-symlinks]'; then
- ewarn "\'sys-devel/gcc-config[-native-symlinks]\' detected, tests call /usr/bin/cc directly (hardcoded)"
- ewarn "and will fail without generic cc symlink"
- ewarn "Skipping tests"
- else
- einfo "test may use optional tools if found: qmake gfortran valgrind"
- # unit tests
- cmake_run_in "${BUILD_DIR}/subprojects/Build/BearSource" ctest --verbose
- # functional tests
- cmake_run_in "${BUILD_DIR}/subprojects/Build/BearTest" ctest --verbose
- fi
-}
diff --git a/dev-util/bear/bear-3.0.21.ebuild b/dev-util/bear/bear-3.0.21.ebuild
deleted file mode 100644
index 3dbde5dce6df..000000000000
--- a/dev-util/bear/bear-3.0.21.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 2020-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit cmake python-any-r1
-
-DESCRIPTION="Build EAR generates a compilation database for clang tooling"
-HOMEPAGE="https://github.com/rizsotto/Bear"
-SRC_URI="https://github.com/rizsotto/Bear/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
-IUSE="test"
-
-RDEPEND="
- >=dev-cpp/nlohmann_json-3.11.2:=
- >=dev-db/sqlite-3.14:=
- >=dev-libs/libfmt-9.1.0:=
- dev-libs/protobuf:=
- >=dev-libs/spdlog-1.11.0:=
- >=net-libs/grpc-1.49.2:=
-"
-
-DEPEND="${RDEPEND}
- test? (
- >=dev-cpp/gtest-1.10
- )
-"
-
-BDEPEND="
- virtual/pkgconfig
- test? (
- dev-build/libtool
- $(python_gen_any_dep '
- dev-python/lit[${PYTHON_USEDEP}]
- ')
- )
-"
-
-RESTRICT="!test? ( test )"
-
-S="${WORKDIR}/${P^}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.0.21-clang16-tests.patch
- "${FILESDIR}"/${PN}-3.0.21-libfmt-10.0.0.patch
-)
-
-pkg_setup() {
- use test && python-any-r1_pkg_setup
-}
-
-src_prepare() {
- cmake_src_prepare
- # Turn off testing before installation
- sed -i 's/TEST_BEFORE_INSTALL/TEST_EXCLUDE_FROM_MAIN/g' CMakeLists.txt || die
-}
-
-src_configure() {
- local mycmakeargs=(
- -DENABLE_UNIT_TESTS="$(usex test)"
- -DENABLE_FUNC_TESTS="$(usex test)"
- )
- cmake_src_configure
-}
-
-src_test() {
- if has sandbox ${FEATURES}; then
- ewarn "\'FEATURES=sandbox\' detected"
- ewarn "Bear overrides LD_PRELOAD and conflicts with gentoo sandbox"
- ewarn "Skipping tests"
- elif
- has usersandbox ${FEATURES}; then
- ewarn "\'FEATURES=usersandbox\' detected"
- ewarn "Skipping tests"
- elif
- has network-sandbox ${FEATURES}; then
- ewarn "\'FEATURES=network-sandbox\' detected"
- ewarn "Skipping tests"
- elif
- has_version -b 'sys-devel/gcc-config[-native-symlinks]'; then
- ewarn "\'sys-devel/gcc-config[-native-symlinks]\' detected, tests call /usr/bin/cc directly (hardcoded)"
- ewarn "and will fail without generic cc symlink"
- ewarn "Skipping tests"
- else
- einfo "test may use optional tools if found: qmake gfortran valgrind"
- # unit tests
- cmake_run_in "${BUILD_DIR}/subprojects/Build/BearSource" ctest --verbose
- # functional tests
- cmake_run_in "${BUILD_DIR}/subprojects/Build/BearTest" ctest --verbose
- fi
-}
diff --git a/dev-util/bear/bear-3.1.2.ebuild b/dev-util/bear/bear-3.1.2.ebuild
deleted file mode 100644
index 9c75a5f7010e..000000000000
--- a/dev-util/bear/bear-3.1.2.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 2020-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit cmake python-any-r1
-
-DESCRIPTION="Build EAR generates a compilation database for clang tooling"
-HOMEPAGE="https://github.com/rizsotto/Bear"
-SRC_URI="https://github.com/rizsotto/Bear/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ~loong ~ppc64 ~riscv x86"
-IUSE="test"
-
-RDEPEND="
- >=dev-cpp/nlohmann_json-3.11.2:=
- >=dev-db/sqlite-3.14:=
- >=dev-libs/libfmt-9.1.0:=
- dev-libs/protobuf:=
- >=dev-libs/spdlog-1.11.0:=
- >=net-libs/grpc-1.49.2:=
-"
-
-DEPEND="${RDEPEND}
- test? (
- >=dev-cpp/gtest-1.13
- )
-"
-
-BDEPEND="
- virtual/pkgconfig
- test? (
- dev-build/libtool
- $(python_gen_any_dep '
- dev-python/lit[${PYTHON_USEDEP}]
- ')
- )
-"
-
-RESTRICT="!test? ( test )"
-
-S="${WORKDIR}/${P^}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.0.21-libfmt-10.0.0.patch
-)
-
-pkg_setup() {
- use test && python-any-r1_pkg_setup
-}
-
-src_prepare() {
- cmake_src_prepare
- # Turn off testing before installation
- sed -i 's/TEST_BEFORE_INSTALL/TEST_EXCLUDE_FROM_MAIN/g' CMakeLists.txt || die
-}
-
-src_configure() {
- local mycmakeargs=(
- -DENABLE_UNIT_TESTS="$(usex test)"
- -DENABLE_FUNC_TESTS="$(usex test)"
- )
- cmake_src_configure
-}
-
-src_test() {
- if has sandbox ${FEATURES}; then
- ewarn "\'FEATURES=sandbox\' detected"
- ewarn "Bear overrides LD_PRELOAD and conflicts with gentoo sandbox"
- ewarn "Skipping tests"
- elif
- has usersandbox ${FEATURES}; then
- ewarn "\'FEATURES=usersandbox\' detected"
- ewarn "Skipping tests"
- elif
- has network-sandbox ${FEATURES}; then
- ewarn "\'FEATURES=network-sandbox\' detected"
- ewarn "Skipping tests"
- elif
- has_version -b 'sys-devel/gcc-config[-native-symlinks]'; then
- ewarn "\'sys-devel/gcc-config[-native-symlinks]\' detected, tests call /usr/bin/cc directly (hardcoded)"
- ewarn "and will fail without generic cc symlink"
- ewarn "Skipping tests"
- else
- einfo "test may use optional tools if found: qmake gfortran valgrind"
- # unit tests
- cmake_run_in "${BUILD_DIR}/subprojects/Build/BearSource" ctest --verbose
- # functional tests
- cmake_run_in "${BUILD_DIR}/subprojects/Build/BearTest" ctest --verbose
- fi
-}
diff --git a/dev-util/bear/files/bear-3.0.21-clang16-tests.patch b/dev-util/bear/files/bear-3.0.21-clang16-tests.patch
deleted file mode 100644
index 19c63ba60849..000000000000
--- a/dev-util/bear/files/bear-3.0.21-clang16-tests.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-https://github.com/rizsotto/Bear/pull/521
-
-From 472cbed312444cdcef9102e924c79070ea1d3ab2 Mon Sep 17 00:00:00 2001
-From: Florian Weimer <fweimer@redhat.com>
-Date: Sat, 15 Apr 2023 19:37:41 +0200
-Subject: [PATCH] Avoid implicit function declarations in tests, for C99
- compatibility
-
-Include <stdio.h> for printf and define _GNU_SOURCE for execvpe.
-
-Future compilers will not support implicit function declartions by
-default, causing these tests to fail to build.
---- a/test/cases/intercept/preload/errno_reset.c
-+++ b/test/cases/intercept/preload/errno_reset.c
-@@ -5,6 +5,7 @@
- #include <stdlib.h>
- #include <errno.h>
- #include <string.h>
-+#include <stdio.h>
-
- int main()
- {
---- a/test/cases/intercept/preload/posix/execvpe/success.c
-+++ b/test/cases/intercept/preload/posix/execvpe/success.c
-@@ -8,6 +8,7 @@
- #include "config.h"
-
- #if defined HAVE_UNISTD_H
-+#define _GNU_SOURCE
- #include <unistd.h>
- #endif
-
diff --git a/dev-util/bear/files/bear-3.0.21-libfmt-10.0.0.patch b/dev-util/bear/files/bear-3.0.21-libfmt-10.0.0.patch
deleted file mode 100644
index 7c8425e46ede..000000000000
--- a/dev-util/bear/files/bear-3.0.21-libfmt-10.0.0.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-BUG: https://bugs.gentoo.org/906082
-UPSTREAM: https://github.com/rizsotto/Bear/pull/526
-
-From 46a032fa0fc8131779ece13f26735ec84be891e8 Mon Sep 17 00:00:00 2001
-From: jinqiang zhang <peeweep@0x0.ee>
-Date: Thu, 11 May 2023 03:33:17 +0800
-Subject: [PATCH] dependency: fix fmt 10.0.0 incompatibilities (#526)
-
-Signed-off-by: jinqiang zhang <peeweep@0x0.ee>
----
- source/CMakeLists.txt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/source/CMakeLists.txt b/source/CMakeLists.txt
-index 6da1131f..fe6b710b 100644
---- a/source/CMakeLists.txt
-+++ b/source/CMakeLists.txt
-@@ -29,7 +29,7 @@ find_package(spdlog REQUIRED)
- find_package(PkgConfig REQUIRED)
- pkg_check_modules(gRPC REQUIRED IMPORTED_TARGET protobuf grpc++)
-
--if (fmt_VERSION_MAJOR EQUAL 9)
-+if (fmt_VERSION_MAJOR GREATER_EQUAL 9)
- set(FMT_NEEDS_OSTREAM_FORMATTER 1)
- set(HAVE_FMT_STD_H 1) # FIXME: this should be done with `check_include_file`
- endif ()