summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-06-17 07:07:18 +0100
committerSam James <sam@gentoo.org>2024-06-17 07:07:18 +0100
commit6ff697c1ed5f83c79425c6dc1f6c55e549acbabf (patch)
tree605cbfaf740097b311c2150d6866773d5b9bdd4b /dev-util/diffoscope
parentdev-python/tlsh: actually wire up testsuite (diff)
downloadgentoo-6ff697c1ed5f83c79425c6dc1f6c55e549acbabf.tar.gz
gentoo-6ff697c1ed5f83c79425c6dc1f6c55e549acbabf.tar.bz2
gentoo-6ff697c1ed5f83c79425c6dc1f6c55e549acbabf.zip
dev-util/diffoscope: skip tests relying on zipdetails for 32-bit systems
We need to fix this in Perl itself, see bug #934444. Note that this worked fine before newer zipdetails landed in Perl (https://github.com/pmqs/zipdetails/pull/7). Bug: https://bugs.gentoo.org/934444 Closes: https://bugs.gentoo.org/934443 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/diffoscope')
-rw-r--r--dev-util/diffoscope/diffoscope-266.ebuild18
-rw-r--r--dev-util/diffoscope/diffoscope-268.ebuild18
-rw-r--r--dev-util/diffoscope/diffoscope-271.ebuild18
3 files changed, 51 insertions, 3 deletions
diff --git a/dev-util/diffoscope/diffoscope-266.ebuild b/dev-util/diffoscope/diffoscope-266.ebuild
index 7191da7ed124..4275c0618db7 100644
--- a/dev-util/diffoscope/diffoscope-266.ebuild
+++ b/dev-util/diffoscope/diffoscope-266.ebuild
@@ -6,7 +6,7 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..12} )
PYTHON_REQ_USE="ncurses"
-inherit distutils-r1
+inherit distutils-r1 toolchain-funcs
DESCRIPTION="Will try to get to the bottom of what makes files or directories different"
HOMEPAGE="https://diffoscope.org/ https://pypi.org/project/diffoscope/"
@@ -122,3 +122,19 @@ EPYTEST_DESELECT=(
)
distutils_enable_tests pytest
+
+src_test() {
+ case $(tc-get-ptr-size) in
+ 4)
+ EPYTEST_IGNORE+=(
+ # Needs fixing in Perl itself (bug #934443)
+ tests/comparators/test_epub.py
+ tests/comparators/test_zip.py
+ )
+ ;;
+ *)
+ ;;
+ esac
+
+ distutils-r1_src_test
+}
diff --git a/dev-util/diffoscope/diffoscope-268.ebuild b/dev-util/diffoscope/diffoscope-268.ebuild
index e4e8cd71bdcc..1761b40e36fc 100644
--- a/dev-util/diffoscope/diffoscope-268.ebuild
+++ b/dev-util/diffoscope/diffoscope-268.ebuild
@@ -6,7 +6,7 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..12} )
PYTHON_REQ_USE="ncurses"
-inherit distutils-r1
+inherit distutils-r1 toolchain-funcs
DESCRIPTION="Will try to get to the bottom of what makes files or directories different"
HOMEPAGE="https://diffoscope.org/ https://pypi.org/project/diffoscope/"
@@ -133,3 +133,19 @@ EPYTEST_DESELECT=(
)
distutils_enable_tests pytest
+
+src_test() {
+ case $(tc-get-ptr-size) in
+ 4)
+ EPYTEST_IGNORE+=(
+ # Needs fixing in Perl itself (bug #934443)
+ tests/comparators/test_epub.py
+ tests/comparators/test_zip.py
+ )
+ ;;
+ *)
+ ;;
+ esac
+
+ distutils-r1_src_test
+}
diff --git a/dev-util/diffoscope/diffoscope-271.ebuild b/dev-util/diffoscope/diffoscope-271.ebuild
index ea0ae53846a2..10e254dd5ac3 100644
--- a/dev-util/diffoscope/diffoscope-271.ebuild
+++ b/dev-util/diffoscope/diffoscope-271.ebuild
@@ -6,7 +6,7 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..12} )
PYTHON_REQ_USE="ncurses"
-inherit distutils-r1
+inherit distutils-r1 toolchain-funcs
DESCRIPTION="Will try to get to the bottom of what makes files or directories different"
HOMEPAGE="https://diffoscope.org/ https://pypi.org/project/diffoscope/"
@@ -129,3 +129,19 @@ EPYTEST_DESELECT=(
)
distutils_enable_tests pytest
+
+src_test() {
+ case $(tc-get-ptr-size) in
+ 4)
+ EPYTEST_IGNORE+=(
+ # Needs fixing in Perl itself (bug #934443)
+ tests/comparators/test_epub.py
+ tests/comparators/test_zip.py
+ )
+ ;;
+ *)
+ ;;
+ esac
+
+ distutils-r1_src_test
+}