summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2018-08-20 08:48:40 +0300
committerMart Raudsepp <leio@gentoo.org>2018-08-20 09:11:38 +0300
commitf2b24988e4ae0f0a059347430d6690ef7fe191b8 (patch)
tree16b5a13893c26f3efbcbf50519e627d6015d4dc9 /dev-util/glib-utils
parentdev-libs/glib: 2.56.2, python utils split out to dev-util/glib-utils (diff)
downloadgentoo-f2b24988e4ae0f0a059347430d6690ef7fe191b8.tar.gz
gentoo-f2b24988e4ae0f0a059347430d6690ef7fe191b8.tar.bz2
gentoo-f2b24988e4ae0f0a059347430d6690ef7fe191b8.zip
dev-util/glib-utils: bump to 2.56.2; now ships the python build utils
The 2.52.3 version here was just a transitional empty package with stable keywords. This 2.56.2 version now actually ships the python utils glib-genmarshal/glib-mkenums/gtester-report itself and thus blocks older glib that shipped it itself instead. The soft blocker should ensure no file collisions and a smooth migration. Package-Manager: Portage-2.3.47, Repoman-2.3.10
Diffstat (limited to 'dev-util/glib-utils')
-rw-r--r--dev-util/glib-utils/Manifest1
-rw-r--r--dev-util/glib-utils/glib-utils-2.56.2.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-util/glib-utils/Manifest b/dev-util/glib-utils/Manifest
new file mode 100644
index 000000000000..99155620c480
--- /dev/null
+++ b/dev-util/glib-utils/Manifest
@@ -0,0 +1 @@
+DIST glib-2.56.2.tar.xz 8041756 BLAKE2B 1af5bb37378856e959602bcb9299266bba46b990839c923f6b9881624aed306af0779005281b3e3a46b5994c54812edc86aade9cb782c596fd63b6fd91baba51 SHA512 8201ea82d3613d2e879284abe01520b766da30957c5a1a22f3e6019b0cce6bf95d25beae78867b6a133401c4165153c0c92974dd459ab12f9e0e9dd0c95df5d4
diff --git a/dev-util/glib-utils/glib-utils-2.56.2.ebuild b/dev-util/glib-utils/glib-utils-2.56.2.ebuild
new file mode 100644
index 000000000000..fb52a8b8a925
--- /dev/null
+++ b/dev-util/glib-utils/glib-utils-2.56.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+GNOME_ORG_MODULE="glib"
+
+inherit gnome.org python-single-r1
+
+DESCRIPTION="Build utilities for GLib using projects"
+HOMEPAGE="https://www.gtk.org/"
+
+LICENSE="LGPL-2.1+"
+SLOT="0" # /usr/bin utilities that can't be parallel installed by their nature
+IUSE=""
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
+
+RDEPEND="${PYTHON_DEPS}
+ !<dev-libs/glib-2.56.2:2
+"
+DEPEND="${RDEPEND}"
+
+src_configure() { :; }
+
+src_compile() {
+ sed -e "s:@VERSION@:${PV}:g;s:@PYTHON@:python:g" gobject/glib-genmarshal.in > gobject/glib-genmarshal
+ sed -e "s:@VERSION@:${PV}:g;s:@PYTHON@:python:g" gobject/glib-mkenums.in > gobject/glib-mkenums
+}
+
+src_install() {
+ python_fix_shebang gobject/glib-genmarshal
+ python_fix_shebang gobject/glib-mkenums
+ python_fix_shebang glib/gtester-report
+ exeinto /usr/bin
+ doexe gobject/glib-genmarshal
+ doexe gobject/glib-mkenums
+ doexe glib/gtester-report
+ doman docs/reference/gobject/glib-genmarshal.1
+ doman docs/reference/gobject/glib-mkenums.1
+ doman docs/reference/glib/gtester-report.1
+}