summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-04 04:32:38 +0000
committerSam James <sam@gentoo.org>2021-12-04 04:32:38 +0000
commit67e2c1b7a958478a8781a084e508f6d02a573cc3 (patch)
treecc9cc79cccc99a790b1db8028f3efa4151992c69 /dev-util/libtree
parentgames-misc/fortune-mod-all: Keyword 5 arm64, #828043 (diff)
downloadgentoo-67e2c1b7a958478a8781a084e508f6d02a573cc3.tar.gz
gentoo-67e2c1b7a958478a8781a084e508f6d02a573cc3.tar.bz2
gentoo-67e2c1b7a958478a8781a084e508f6d02a573cc3.zip
dev-util/libtree: initial import
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/libtree')
-rw-r--r--dev-util/libtree/Manifest1
-rw-r--r--dev-util/libtree/libtree-2.0.0.ebuild31
-rw-r--r--dev-util/libtree/metadata.xml11
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-util/libtree/Manifest b/dev-util/libtree/Manifest
new file mode 100644
index 000000000000..330c503300fa
--- /dev/null
+++ b/dev-util/libtree/Manifest
@@ -0,0 +1 @@
+DIST libtree-2.0.0.tar.gz 161133 BLAKE2B cf681f06fef9dfb44ad6099a4b7ab950cb23aef052a180cdd646498ac0baacf0f0caa14bac6a629d2bac2bd638d4b6e5ad97dd0d705e4d681021a168a6753b0f SHA512 9272afd8540110f43ade864a2df58d8b8a7690c79cd29a9804b43e7e550bc05a4da530a763a27bd85a474673055e7a5ba63c0aa0bcaf8b246fbfc73a4f36c870
diff --git a/dev-util/libtree/libtree-2.0.0.ebuild b/dev-util/libtree/libtree-2.0.0.ebuild
new file mode 100644
index 000000000000..a9152d7fe064
--- /dev/null
+++ b/dev-util/libtree/libtree-2.0.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="ldd as a tree with an option to bundle dependencies into a single folder"
+HOMEPAGE="https://github.com/haampie/libtree"
+SRC_URI="https://github.com/haampie/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-libs/cxxopts
+ dev-cpp/elfio
+ dev-cpp/termcolor
+ test? ( dev-cpp/gtest )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DLIBTREE_BUILD_TESTS=$(usex test)
+ )
+
+ cmake_src_configure
+}
diff --git a/dev-util/libtree/metadata.xml b/dev-util/libtree/metadata.xml
new file mode 100644
index 000000000000..e63def80e5ba
--- /dev/null
+++ b/dev-util/libtree/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sam@gentoo.org</email>
+ <name>Sam James</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">haampie/libtree</remote-id>
+ </upstream>
+</pkgmetadata>