summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2016-03-17 22:40:43 +0000
committerJames Le Cuirot <chewi@gentoo.org>2016-03-17 22:41:52 +0000
commit60daa7b26d25f75aaf5ee361550b4cecbed83e1f (patch)
treec52be366e039ce69c03aa71f53e6612c7caa7216 /dev-util/patchelf/patchelf-0.9.ebuild
parentmedia-sound/skype-call-recorder: Version bump 0.11, bug #577532 (diff)
downloadgentoo-60daa7b26d25f75aaf5ee361550b4cecbed83e1f.tar.gz
gentoo-60daa7b26d25f75aaf5ee361550b4cecbed83e1f.tar.bz2
gentoo-60daa7b26d25f75aaf5ee361550b4cecbed83e1f.zip
dev-util/patchelf: Version bump to 0.9 wrt #577632, EAPI bump
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-util/patchelf/patchelf-0.9.ebuild')
-rw-r--r--dev-util/patchelf/patchelf-0.9.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-util/patchelf/patchelf-0.9.ebuild b/dev-util/patchelf/patchelf-0.9.ebuild
new file mode 100644
index 000000000000..71ca6a2b829e
--- /dev/null
+++ b/dev-util/patchelf/patchelf-0.9.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Small utility to modify the dynamic linker and RPATH of ELF executables"
+HOMEPAGE="http://nixos.org/patchelf.html"
+SRC_URI="http://releases.nixos.org/${PN}/${P}/${P}.tar.bz2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-3"
+
+src_prepare() {
+ default
+ rm src/elf.h || die
+
+ sed -i \
+ -e 's:-Werror::g' \
+ -e 's:parallel-tests:serial-tests:g' \
+ configure.ac || die
+
+ eautoreconf
+}