summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNils Freydank <holgersson@posteo.de>2022-05-26 19:05:11 +0200
committerJoonas Niilola <juippis@gentoo.org>2022-06-12 09:51:41 +0300
commit8e552d48cec53041428dccd098c5a86fc7e4ec1a (patch)
tree18cc9401004f5cc6bd6099d1839d152d4681ac68 /dev-vcs/git-lfs
parentsci-libs/trilinos: disable broken module, add comment (diff)
downloadgentoo-8e552d48cec53041428dccd098c5a86fc7e4ec1a.tar.gz
gentoo-8e552d48cec53041428dccd098c5a86fc7e4ec1a.tar.bz2
gentoo-8e552d48cec53041428dccd098c5a86fc7e4ec1a.zip
dev-vcs/git-lfs: Bump to 3.2.0
Signed-off-by: Nils Freydank <holgersson@posteo.de> Closes: https://github.com/gentoo/gentoo/pull/25642 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-vcs/git-lfs')
-rw-r--r--dev-vcs/git-lfs/Manifest1
-rw-r--r--dev-vcs/git-lfs/git-lfs-3.2.0.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-vcs/git-lfs/Manifest b/dev-vcs/git-lfs/Manifest
index f705d371bd58..d9553880f55f 100644
--- a/dev-vcs/git-lfs/Manifest
+++ b/dev-vcs/git-lfs/Manifest
@@ -1,2 +1,3 @@
DIST git-lfs-3.1.2.tar.gz 3254358 BLAKE2B 77df9aef438c2d839b6a3690c6f34191b993180be7b3cbccedbe2d439cd8d77676f91a864598af40ebfe4d9d021bbc179bb6bcbb3635ca0a7ed78eecd2da0246 SHA512 de2b56146b929adf7f6ff1989f07d4aca59bde218a51273c0d443a4cace0ccfcf9d4d72c2458c53f95fe06f092baaf6ccbde304e9ca20691ccb9e7aa56f49ebb
DIST git-lfs-3.1.4.tar.gz 3254376 BLAKE2B 3eeb32b6a9b5c40f53b9c32a557911edf2216243108250aae407280b2a26293ce4cb981f1bb2863dcaf5553976ba34fa42ec4dc8a1a76cd0fd5946fd482b2f99 SHA512 ff62e19532ec09d71e241ffb9b6a0ed91a76cbe1fe32a88a6e3679e15cf97b09bcfdb5fc1aa0c1a9984bc888c88be87940bd7044d68102eadf93cb68dc5e9c1c
+DIST git-lfs-3.2.0.tar.gz 3270970 BLAKE2B fc235d48e44f8a0f446b05914cd110e6486481482b2884483dcf04198a3275a633cd8090e1591975f8b84ba678c258581e3510fc0d478d5fc72abf6aa98bd5c0 SHA512 c2ba8cecd5b3519a032f446b0c3043352f37f3c67ff3c2304a38beb176f0ae8efd1deaeb8bd54a35d7dd7dcd988da67249c896dffd83fc293b165a3e6bb02d66
diff --git a/dev-vcs/git-lfs/git-lfs-3.2.0.ebuild b/dev-vcs/git-lfs/git-lfs-3.2.0.ebuild
new file mode 100644
index 000000000000..820116904c3c
--- /dev/null
+++ b/dev-vcs/git-lfs/git-lfs-3.2.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+EGO_PN=github.com/git-lfs/git-lfs
+inherit go-module
+
+DESCRIPTION="Command line extension and specification for managing large files with git"
+HOMEPAGE="https://git-lfs.github.com/"
+
+if [[ "${PV}" = 9999* ]]; then
+ EGIT_REPO_URI="https://${EGO_PN}"
+ inherit git-r3
+else
+ SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="Apache-2.0 BSD BSD-2 BSD-4 ISC MIT"
+SLOT="0"
+IUSE="doc test"
+
+BDEPEND="doc? ( || ( app-text/ronn-ng app-text/ronn ) )"
+RDEPEND="dev-vcs/git"
+
+RESTRICT+=" !test? ( test )"
+
+DOCS=(
+ CHANGELOG.md
+ CODE-OF-CONDUCT.md
+ CONTRIBUTING.md
+ README.md
+ SECURITY.md
+)
+
+src_compile() {
+ # Flags -w, -s: Omit debugging information to reduce binary size,
+ # see https://golang.org/cmd/link/.
+ local mygobuildargs=(
+ -ldflags="-X ${EGO_PN}/config.GitCommit=${GIT_COMMIT} -s -w"
+ -mod vendor -v -work -x
+ )
+ go build "${mygobuildargs[@]}" -o git-lfs git-lfs.go || die
+
+ if use doc; then
+ ronn docs/man/*.ronn || die "man building failed"
+ fi
+}
+
+src_install() {
+ dobin git-lfs
+ einstalldocs
+ use doc && doman docs/man/*.1
+}
+
+src_test() {
+ local mygotestargs=(
+ -ldflags="-X ${EGO_PN}/config.GitCommit=${GIT_COMMIT}"
+ -mod vendor
+ )
+ go test "${mygotestargs[@]}" ./... || die
+}
+
+pkg_postinst () {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog ""
+ elog "Run \'git lfs install\' once for each user account manually."
+ elog "For more details see https://bugs.gentoo.org/show_bug.cgi?id=733372."
+ fi
+}