summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2025-01-16 21:00:14 +0300
committerAndreas Sturmlechner <asturm@gentoo.org>2025-01-19 14:48:25 +0100
commit12d10fba7c53fa06425b3c28d347ecd8ce35a55b (patch)
tree491802ce57a80f1ba5b01eac16bf7d1501876524 /dev-vcs
parentdev-python/qscintilla: 2.14.1-r2, add PYTHON_COMPAT=python3_13 (diff)
downloadgentoo-12d10fba7c53fa06425b3c28d347ecd8ce35a55b.tar.gz
gentoo-12d10fba7c53fa06425b3c28d347ecd8ce35a55b.tar.bz2
gentoo-12d10fba7c53fa06425b3c28d347ecd8ce35a55b.zip
dev-vcs/tortoisehg: 6.9 version bump
Closes: https://bugs.gentoo.org/947315 Bug: https://bugs.gentoo.org/948006 Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru> Closes: https://github.com/gentoo/gentoo/pull/40166 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/tortoisehg/Manifest1
-rw-r--r--dev-vcs/tortoisehg/tortoisehg-6.9.ebuild82
-rw-r--r--dev-vcs/tortoisehg/tortoisehg-9999.ebuild12
3 files changed, 89 insertions, 6 deletions
diff --git a/dev-vcs/tortoisehg/Manifest b/dev-vcs/tortoisehg/Manifest
index 212a41c70d1b..67b36e111bae 100644
--- a/dev-vcs/tortoisehg/Manifest
+++ b/dev-vcs/tortoisehg/Manifest
@@ -1 +1,2 @@
DIST tortoisehg-6.6.3.tar.gz 8857342 BLAKE2B 166d1305ed3ee54496b3e0b08fc92a34a56a9398aa618a0f2266e7413fafc371be3c308debc3260a15b59c147a00bbe0773df52a838c4a4f0028b29c1cb05090 SHA512 8de8a68a753e8554dcb9936f6ba237e0598df65e6039f7c608e692bc375258e64a443e27e63c337f361fc32c0076b79bd98a972c220089902ff4489ab3507928
+DIST tortoisehg-6.9.tar.gz 8862668 BLAKE2B b7f917a8c9f0ca575e27ab1670bfe940e6257940691c53fca464b4012417283c9915fe5f604b0c1a5cb7f620ce20b47e945bb9e88b301f7ac036c19fcb4508b5 SHA512 f9f7ed9c3a1cdf633c453a12c7f68505027975fbd858c4e9cd4ce09920126f22043c1621a5d949391d31a9a13331cee2466d718635aa16dc8558bac5536d14fb
diff --git a/dev-vcs/tortoisehg/tortoisehg-6.9.ebuild b/dev-vcs/tortoisehg/tortoisehg-6.9.ebuild
new file mode 100644
index 000000000000..026b203968d8
--- /dev/null
+++ b/dev-vcs/tortoisehg/tortoisehg-6.9.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+DISTUTILS_USE_PEP517=setuptools
+inherit desktop distutils-r1 optfeature xdg-utils
+
+if [[ ${PV} != *9999* ]]; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+ SRC_URI="https://foss.heptapod.net/mercurial/${PN}/thg/-/archive/${PV}/thg-${PV}.tar.gz -> ${P}.tar.gz"
+ HG_DEPEND=">=dev-vcs/mercurial-6.3[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-vcs/mercurial-6.9[${PYTHON_USEDEP}]' python3_13 )
+ <dev-vcs/mercurial-6.10[${PYTHON_USEDEP}]"
+ S="${WORKDIR}/thg-${PV}"
+else
+ inherit mercurial
+ EHG_REPO_URI="https://foss.heptapod.net/mercurial/${PN}/thg"
+ EHG_REVISION="stable"
+ HG_DEPEND=">=dev-vcs/mercurial-6.3[${PYTHON_USEDEP}]"
+fi
+
+DESCRIPTION="Set of graphical tools for Mercurial"
+HOMEPAGE="https://tortoisehg.bitbucket.io/"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="${HG_DEPEND}
+ dev-python/iniparse[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/pyqt6[network,svg,${PYTHON_USEDEP}]
+ >=dev-python/qscintilla-2.14.1-r1[qt6(+),${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx doc/source
+
+python_prepare_all() {
+ # Remove file that collides with >=mercurial-4.0 (bug #599266).
+ rm "${S}"/hgext3rd/__init__.py || die "can't remove /hgext3rd/__init__.py"
+
+ sed -i -e 's:share/doc/tortoisehg:share/doc/'"${PF}"':' setup.py || die
+ sed -i -e '/^testedwith/s/6.8/6.8 6.9/' tortoisehg/util/hgversion.py || die
+ export THG_QT_API=PyQt6
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ ${EPYTHON} tests/run-tests.py -m 'not largefiles' --disable-pytest-warnings --doctest-modules tests || die "Tests failed with ${EPYTHON}"
+ ${EPYTHON} tests/run-tests.py -m largefiles --disable-pytest-warnings tests || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ export THG_QT_API=PyQt6
+ distutils-r1_python_install_all
+ dodoc doc/ReadMe*.txt doc/TODO contrib/mergetools.rc
+ newicon -s scalable icons/scalable/apps/thg.svg thg_logo.svg
+ domenu contrib/thg.desktop
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ elog "When startup of ${PN} fails with an API version mismatch error"
+ elog "between dev-python/sip and dev-python/pyqt6 please rebuild"
+ elog "dev-python/qscintilla."
+
+ optfeature "the core git extension support" dev-python/pygit2
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
diff --git a/dev-vcs/tortoisehg/tortoisehg-9999.ebuild b/dev-vcs/tortoisehg/tortoisehg-9999.ebuild
index a18ccd3822a5..888aa2f9a021 100644
--- a/dev-vcs/tortoisehg/tortoisehg-9999.ebuild
+++ b/dev-vcs/tortoisehg/tortoisehg-9999.ebuild
@@ -1,24 +1,24 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
DISTUTILS_USE_PEP517=setuptools
inherit desktop distutils-r1 optfeature xdg-utils
if [[ ${PV} != *9999* ]]; then
KEYWORDS="~amd64 ~arm64 ~x86"
SRC_URI="https://foss.heptapod.net/mercurial/${PN}/thg/-/archive/${PV}/thg-${PV}.tar.gz -> ${P}.tar.gz"
- HG_DEPEND=">=dev-vcs/mercurial-6.2[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '>=dev-vcs/mercurial-6.3.2[${PYTHON_USEDEP}]' python3_11 )
- <dev-vcs/mercurial-6.7[${PYTHON_USEDEP}]"
+ HG_DEPEND=">=dev-vcs/mercurial-6.3[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-vcs/mercurial-6.9[${PYTHON_USEDEP}]' python3_13 )
+ <dev-vcs/mercurial-6.10[${PYTHON_USEDEP}]"
S="${WORKDIR}/thg-${PV}"
else
inherit mercurial
EHG_REPO_URI="https://foss.heptapod.net/mercurial/${PN}/thg"
EHG_REVISION="stable"
- HG_DEPEND=">=dev-vcs/mercurial-6.2[${PYTHON_USEDEP}]"
+ HG_DEPEND=">=dev-vcs/mercurial-6.3[${PYTHON_USEDEP}]"
fi
DESCRIPTION="Set of graphical tools for Mercurial"