summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /eclass/emboss-r1.eclass
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'eclass/emboss-r1.eclass')
-rw-r--r--eclass/emboss-r1.eclass133
1 files changed, 133 insertions, 0 deletions
diff --git a/eclass/emboss-r1.eclass b/eclass/emboss-r1.eclass
new file mode 100644
index 000000000000..3a494b9b0686
--- /dev/null
+++ b/eclass/emboss-r1.eclass
@@ -0,0 +1,133 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# @ECLASS: emboss-r1.eclass
+# @MAINTAINER:
+# sci-biology@gentoo.org
+# jlec@gentoo.org
+# ted.tanberry@gmail.com
+# @AUTHOR:
+# Original author: Author Olivier Fisette <ofisette@gmail.com>
+# Next gen author: Justin Lecher <jlec@gentoo.org>
+# Next gen author: Ted Tanberry <ted.tanberry@gmail.com>
+# @BLURB: Use this to easy install EMBOSS and EMBASSY programs (EMBOSS add-ons).
+# @DESCRIPTION:
+# The inheriting ebuild must set at least EAPI=5 and provide EBO_DESCRIPTION before the inherit line.
+# KEYWORDS should be set. Additionally "(R|P)DEPEND"encies and other standard
+# ebuild variables can be extended (FOO+=" bar").
+#
+# Example:
+#
+# EAPI="5"
+#
+# EBO_DESCRIPTION="applications from the CBS group"
+#
+# inherit emboss-r1
+
+# @ECLASS-VARIABLE: EBO_DESCRIPTION
+# @DESCRIPTION:
+# Should be set. Completes the generic description of the embassy module as follows:
+#
+# EMBOSS integrated version of ${EBO_DESCRIPTION},
+# e.g.
+# "EMBOSS integrated version of applications from the CBS group"
+#
+# Defaults to the upstream name of the module.
+
+# @ECLASS-VARIABLE: EBO_EXTRA_ECONF
+# @DEFAULT_UNSET
+# @DESCRIPTION:
+# Extra config options passed to econf.
+
+case ${EAPI:-0} in
+ 5) ;;
+ *) die "this eclass doesn't support < EAPI 5" ;;
+esac
+
+inherit autotools-utils eutils flag-o-matic
+
+HOMEPAGE="http://emboss.sourceforge.net/"
+LICENSE="LGPL-2 GPL-2"
+
+SLOT="0"
+IUSE="mysql pdf png postgres static-libs X"
+
+DEPEND="
+ dev-libs/expat
+ dev-libs/libpcre:3
+ sci-libs/plplot
+ sys-libs/zlib
+ mysql? ( virtual/mysql )
+ pdf? ( media-libs/libharu )
+ png? ( media-libs/gd[png] )
+ postgres? ( dev-db/postgresql:= )
+ X? ( x11-libs/libXt )"
+RDEPEND="${DEPEND}"
+
+if [[ ${PN} == embassy-* ]]; then
+ EMBASSY_PACKAGE=yes
+ # The EMBASSY package name, retrieved from the inheriting ebuild's name
+ EN=${PN:8}
+ # The full name and version of the EMBASSY package (excluding the Gentoo
+ # revision number)
+ EF=$(echo ${EN} | tr "[:lower:]" "[:upper:]")-${PV}
+ : ${EBO_DESCRIPTION:=${EN}}
+ DESCRIPTION="EMBOSS integrated version of ${EBO_DESCRIPTION}"
+ SRC_URI="ftp://emboss.open-bio.org/pub/EMBOSS/${EF}.tar.gz -> embassy-${EN}-${PVR}.tar.gz"
+ DEPEND+=" >=sci-biology/emboss-6.6.0[mysql=,pdf=,png=,postgres=,static-libs=,X=]"
+
+ S="${WORKDIR}"/${EF}
+fi
+
+# @FUNCTION: emboss_src_prepare
+# @DESCRIPTION:
+# Does the following things
+#
+# 1. Renames configure.in to configure.ac, if possible
+# 2. Applies ${PATCHES[@]} and runs autotools via autotools-utils.eclass
+#
+
+emboss-r1_src_prepare() {
+ if [[ -e configure.in ]]; then
+ mv configure.{in,ac} || die
+ fi
+
+ autotools-utils_src_prepare
+}
+
+# @FUNCTION: emboss_src_configure
+# @DESCRIPTION:
+# runs econf with following options.
+#
+# $(use_with X x)
+# $(use_with png pngdriver)
+# $(use_with pdf hpdf)
+# $(use_with mysql mysql)
+# $(use_with postgres postgresql)
+# $(use_enable static-libs static)
+# --enable-large
+# --without-java
+# --enable-systemlibs
+# ${EBO_EXTRA_ECONF}
+
+emboss-r1_src_configure() {
+ local myeconfargs=(
+ $(use_with X x)
+ $(use_with png pngdriver "${EPREFIX}/usr")
+ $(use_with pdf hpdf "${EPREFIX}/usr")
+ $(use_with mysql mysql "${EPREFIX}/usr/bin/mysql_config")
+ $(use_with postgres postgresql "${EPREFIX}/usr/bin/pg_config")
+ --enable-large
+ --without-java
+ --enable-systemlibs
+ ${EBO_EXTRA_ECONF}
+ )
+
+ [[ ${EMBASSY_PACKAGE} == yes ]] && \
+ append-cppflags "-I${EPREFIX}/usr/include/emboss"
+
+ autotools-utils_src_configure
+}
+
+EXPORT_FUNCTIONS src_prepare src_configure