summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-action/wordwarvi
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-action/wordwarvi')
-rw-r--r--games-action/wordwarvi/Manifest1
-rw-r--r--games-action/wordwarvi/files/wordwarvi-1.00-sound.patch80
-rw-r--r--games-action/wordwarvi/metadata.xml8
-rw-r--r--games-action/wordwarvi/wordwarvi-1.00.ebuild54
4 files changed, 143 insertions, 0 deletions
diff --git a/games-action/wordwarvi/Manifest b/games-action/wordwarvi/Manifest
new file mode 100644
index 000000000000..35eb26cafbfb
--- /dev/null
+++ b/games-action/wordwarvi/Manifest
@@ -0,0 +1 @@
+DIST wordwarvi-1.00.tar.gz 8828099 SHA256 7aa668b18096e85583ee0cfa1e21316b6754268df564adb4ff6ae8a8fe791ee9 SHA512 e8f8609300fa2f9bd2ff763fee11699c5f30e96ccb3a5d531456134e983148227bb12fb6421b4ad00bcac46cddcdb5a036d416b8e55aedf037d1c3f0b5e04fa9 WHIRLPOOL 66000d4af4ac769cd7830d9291d38d30748eb4ad55700fd7b53391b522237c681e5563acfa7e1404d98148688eca8e7f255a6f97b55bfb0950c2a0ab39172fa3
diff --git a/games-action/wordwarvi/files/wordwarvi-1.00-sound.patch b/games-action/wordwarvi/files/wordwarvi-1.00-sound.patch
new file mode 100644
index 000000000000..5ad7bc8440b9
--- /dev/null
+++ b/games-action/wordwarvi/files/wordwarvi-1.00-sound.patch
@@ -0,0 +1,80 @@
+diff -ru wordwarvi-1.00.orig/Makefile wordwarvi-1.00/Makefile
+--- wordwarvi-1.00.orig/Makefile 2011-06-09 00:06:22.000000000 -0400
++++ wordwarvi-1.00/Makefile 2011-06-11 19:57:55.609619777 -0400
+@@ -1,5 +1,5 @@
+ PREFIX=/usr
+-DATADIR=${PREFIX}/share/wordwarvi
++DATADIR?=${PREFIX}/share/wordwarvi
+ MANDIR?=${PREFIX}/share/man
+ MANPAGEDIR=${MANDIR}/man6
+
+@@ -24,18 +24,6 @@
+ CC ?= gcc
+ BUILD_CC ?= gcc
+
+-# DEBUG=-g
+-# DEBUG=
+-# PROFILE_FLAG=-pg
+-#PROFILE_FLAG=
+-#OPTIMIZE_FLAG=
+-# OPTIMIZE_FLAG=-O3
+-#OPTIMIZE_FLAG=-O3 -pedantic -D_FORTIFY_SOURCE=2 -Wformat -Wformat-security
+-OPTIMIZE_FLAG=-O3 -pedantic
+-
+-
+-LDFLAGS=${PROFILE_FLAG}
+-
+ DEFINES=${SNDFLAGS} -DDATADIR=\"${DATADIR}/\"
+
+ all: wordwarvi wordwarvi.6.gz
+@@ -53,24 +41,24 @@
+ endif
+
+ joystick.o: joystick.c joystick.h Makefile
+- $(CC) ${DEBUG} ${PROFILE_FLAG} ${OPTIMIZE_FLAG} -pthread -Wall -c joystick.c
++ $(CC) ${DEBUG} ${PROFILE_FLAG} ${CFLAGS} -pthread -Wall -c joystick.c
+
+ ogg_to_pcm.o: ogg_to_pcm.c ogg_to_pcm.h Makefile
+- $(CC) ${DEBUG} ${PROFILE_FLAG} ${OPTIMIZE_FLAG} `pkg-config --cflags vorbisfile` \
++ $(CC) ${DEBUG} ${PROFILE_FLAG} ${CFLAGS} `pkg-config --cflags vorbisfile` \
+ -pthread -Wall -c ogg_to_pcm.c
+
+ wwviaudio.o: wwviaudio.c wwviaudio.h ogg_to_pcm.h my_point.h Makefile
+- $(CC) -Wall ${DEBUG} ${PROFILE_FLAG} ${OPTIMIZE_FLAG} \
++ $(CC) -Wall ${DEBUG} ${PROFILE_FLAG} ${CFLAGS} \
+ ${DEFINES} \
+ -pthread `pkg-config --cflags vorbisfile` \
+ -c wwviaudio.c
+
+ rumble.o: rumble.c rumble.h Makefile
+- $(CC) ${DEBUG} ${PROFILE_FLAG} ${OPTIMIZE_FLAG} `pkg-config --cflags vorbisfile` \
++ $(CC) ${DEBUG} ${PROFILE_FLAG} ${CFLAGS} `pkg-config --cflags vorbisfile` \
+ -pthread -Wall -c rumble.c
+
+ wwvi_font.o: wwvi_font.c wwvi_font.h my_point.h Makefile
+- $(CC) ${DEBUG} ${PROFILE_FLAG} ${OPTIMIZE_FLAG} -pthread -Wall -c wwvi_font.c
++ $(CC) ${DEBUG} ${PROFILE_FLAG} ${CFLAGS} -pthread -Wall -c wwvi_font.c
+
+ stamp: stamp.c
+ $(BUILD_CC) -o stamp stamp.c
+@@ -78,7 +66,7 @@
+ wordwarvi: wordwarvi.c joystick.o rumble.o ${OGGOBJ} wwviaudio.o wwvi_font.o \
+ Makefile version.h stamp levels.h rumble.h
+ ./stamp > stamp.h
+- $(CC) ${DEBUG} ${PROFILE_FLAG} ${OPTIMIZE_FLAG} ${SCREENSAVERFLAG} -pthread -Wall ${DEFINES} \
++ $(CC) $(LDFLAGS) ${DEBUG} ${PROFILE_FLAG} ${CFLAGS} ${SCREENSAVERFLAG} -pthread -Wall ${DEFINES} \
+ joystick.o \
+ rumble.o \
+ wwvi_font.o \
+diff -ru wordwarvi-1.00.orig/wwviaudio.c wordwarvi-1.00/wwviaudio.c
+--- wordwarvi-1.00.orig/wwviaudio.c 2011-06-09 00:06:22.000000000 -0400
++++ wordwarvi-1.00/wwviaudio.c 2011-06-11 19:57:17.394274660 -0400
+@@ -121,7 +121,7 @@
+ if (clipnum >= max_sound_clips || clipnum < 0)
+ return -1;
+
+- snprintf(filebuf, PATH_MAX, "%s/%s", DATADIR, filename);
++ snprintf(filebuf, PATH_MAX, "GENTOO_DATADIR/%s", DATADIR, filename);
+ rc = stat(filebuf, &statbuf);
+ if (rc != 0) {
+ strncpy(filebuf, filename, PATH_MAX);
diff --git a/games-action/wordwarvi/metadata.xml b/games-action/wordwarvi/metadata.xml
new file mode 100644
index 000000000000..5f8fcc05224e
--- /dev/null
+++ b/games-action/wordwarvi/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">wordwarvi</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-action/wordwarvi/wordwarvi-1.00.ebuild b/games-action/wordwarvi/wordwarvi-1.00.ebuild
new file mode 100644
index 000000000000..0ef897387f76
--- /dev/null
+++ b/games-action/wordwarvi/wordwarvi-1.00.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils games
+
+DESCRIPTION="A retro side-scrolling shoot'em up based on the editor war story"
+HOMEPAGE="http://wordwarvi.sourceforge.net"
+SRC_URI="mirror://sourceforge/wordwarvi/${P}.tar.gz"
+
+LICENSE="GPL-2 CC-BY-2.0 CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="portaudio"
+
+RDEPEND="x11-libs/gtk+:2
+ portaudio? ( media-libs/libvorbis
+ >=media-libs/portaudio-19_pre1 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-sound.patch
+ sed -i \
+ -e "/^WITHAUDIO/s/yes/$(use portaudio && echo yes || echo no)/" \
+ Makefile \
+ || die "sed failed"
+ sed -i \
+ -e "s:GENTOO_DATADIR:${GAMES_DATADIR}/${PN}:" \
+ wwviaudio.c \
+ || die "sed failed"
+}
+
+src_compile() {
+ emake \
+ PREFIX="${GAMES_PREFIX}" \
+ DATADIR="${GAMES_DATADIR}/${PN}" \
+ MANDIR="/usr/share/man"
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ PREFIX="${GAMES_PREFIX}" \
+ DATADIR="${GAMES_DATADIR}/${PN}" \
+ MANDIR="/usr/share/man" \
+ install
+ use portaudio || rm -rf "${D}${GAMES_DATADIR}"
+ dodoc README AUTHORS changelog.txt AAA_HOW_TO_MAKE_NEW_LEVELS.txt
+ newicon icons/wordwarvi_icon_128x128.png ${PN}.png
+ make_desktop_entry ${PN} "Word War vi"
+ prepgamesdirs
+}