summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-07-01 04:25:11 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-07-01 05:07:17 -0400
commit638d959dfe1ae6462e3d3996f6cb7e4558c23429 (patch)
tree0449f7c4b57d3a83d59f464d2730efdd3219ebb1 /games-emulation/pcsx2/files
parentprofiles/arch/loong: mask >=dev-libs/openssl-3.1[asm] for now (diff)
downloadgentoo-638d959dfe1ae6462e3d3996f6cb7e4558c23429.tar.gz
gentoo-638d959dfe1ae6462e3d3996f6cb7e4558c23429.tar.bz2
gentoo-638d959dfe1ae6462e3d3996f6cb7e4558c23429.zip
games-emulation/pcsx2: update live
gtest unbundling needs rebasing, and unfortunately can no longer use system soundtouch as-is (newly bundled, fails if unbundled). Also split unbundling patches while at it, using diff -U0 so they're unlikely to break easily while touching the same file (context is not important for these). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-emulation/pcsx2/files')
-rw-r--r--games-emulation/pcsx2/files/pcsx2-1.7.4667-flags.patch7
-rw-r--r--games-emulation/pcsx2/files/pcsx2-1.7.4667-system-chdr.patch6
-rw-r--r--games-emulation/pcsx2/files/pcsx2-1.7.4667-system-gtest.patch15
-rw-r--r--games-emulation/pcsx2/files/pcsx2-1.7.4667-system-zstd.patch13
4 files changed, 41 insertions, 0 deletions
diff --git a/games-emulation/pcsx2/files/pcsx2-1.7.4667-flags.patch b/games-emulation/pcsx2/files/pcsx2-1.7.4667-flags.patch
new file mode 100644
index 000000000000..ad76cc99c6b6
--- /dev/null
+++ b/games-emulation/pcsx2/files/pcsx2-1.7.4667-flags.patch
@@ -0,0 +1,7 @@
+If upstream believes -ffast-math is ok for this part then that is
+fine, but we do not want to override users' -O.
+--- a/3rdparty/soundtouch/CMakeLists.txt
++++ b/3rdparty/soundtouch/CMakeLists.txt
+@@ -43 +43 @@
+- target_compile_options(pcsx2-soundtouch PRIVATE -Ofast)
++ target_compile_options(pcsx2-soundtouch PRIVATE -ffast-math)
diff --git a/games-emulation/pcsx2/files/pcsx2-1.7.4667-system-chdr.patch b/games-emulation/pcsx2/files/pcsx2-1.7.4667-system-chdr.patch
new file mode 100644
index 000000000000..9787cd380337
--- /dev/null
+++ b/games-emulation/pcsx2/files/pcsx2-1.7.4667-system-chdr.patch
@@ -0,0 +1,6 @@
+--- a/cmake/SearchForStuff.cmake
++++ b/cmake/SearchForStuff.cmake
+@@ -164 +164,2 @@
+-add_subdirectory(3rdparty/libchdr EXCLUDE_FROM_ALL)
++pkg_check_modules(chdr REQUIRED IMPORTED_TARGET libchdr)
++alias_library(chdr-static PkgConfig::chdr)
diff --git a/games-emulation/pcsx2/files/pcsx2-1.7.4667-system-gtest.patch b/games-emulation/pcsx2/files/pcsx2-1.7.4667-system-gtest.patch
new file mode 100644
index 000000000000..858efc3b3e47
--- /dev/null
+++ b/games-emulation/pcsx2/files/pcsx2-1.7.4667-system-gtest.patch
@@ -0,0 +1,15 @@
+--- a/cmake/SearchForStuff.cmake
++++ b/cmake/SearchForStuff.cmake
+@@ -96,6 +95,0 @@
+-if(ENABLE_TESTS)
+- if(NOT EXISTS "${CMAKE_SOURCE_DIR}/3rdparty/gtest/CMakeLists.txt")
+- message(WARNING "ENABLE_TESTS was on but gtest was not found, unit tests will not be enabled")
+- set(ACTUALLY_ENABLE_TESTS Off)
+- endif()
+-endif()
+--- a/tests/ctest/CMakeLists.txt
++++ b/tests/ctest/CMakeLists.txt
+@@ -20 +20,2 @@
+-add_subdirectory(gtest)
++find_package(GTest REQUIRED)
++alias_library(gtest_main GTest::gtest_main)
diff --git a/games-emulation/pcsx2/files/pcsx2-1.7.4667-system-zstd.patch b/games-emulation/pcsx2/files/pcsx2-1.7.4667-system-zstd.patch
new file mode 100644
index 000000000000..27b2e82852e8
--- /dev/null
+++ b/games-emulation/pcsx2/files/pcsx2-1.7.4667-system-zstd.patch
@@ -0,0 +1,13 @@
+This can use system zstd already but will not find it given
+it does not install cmake files, so use pkg-config.
+https://bugs.gentoo.org/872254
+--- a/cmake/SearchForStuff.cmake
++++ b/cmake/SearchForStuff.cmake
+@@ -114,5 +114,2 @@
+-find_optional_system_library(zstd 3rdparty/zstd 1.4.5)
+-if (${zstd_TYPE} STREQUAL System)
+- alias_library(Zstd::Zstd zstd::libzstd_shared)
+- alias_library(pcsx2-zstd zstd::libzstd_shared)
+-endif()
++pkg_check_modules(zstd REQUIRED IMPORTED_TARGET libzstd)
++alias_library(Zstd::Zstd PkgConfig::zstd)