summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-07-22 10:12:41 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-07-22 10:23:04 -0400
commit5af0627f94f7f9088def4f47b9737bddd51e43b4 (patch)
tree111651a83e0e298c17d3a53c34b075cd8df9cdb4 /games-emulation
parentdev-java/java-service-wrapper: made building tests USE-conditional (diff)
downloadgentoo-5af0627f94f7f9088def4f47b9737bddd51e43b4.tar.gz
gentoo-5af0627f94f7f9088def4f47b9737bddd51e43b4.tar.bz2
gentoo-5af0627f94f7f9088def4f47b9737bddd51e43b4.zip
games-emulation/dolphin: disable qt6 automagic
In advance before Qt6 is in tree, works fine with 6 but don't want it to be automagic without proper dependency checks. Was hoping for a non-sed way to handle this but due to the method used we can't use DISABLE_FIND_PACKAGE and such, maybe there is some variable that'd work but well. It may make sense to just drop Qt5 support in a future snapshot given 6 is the upstream preference. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/dolphin/dolphin-5.0_p20210506-r3.ebuild3
-rw-r--r--games-emulation/dolphin/dolphin-5.0_p20220520-r1.ebuild3
-rw-r--r--games-emulation/dolphin/dolphin-9999.ebuild3
3 files changed, 9 insertions, 0 deletions
diff --git a/games-emulation/dolphin/dolphin-5.0_p20210506-r3.ebuild b/games-emulation/dolphin/dolphin-5.0_p20210506-r3.ebuild
index 33218b7db9b5..6ff4a8dd29b9 100644
--- a/games-emulation/dolphin/dolphin-5.0_p20210506-r3.ebuild
+++ b/games-emulation/dolphin/dolphin-5.0_p20210506-r3.ebuild
@@ -129,6 +129,9 @@ src_prepare() {
# Remove dirty suffix: needed for netplay
sed -i -e 's/--dirty/&=""/' CMakeLists.txt || die
+
+ # Force Qt5 rather than automagic until support is properly handled here
+ sed -i -e '/NAMES Qt6 COMP/d' Source/Core/DolphinQt/CMakeLists.txt || die
}
src_configure() {
diff --git a/games-emulation/dolphin/dolphin-5.0_p20220520-r1.ebuild b/games-emulation/dolphin/dolphin-5.0_p20220520-r1.ebuild
index abcdeec7c45b..5d4b0219d150 100644
--- a/games-emulation/dolphin/dolphin-5.0_p20220520-r1.ebuild
+++ b/games-emulation/dolphin/dolphin-5.0_p20220520-r1.ebuild
@@ -147,6 +147,9 @@ src_prepare() {
# Remove dirty suffix: needed for netplay
sed -i -e 's/--dirty/&=""/' CMakeLists.txt || die
+
+ # Force Qt5 rather than automagic until support is properly handled here
+ sed -i -e '/NAMES Qt6 COMP/d' Source/Core/DolphinQt/CMakeLists.txt || die
}
src_configure() {
diff --git a/games-emulation/dolphin/dolphin-9999.ebuild b/games-emulation/dolphin/dolphin-9999.ebuild
index d888afe15b4d..ebe6fb575460 100644
--- a/games-emulation/dolphin/dolphin-9999.ebuild
+++ b/games-emulation/dolphin/dolphin-9999.ebuild
@@ -145,6 +145,9 @@ src_prepare() {
# Remove dirty suffix: needed for netplay
sed -i -e 's/--dirty/&=""/' CMakeLists.txt || die
+
+ # Force Qt5 rather than automagic until support is properly handled here
+ sed -i -e '/NAMES Qt6 COMP/d' Source/Core/DolphinQt/CMakeLists.txt || die
}
src_configure() {