summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-rpg/adonthell
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-rpg/adonthell')
-rw-r--r--games-rpg/adonthell/Manifest1
-rw-r--r--games-rpg/adonthell/adonthell-0.3.5-r1.ebuild69
-rw-r--r--games-rpg/adonthell/files/adonthell-0.3.5-configure.in.patch92
-rw-r--r--games-rpg/adonthell/files/adonthell-0.3.5-format.patch11
-rw-r--r--games-rpg/adonthell/files/adonthell-0.3.5-gcc46.patch13
-rw-r--r--games-rpg/adonthell/files/adonthell-0.3.5-glibc-2.10.patch22
-rw-r--r--games-rpg/adonthell/metadata.xml5
7 files changed, 213 insertions, 0 deletions
diff --git a/games-rpg/adonthell/Manifest b/games-rpg/adonthell/Manifest
new file mode 100644
index 000000000000..9a321fdf802e
--- /dev/null
+++ b/games-rpg/adonthell/Manifest
@@ -0,0 +1 @@
+DIST adonthell-src-0.3.5.tar.gz 877439 SHA256 b1b24f26b9f32782793b222c687943442be83fc0d7f5dbb4928a61074be36dd7 SHA512 bf970b809b22a8563b196d6817553dd58dc9cb09b3bd99eb99d5c8e6f0828cf59965633acd4fdf7835dd9cb732cbb3290d3663521201ece7569cad2f494fb15d WHIRLPOOL 4db4d959879e36b1ed3003cbb200c02de18432d19fd6576132c7b54a3efee1c19290003254fe59db181800e0186aafe532c7c9427102c64b7e0cb4a84c078347
diff --git a/games-rpg/adonthell/adonthell-0.3.5-r1.ebuild b/games-rpg/adonthell/adonthell-0.3.5-r1.ebuild
new file mode 100644
index 000000000000..c49474b5e45a
--- /dev/null
+++ b/games-rpg/adonthell/adonthell-0.3.5-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools eutils python-single-r1 games
+
+DESCRIPTION="roleplaying game engine"
+HOMEPAGE="http://adonthell.linuxgames.com/"
+SRC_URI="http://savannah.nongnu.org/download/${PN}/${PN}-src-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="doc nls"
+
+RDEPEND="${PYTHON_DEPS}
+ media-libs/sdl-ttf
+ media-libs/sdl-mixer[vorbis]
+ media-libs/libsdl:0[X,video,sound]
+ sys-libs/zlib
+ media-libs/freetype
+ media-libs/libogg
+ media-libs/libvorbis
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ dev-lang/swig
+ doc? (
+ media-gfx/graphviz
+ app-doc/doxygen
+ )
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/${PN}-${PV/a/}
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ games_pkg_setup
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-configure.in.patch \
+ "${FILESDIR}"/${P}-glibc-2.10.patch \
+ "${FILESDIR}"/${P}-format.patch \
+ "${FILESDIR}"/${P}-gcc46.patch
+ sed -i \
+ -e "/AC_PATH_PROGS/s:python:${EPYTHON}:" \
+ configure.in || die "sed failed"
+ rm -f ac{local,include}.m4
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --disable-py-debug \
+ $(use_enable nls) \
+ $(use_enable doc)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ keepdir "${GAMES_DATADIR}"/${PN}/games
+ dodoc AUTHORS ChangeLog FULLSCREEN.howto NEWBIE NEWS README
+ prepgamesdirs
+}
diff --git a/games-rpg/adonthell/files/adonthell-0.3.5-configure.in.patch b/games-rpg/adonthell/files/adonthell-0.3.5-configure.in.patch
new file mode 100644
index 000000000000..903bd9a5f67d
--- /dev/null
+++ b/games-rpg/adonthell/files/adonthell-0.3.5-configure.in.patch
@@ -0,0 +1,92 @@
+--- configure.in
++++ configure.in
+@@ -13,7 +13,7 @@
+ AM_INIT_AUTOMAKE([])
+ AM_CONFIG_HEADER(config.h)
+
+-CFLAGS="-g -Wall -fno-exceptions"
++CXXFLAGS="$CXXFLAGS -Wall -fno-exceptions"
+ CPPFLAGS=""
+ DEFS=""
+
+@@ -163,10 +163,8 @@
+
+ dnl Extract the version using Python, check against 2.2+
+
+- changequote(<<, >>)
+- PYTHON_VERSION=`$PYPACKAGE -c 'import sys ; print (int(sys.version[0]) * 10 + int(sys.version[2]))'`
+- PY_VERSION=`$PYPACKAGE -c 'import sys ; print sys.version[0:3]'`
+- changequote([, ])
++ PYTHON_VERSION=`$PYPACKAGE -c 'import sys ; print (int(sys.version@<:@0@:>@) * 10 + int(sys.version@<:@2@:>@))'`
++ PY_VERSION=`$PYPACKAGE -c 'import sys ; print sys.version@<:@0:3@:>@'`
+
+ if test $PYTHON_VERSION -lt 22; then
+ echo "Sorry, you need to have Python 2.2+ installed - update your version!"
+@@ -176,9 +174,7 @@
+ dnl Find the Python.h header file
+
+ AC_MSG_CHECKING(for Python header files)
+- changequote(<<, >>)
+- PYINCLUDE=`$PYPACKAGE -c 'import sys ; print "%s/include/python%s" % (sys.prefix, sys.version[:3])'`
+- changequote([, ])
++ PYINCLUDE=`$PYPACKAGE -c 'import sys ; print "%s/include/python%s" % (sys.prefix, sys.version@<:@:3@:>@)'`
+
+ if test -r "$PYINCLUDE/Python.h"; then
+ PY_CFLAGS="-I$PYINCLUDE"
+@@ -191,10 +187,8 @@
+ dnl Find the Python library
+ AC_MSG_CHECKING(for Python library)
+ PYLIB=""
+- changequote(<<, >>)
+ PYPREFIX=`$PYPACKAGE -c 'import sys; print sys.prefix'`
+- PYLIBVER=`$PYPACKAGE -c 'import sys; print sys.version[:3]'`
+- changequote([, ])
++ PYLIBVER=`$PYPACKAGE -c 'import sys; print sys.version@<:@:3@:>@'`
+
+ dnl look for a framework build of python first
+ fw=`echo "$PYPREFIX" | sed 's/.*\(Python\.framework\).*/\1/;'`
+@@ -233,19 +227,9 @@
+ fi
+ dnl Get the libraries that python depends on
+
+- AC_PATH_PROG(haveldd, ldd)
+ AC_MSG_CHECKING(for Python's dependencies)
+
+- if test x$haveldd != x ; then
+- changequote(<<, >>)
+- py_deps=`ldd $PYPACKAGE | sed 's/\( *.*lib\([^\/]*\)\.so.*=.*$\)/-l\2/p; d' | grep -v 'stdc++'`
+- for py_lib in $py_deps ; do
+- if test "$py_lib" != "-lm" && test "$py_lib" != "-lc" ; then
+- PY_DEPS="$PY_DEPS $py_lib"
+- fi
+- done
+- changequote([, ])
+- fi
++ PY_DEPS="$PY_DEPS `python-config --libs` -lutil"
+
+ case $target in
+ *-sun-solaris*)
+@@ -293,11 +277,9 @@
+ if test "$P_SWIG" != "no" ; then
+ $P_SWIG -version &> swig.ver
+
+- changequote(<<, >>)
+- swig_major_ver=`more swig.ver | sed 's/.* \([0-9]*\)\.[0-9]*\.[0-9]*.*/\1/p; d'`
+- swig_minor_ver=`more swig.ver | sed 's/.* [0-9]*\.\([0-9]*\)\.[0-9]*.*/\1/p; d'`
+- swig_micro_ver=`more swig.ver | sed 's/.* [0-9]*\.[0-9]*\.\([0-9]*\).*/\1/p; d'`
+- changequote([, ])
++ swig_major_ver=`more swig.ver | sed 's/.* \(@<:@0-9@:>@*\)\.@<:@0-9@:>@*\.@<:@0-9@:>@*.*/\1/p; d'`
++ swig_minor_ver=`more swig.ver | sed 's/.* @<:@0-9@:>@*\.\(@<:@0-9@:>@*\)\.@<:@0-9@:>@*.*/\1/p; d'`
++ swig_micro_ver=`more swig.ver | sed 's/.* @<:@0-9@:>@*\.@<:@0-9@:>@*\.\(@<:@0-9@:>@*\).*/\1/p; d'`
+
+ rm -f swig.ver
+
+@@ -387,7 +369,7 @@
+ dnl Generate our compiler arguements
+ dnl ********************************
+
+-CXXFLAGS="$CFLAGS $DEFS $INCLUDES"
++CXXFLAGS="$CXXFLAGS $DEFS $INCLUDES"
+
+ AC_SUBST(CXX)
+ AC_SUBST(CXXFLAGS)
diff --git a/games-rpg/adonthell/files/adonthell-0.3.5-format.patch b/games-rpg/adonthell/files/adonthell-0.3.5-format.patch
new file mode 100644
index 000000000000..f66cc50e16db
--- /dev/null
+++ b/games-rpg/adonthell/files/adonthell-0.3.5-format.patch
@@ -0,0 +1,11 @@
+--- src/py_adonthell_wrap.cc.old 2014-10-20 14:21:57.495642785 +0200
++++ src/py_adonthell_wrap.cc 2014-10-20 14:22:35.019293237 +0200
+@@ -867,7 +867,7 @@
+ Py_DECREF(old_str);
+ Py_DECREF(value);
+ } else {
+- PyErr_Format(PyExc_RuntimeError, mesg);
++ PyErr_Format(PyExc_RuntimeError, "%s", mesg);
+ }
+ }
+
diff --git a/games-rpg/adonthell/files/adonthell-0.3.5-gcc46.patch b/games-rpg/adonthell/files/adonthell-0.3.5-gcc46.patch
new file mode 100644
index 000000000000..f4d07e867e48
--- /dev/null
+++ b/games-rpg/adonthell/files/adonthell-0.3.5-gcc46.patch
@@ -0,0 +1,13 @@
+--- src/win_event.cc.old 2011-04-18 08:24:16.000000000 +0200
++++ src/win_event.cc 2011-04-18 08:25:18.000000000 +0200
+@@ -34,8 +34,9 @@
+
+ case DESTROY:
+ {
++ Functor0wRet<bool> func0ret;
+ set_callback_destroy (
+- makeFunctor (&Functor0wRet<bool>(), *callback, &py_callback::callback_func0ret));
++ makeFunctor (&func0ret, *callback, &py_callback::callback_func0ret));
+ break;
+ }
+
diff --git a/games-rpg/adonthell/files/adonthell-0.3.5-glibc-2.10.patch b/games-rpg/adonthell/files/adonthell-0.3.5-glibc-2.10.patch
new file mode 100644
index 000000000000..7aec808cd5f1
--- /dev/null
+++ b/games-rpg/adonthell/files/adonthell-0.3.5-glibc-2.10.patch
@@ -0,0 +1,22 @@
+diff -Naurp adonthell-0.3.4-orig/src/dialog.cc adonthell-0.3.4/src/dialog.cc
+--- adonthell-0.3.4-orig/src/dialog.cc 2005-03-10 12:39:41.000000000 -0600
++++ adonthell-0.3.4/src/dialog.cc 2009-07-26 15:57:01.410882131 -0600
+@@ -265,7 +265,8 @@ string dialog::scan_string (const char *
+ {
+ u_int32 begin, end, len;
+ PyObject *result;
+- char *tmp, *start, *mid, *str = NULL;
++ const char *start;
++ char *tmp, *mid, *str = NULL;
+ character *the_player = data::the_player;
+ string newstr (s);
+
+@@ -318,7 +319,7 @@ string dialog::scan_string (const char *
+
+ // Error!
+ cout << "\n*** Error, unknown macro " << start << flush;
+- start[0] = ' ';
++ newstr[newstr.length () - strlen (start)] = ' ';
+ }
+
+ // execute python functions
diff --git a/games-rpg/adonthell/metadata.xml b/games-rpg/adonthell/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-rpg/adonthell/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>