summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-12-18 23:09:34 -0500
committerMatt Turner <mattst88@gentoo.org>2021-12-18 23:53:05 -0500
commit9044840d6da167b29aed0dbdf1b8d922e6ea1800 (patch)
tree4fc0ad724600c0e98b297d74252df7873013debf /gnome-base
parentgnome-base/gnome-settings-daemon: Version bump to 41.0 (diff)
downloadgentoo-9044840d6da167b29aed0dbdf1b8d922e6ea1800.tar.gz
gentoo-9044840d6da167b29aed0dbdf1b8d922e6ea1800.tar.bz2
gentoo-9044840d6da167b29aed0dbdf1b8d922e6ea1800.zip
gnome-base/gnome-desktop: Version bump to 41.2
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/gnome-desktop/Manifest1
-rw-r--r--gnome-base/gnome-desktop/gnome-desktop-41.2.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/gnome-base/gnome-desktop/Manifest b/gnome-base/gnome-desktop/Manifest
index f6b765a4994b..dc0e6dd4e708 100644
--- a/gnome-base/gnome-desktop/Manifest
+++ b/gnome-base/gnome-desktop/Manifest
@@ -1,2 +1,3 @@
DIST gnome-desktop-40.5.tar.xz 722316 BLAKE2B 1f2e214eaea74295c892a465f767d29175ac0719a66d8d5b60b924c448f7b8317d3f9e23361d65b4d171018edd206dce764c38545a716ad9c83f20214fe5c4e9 SHA512 a65bf42be69d04efd80da6a8c8b08c4adc09db1c6627b93d4eecc3396376bc4407bfad914fc131d16d78b3b3263e635c925ed3dcff92af069525f809bea21afc
DIST gnome-desktop-40.6.tar.xz 722388 BLAKE2B b13fbf4ba6c38a5b26f3275b973f834d41416f7163ccf192a20fc9092af8021d5a9ba34a7a44141b1f6f61a890fee1d3e4a89b047bd0b27c42d4296a98ca88a2 SHA512 0e1bd2c1add0485d6c6cdaf1ba816ad4cbe1dd338d494ff90b09f2ac8cef140433c136b4be4e6832478e4880fb8bfbf3cc931b3925cad29b64eca4573d6c4498
+DIST gnome-desktop-41.2.tar.xz 732788 BLAKE2B 5ae560fb31166db0fff56c3c3afd13a5890a540a748ba0602cee7a2f129facd023104198600379415a8f00f6edf1eba670769810cc0542e4c75dc1deb4da0f57 SHA512 1a520c84f7a781c59bfd8499c87c7049044a59b87033fac078c4a255c8bcaf79f9b614ad20985ea19c245424bb1972af744ad66fdafa5501800ad342b60fb531
diff --git a/gnome-base/gnome-desktop/gnome-desktop-41.2.ebuild b/gnome-base/gnome-desktop/gnome-desktop-41.2.ebuild
new file mode 100644
index 000000000000..2c2f814e2db1
--- /dev/null
+++ b/gnome-base/gnome-desktop/gnome-desktop-41.2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org meson xdg
+
+DESCRIPTION="Library with common API for various GNOME modules"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gnome-desktop/"
+
+LICENSE="GPL-2+ LGPL-2+ FDL-1.1+"
+SLOT="3/19" # subslot = libgnome-desktop-3 soname version
+IUSE="debug gtk-doc +introspection seccomp systemd udev"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+
+COMMON_DEPEND="
+ >=x11-libs/gdk-pixbuf-2.36.5:2[introspection?]
+ >=x11-libs/gtk+-3.3.6:3[X,introspection?]
+ >=dev-libs/glib-2.53.0:2
+ >=gnome-base/gsettings-desktop-schemas-3.27.0[introspection?]
+ x11-misc/xkeyboard-config
+ x11-libs/libxkbcommon
+ app-text/iso-codes
+ systemd? ( sys-apps/systemd:= )
+ udev? ( virtual/libudev:= )
+ seccomp? ( sys-libs/libseccomp )
+
+ x11-libs/cairo:=
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+DEPEND="${COMMON_DEPEND}
+ media-libs/fontconfig
+"
+RDEPEND="${COMMON_DEPEND}
+ seccomp? ( sys-apps/bubblewrap )
+"
+BDEPEND="
+ app-text/docbook-xml-dtd:4.1.2
+ dev-util/gdbus-codegen
+ gtk-doc? ( >=dev-util/gtk-doc-1.14 )
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ x11-base/xorg-proto
+ virtual/pkgconfig
+"
+# Includes X11/Xatom.h in libgnome-desktop/gnome-bg.c which comes from xorg-proto
+
+PATCHES=(
+ "${FILESDIR}"/3.32.2-optional-introspection.patch # add introspection meson option
+)
+
+src_prepare() {
+ # Don't build manual test programs that will never get run
+ sed -i -e "/'test-.*'/d" libgnome-desktop/meson.build || die
+ xdg_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dgnome_distributor=Gentoo
+ -Ddate_in_gnome_version=true
+ -Ddesktop_docs=true
+ $(meson_use debug debug_tools)
+ $(meson_use introspection)
+ $(meson_feature udev)
+ $(meson_feature systemd)
+ $(meson_use gtk-doc gtk_doc)
+ -Dinstalled_tests=false
+ )
+ meson_src_configure
+}