summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnome-extra/cinnamon-control-center
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnome-extra/cinnamon-control-center')
-rw-r--r--gnome-extra/cinnamon-control-center/Manifest2
-rw-r--r--gnome-extra/cinnamon-control-center/cinnamon-control-center-2.4.2-r2.ebuild105
-rw-r--r--gnome-extra/cinnamon-control-center/cinnamon-control-center-2.6.0.ebuild100
-rw-r--r--gnome-extra/cinnamon-control-center/files/cinnamon-control-center-2.2.5-optional.patch93
-rw-r--r--gnome-extra/cinnamon-control-center/files/cinnamon-control-center-2.4.2-networkmanager-version.patch46
-rw-r--r--gnome-extra/cinnamon-control-center/files/cinnamon-control-center-2.6.0-optional.patch99
-rw-r--r--gnome-extra/cinnamon-control-center/metadata.xml12
7 files changed, 457 insertions, 0 deletions
diff --git a/gnome-extra/cinnamon-control-center/Manifest b/gnome-extra/cinnamon-control-center/Manifest
new file mode 100644
index 000000000000..b2b4dc0096c1
--- /dev/null
+++ b/gnome-extra/cinnamon-control-center/Manifest
@@ -0,0 +1,2 @@
+DIST cinnamon-control-center-2.4.2.tar.gz 4305006 SHA256 7d25193a3cc13c12f22864f3c9a907acfaa616392cb2b7ab4e0624f0d200f188 SHA512 c3b4e5af84b7e6e01deaae51ed29e184158860c5effa2550b9d285902c2c35b690cb867ae747b437ed2ac2d0e75b0e6b36c97f9af3c5bf3f4621bdf304d5c253 WHIRLPOOL 41a32cb1c97f0fd3c57d67891c66082b66db6dc5a43737d50fdc6a17819c64d9b58ac2b679baa7f9bdd906643c02c161b4a72fd208b48561cdd43807a58f5621
+DIST cinnamon-control-center-2.6.0.tar.gz 4169903 SHA256 bbc39ac8ddcbc06b6aada1ef271f95f5f0d0fe439bec38b9cd847af420305c49 SHA512 ed383484b751a9d98de7f136c21c5eb6ce7cfe1418945bd0725aa9e9f08397eb78854b38db258434ed8895dbadd2ce29b5a423a9025dea17fb4876f8847ff125 WHIRLPOOL 7e6d3373e97116d5b531f4fcff85984050fd5d7ad343137b76e30089b3c6f4ff5409f68867289f3967a257a67cd04059f2aa02c48a4e0e4c29b43755d6f4cd84
diff --git a/gnome-extra/cinnamon-control-center/cinnamon-control-center-2.4.2-r2.ebuild b/gnome-extra/cinnamon-control-center/cinnamon-control-center-2.4.2-r2.ebuild
new file mode 100644
index 000000000000..af72f34742b3
--- /dev/null
+++ b/gnome-extra/cinnamon-control-center/cinnamon-control-center-2.4.2-r2.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes" # gmodule is used, which uses dlopen
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="Cinnamons's main interface to configure various aspects of the desktop"
+HOMEPAGE="http://cinnamon.linuxmint.com/"
+SRC_URI="https://github.com/linuxmint/cinnamon-control-center/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="+colord +cups input_devices_wacom"
+KEYWORDS="amd64 x86"
+
+# False positives caused by nested configure scripts
+QA_CONFIGURE_OPTIONS=".*"
+
+# FIXME: modemmanager is not optional
+# networkmanager is not optional
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.31:2
+ dev-libs/libxml2:2
+ >=gnome-base/libgnomekbd-2.91.91:0=
+ >=gnome-extra/cinnamon-desktop-1.0:0=
+ >=gnome-extra/cinnamon-menus-1.0:0=
+ >=gnome-extra/cinnamon-settings-daemon-1.0:0=
+ >=gnome-extra/nm-applet-0.9.8
+ media-libs/fontconfig
+ >=media-libs/libcanberra-0.13[gtk3]
+ >=media-sound/pulseaudio-1.1[glib]
+ >=net-misc/modemmanager-0.7
+ >=net-misc/networkmanager-0.9.8[modemmanager]
+ >=sys-auth/polkit-0.103
+ || ( >=sys-power/upower-0.9.1:= sys-power/upower-pm-utils )
+ >=x11-libs/gdk-pixbuf-2.23.0:2
+ >=x11-libs/gtk+-3.4.1:3
+ >=x11-libs/libnotify-0.7.3:0=
+ x11-libs/libX11
+ x11-libs/libxklavier
+ colord? ( >=x11-misc/colord-0.1.8:0= )
+ cups? ( >=net-print/cups-1.4[dbus] )
+ input_devices_wacom? (
+ >=dev-libs/libwacom-0.7
+ >=x11-libs/gtk+-3.8:3
+ >=x11-libs/libXi-1.2 )
+"
+# <gnome-color-manager-3.1.2 has file collisions with g-c-c-3.1.x
+# libgnomekbd needed only for gkbd-keyboard-display tool
+RDEPEND="${COMMON_DEPEND}
+ || ( ( app-admin/openrc-settingsd sys-auth/consolekit ) >=sys-apps/systemd-31 )
+ x11-themes/gnome-icon-theme
+ x11-themes/gnome-icon-theme-symbolic
+ colord? ( >=gnome-extra/gnome-color-manager-3 )
+ cups? (
+ app-admin/system-config-printer
+ net-print/cups-pk-helper )
+ input_devices_wacom? ( gnome-extra/cinnamon-settings-daemon[input_devices_wacom] )
+"
+
+DEPEND="${COMMON_DEPEND}
+ app-text/iso-codes
+ x11-proto/xproto
+ x11-proto/xf86miscproto
+ x11-proto/kbproto
+
+ dev-libs/libxslt
+ >=dev-util/intltool-0.40.1
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+
+ gnome-base/gnome-common
+"
+# Needed for autoreconf
+# gnome-base/gnome-common
+
+src_prepare() {
+ # make some panels optional
+ epatch "${FILESDIR}"/${PN}-2.2.5-optional.patch
+
+ # Fix NM version checking, bug #536850
+ epatch "${FILESDIR}"/${PN}-2.4.2-networkmanager-version.patch
+
+ epatch_user
+
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # --enable-systemd doesn't do anything in $PN-2.2.5
+ gnome2_src_configure \
+ --disable-update-mimedb \
+ --disable-static \
+ --enable-documentation \
+ --without-libsocialweb \
+ $(use_enable colord color) \
+ $(use_enable cups) \
+ $(use_enable input_devices_wacom wacom)
+}
diff --git a/gnome-extra/cinnamon-control-center/cinnamon-control-center-2.6.0.ebuild b/gnome-extra/cinnamon-control-center/cinnamon-control-center-2.6.0.ebuild
new file mode 100644
index 000000000000..7b7384fb9925
--- /dev/null
+++ b/gnome-extra/cinnamon-control-center/cinnamon-control-center-2.6.0.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes" # gmodule is used, which uses dlopen
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="Cinnamons's main interface to configure various aspects of the desktop"
+HOMEPAGE="http://cinnamon.linuxmint.com/"
+SRC_URI="https://github.com/linuxmint/cinnamon-control-center/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="+colord +cups input_devices_wacom"
+KEYWORDS="~amd64 ~x86"
+
+# False positives caused by nested configure scripts
+QA_CONFIGURE_OPTIONS=".*"
+
+# FIXME: modemmanager is not optional
+# networkmanager is not optional
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.31:2
+ dev-libs/libxml2:2
+ >=gnome-base/libgnomekbd-2.91.91:0=
+ >=gnome-extra/cinnamon-desktop-1.0:0=
+ >=gnome-extra/cinnamon-menus-1.0:0=
+ >=gnome-extra/cinnamon-settings-daemon-1.0:0=
+ >=gnome-extra/nm-applet-0.9.8
+ media-libs/fontconfig
+ >=media-libs/libcanberra-0.13[gtk3]
+ >=media-sound/pulseaudio-1.1[glib]
+ >=net-misc/modemmanager-0.7
+ >=net-misc/networkmanager-0.9.8[modemmanager]
+ >=sys-auth/polkit-0.103
+ >=x11-libs/gdk-pixbuf-2.23.0:2
+ >=x11-libs/gtk+-3.4.1:3
+ >=x11-libs/libnotify-0.7.3:0=
+ x11-libs/libX11
+ x11-libs/libxklavier
+ colord? ( >=x11-misc/colord-0.1.14:0= )
+ cups? ( >=net-print/cups-1.4[dbus] )
+ input_devices_wacom? (
+ >=dev-libs/libwacom-0.7
+ >=x11-libs/gtk+-3.8:3
+ >=x11-libs/libXi-1.2 )
+"
+# <gnome-color-manager-3.1.2 has file collisions with g-c-c-3.1.x
+# libgnomekbd needed only for gkbd-keyboard-display tool
+RDEPEND="${COMMON_DEPEND}
+ || ( ( app-admin/openrc-settingsd sys-auth/consolekit ) >=sys-apps/systemd-31 )
+ x11-themes/gnome-icon-theme
+ x11-themes/gnome-icon-theme-symbolic
+ colord? ( >=gnome-extra/gnome-color-manager-3 )
+ cups? (
+ app-admin/system-config-printer
+ net-print/cups-pk-helper )
+ input_devices_wacom? ( gnome-extra/cinnamon-settings-daemon[input_devices_wacom] )
+"
+
+DEPEND="${COMMON_DEPEND}
+ app-text/iso-codes
+ x11-proto/xproto
+ x11-proto/xf86miscproto
+ x11-proto/kbproto
+
+ dev-libs/libxslt
+ >=dev-util/intltool-0.40.1
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+
+ gnome-base/gnome-common
+"
+# Needed for autoreconf
+# gnome-base/gnome-common
+
+src_prepare() {
+ # make some panels optional
+ epatch "${FILESDIR}"/${PN}-2.6.0-optional.patch
+
+ epatch_user
+
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # --enable-systemd doesn't do anything in $PN-2.2.5
+ gnome2_src_configure \
+ --disable-static \
+ --enable-documentation \
+ --without-libsocialweb \
+ $(use_enable colord color) \
+ $(use_enable cups) \
+ $(use_enable input_devices_wacom wacom)
+}
diff --git a/gnome-extra/cinnamon-control-center/files/cinnamon-control-center-2.2.5-optional.patch b/gnome-extra/cinnamon-control-center/files/cinnamon-control-center-2.2.5-optional.patch
new file mode 100644
index 000000000000..e6a1f41c3eff
--- /dev/null
+++ b/gnome-extra/cinnamon-control-center/files/cinnamon-control-center-2.2.5-optional.patch
@@ -0,0 +1,93 @@
+diff --git a/configure.ac b/configure.ac
+index b900c53..0656e18 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -123,7 +123,6 @@ PKG_CHECK_MODULES(MEDIA_PANEL, $COMMON_MODULES)
+ PKG_CHECK_MODULES(NETWORK_PANEL, $COMMON_MODULES)
+ PKG_CHECK_MODULES(POWER_PANEL, $COMMON_MODULES upower-glib >= 0.9.1
+ cinnamon-settings-daemon >= $CSD_REQUIRED_VERSION)
+-PKG_CHECK_MODULES(COLOR_PANEL, $COMMON_MODULES colord >= 0.1.8)
+ PKG_CHECK_MODULES(REGION_PANEL, $COMMON_MODULES libgnomekbd >= 2.91.91
+ polkit-gobject-1 >= $POLKIT_REQUIRED_VERSION
+ libxklavier >= 5.1 libgnomekbdui >= 2.91.91)
+@@ -182,15 +181,51 @@ if test x"$enable_cups" != x"no" ; then
+ AC_SUBST(CUPS_LIBS)
+ fi
+
++build_color=false
++AC_ARG_ENABLE(color,
++ AC_HELP_STRING([--disable-color],
++ [disable color management panel]),
++ [case "${enableval}" in
++ yes) WANT_COLOR=yes ;;
++ no) WANT_COLOR=no ;;
++ *) AC_MSG_ERROR(bad value ${enableval} for --disable-color) ;;
++ esac],
++ [WANT_COLOR=yes]) dnl Default value
++
++if test x$WANT_COLOR = xyes; then
++ PKG_CHECK_MODULES(COLOR_PANEL, $COMMON_MODULES colord >= 0.1.8)
++ build_color=true
++fi
++if test "x$build_color" = xtrue ; then
++ AC_DEFINE(BUILD_COLOR, 1, [Define to 1 to build the Color panel])
++fi
++AM_CONDITIONAL(BUILD_COLOR, test "x$build_color" = "xtrue")
++AC_SUBST(COLOR_PANEL_CFLAGS)
++AC_SUBST(COLOR_PANEL_LIBS)
++
+ build_wacom=false
+-PKG_CHECK_MODULES(WACOM_PANEL, [$COMMON_MODULES
++AC_ARG_ENABLE(wacom,
++ AC_HELP_STRING([--disable-wacom],
++ [disable wacom management panel]),
++ [case "${enableval}" in
++ yes) WANT_WACOM=yes ;;
++ no) WANT_WACOM=no ;;
++ *) AC_MSG_ERROR(bad value ${enableval} for --disable-wacom) ;;
++ esac],
++ [WANT_WACOM=yes]) dnl Default value
++
++if test x$WANT_WACOM = xyes; then
++ PKG_CHECK_MODULES(WACOM_PANEL, [$COMMON_MODULES
+ cinnamon-settings-daemon >= $CSD_REQUIRED_VERSION
+ xi >= 1.2 x11 libwacom >= $LIBWACOM_REQUIRED_VERSION
+ cinnamon-desktop
+- gtk+-3.0 >= 3.8.0],
+- [build_wacom="true" AC_DEFINE(HAVE_WACOM, 1, [Define if wacom is being build])], [build_wacom="false"])
+-
++ gtk+-3.0 >= 3.8.0])
++ build_wacom="true"
++ AC_DEFINE(HAVE_WACOM, 1, [Define if wacom is being build])]
++fi
+ AM_CONDITIONAL(BUILD_WACOM, test "x$build_wacom" = "xtrue")
++AC_SUBST(WACOM_PANEL_CFLAGS)
++AC_SUBST(WACOM_PANEL_LIBS)
+
+ # This is a hard-dependency for the region and user-accounts panels
+ PKG_CHECK_MODULES(ISOCODES, iso-codes)
+diff --git a/panels/Makefile.am b/panels/Makefile.am
+index ff8ea98..4a7fba7 100644
+--- a/panels/Makefile.am
++++ b/panels/Makefile.am
+@@ -3,7 +3,6 @@ NULL =
+ enabled_panels = \
+ common \
+ screen \
+- color \
+ display \
+ region \
+ universal-access \
+@@ -15,6 +14,12 @@ enabled_panels = \
+
+ disabled_panels = $(NULL)
+
++if BUILD_COLOR
++enabled_panels += color
++else
++disabled_panels += color
++endif
++
+ if BUILD_WACOM
+ enabled_panels += wacom
+ else
diff --git a/gnome-extra/cinnamon-control-center/files/cinnamon-control-center-2.4.2-networkmanager-version.patch b/gnome-extra/cinnamon-control-center/files/cinnamon-control-center-2.4.2-networkmanager-version.patch
new file mode 100644
index 000000000000..7c2078f1095e
--- /dev/null
+++ b/gnome-extra/cinnamon-control-center/files/cinnamon-control-center-2.4.2-networkmanager-version.patch
@@ -0,0 +1,46 @@
+--- panels/network/cc-network-panel.c.old 2015-01-17 16:35:04.395520484 +0100
++++ panels/network/cc-network-panel.c 2015-01-17 16:36:11.706685966 +0100
+@@ -1311,30 +1311,18 @@
+ panel_check_network_manager_version (CcNetworkPanel *panel)
+ {
+ const gchar *version;
+- gchar **split = NULL;
+- guint major = 0;
+- guint micro = 0;
+- guint minor = 0;
+ gboolean ret = TRUE;
+
+ /* parse running version */
+ version = nm_client_get_version (panel->priv->client);
+- if (version != NULL) {
+- split = g_strsplit (version, ".", -1);
+- major = atoi (split[0]);
+- minor = atoi (split[1]);
+- micro = atoi (split[2]);
+- }
+
+- /* is it too new or old */
+- if (major > 0 || minor > 9 || (minor <= 8 && micro < 992)) {
++ if (version == NULL) {
+ ret = FALSE;
+
+ /* do modal dialog in idle so we don't block startup */
+ panel->priv->nm_warning_idle = g_idle_add ((GSourceFunc)display_version_warning_idle, panel);
+ }
+
+- g_strfreev (split);
+ return ret;
+ }
+
+@@ -1381,8 +1369,9 @@
+ {
+ gboolean ret;
+
+- /* is the user compiling against a new version, but running an
+- * old daemon version? */
++ /* is the user compiling against a new version, but not running
++ * the daemon? */
++
+ ret = panel_check_network_manager_version (panel);
+ if (ret) {
+ manager_running (panel->priv->client, NULL, panel);
diff --git a/gnome-extra/cinnamon-control-center/files/cinnamon-control-center-2.6.0-optional.patch b/gnome-extra/cinnamon-control-center/files/cinnamon-control-center-2.6.0-optional.patch
new file mode 100644
index 000000000000..b76405c28dad
--- /dev/null
+++ b/gnome-extra/cinnamon-control-center/files/cinnamon-control-center-2.6.0-optional.patch
@@ -0,0 +1,99 @@
+diff --git a/configure.ac b/configure.ac
+index 144bf78..a83e1eb 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -121,7 +121,6 @@ PKG_CHECK_MODULES(DISPLAY_PANEL, $COMMON_MODULES cinnamon-desktop x11)
+ PKG_CHECK_MODULES(MEDIA_PANEL, $COMMON_MODULES)
+
+ PKG_CHECK_MODULES(NETWORK_PANEL, $COMMON_MODULES gmodule-2.0)
+-PKG_CHECK_MODULES(COLOR_PANEL, $COMMON_MODULES colord >= 0.1.14)
+ PKG_CHECK_MODULES(REGION_PANEL, $COMMON_MODULES libgnomekbd >= 2.91.91
+ polkit-gobject-1 >= $POLKIT_REQUIRED_VERSION
+ libxklavier >= 5.1 libgnomekbdui >= 2.91.91)
+@@ -197,15 +196,51 @@ if test x"$enable_cups" != x"no" ; then
+ AC_SUBST(CUPS_LIBS)
+ fi
+
++build_color=false
++AC_ARG_ENABLE(color,
++ AC_HELP_STRING([--disable-color],
++ [disable color management panel]),
++ [case "${enableval}" in
++ yes) WANT_COLOR=yes ;;
++ no) WANT_COLOR=no ;;
++ *) AC_MSG_ERROR(bad value ${enableval} for --disable-color) ;;
++ esac],
++ [WANT_COLOR=yes]) dnl Default value
++
++if test x$WANT_COLOR = xyes; then
++ PKG_CHECK_MODULES(COLOR_PANEL, $COMMON_MODULES colord >= 0.1.14)
++ build_color=true
++fi
++if test "x$build_color" = xtrue ; then
++ AC_DEFINE(BUILD_COLOR, 1, [Define to 1 to build the Color panel])
++fi
++AM_CONDITIONAL(BUILD_COLOR, test "x$build_color" = "xtrue")
++AC_SUBST(COLOR_PANEL_CFLAGS)
++AC_SUBST(COLOR_PANEL_LIBS)
++
+ build_wacom=false
+-PKG_CHECK_MODULES(WACOM_PANEL, [$COMMON_MODULES
++AC_ARG_ENABLE(wacom,
++ AC_HELP_STRING([--disable-wacom],
++ [disable wacom management panel]),
++ [case "${enableval}" in
++ yes) WANT_WACOM=yes ;;
++ no) WANT_WACOM=no ;;
++ *) AC_MSG_ERROR(bad value ${enableval} for --disable-wacom) ;;
++ esac],
++ [WANT_WACOM=yes]) dnl Default value
++
++if test x$WANT_WACOM = xyes; then
++ PKG_CHECK_MODULES(WACOM_PANEL, [$COMMON_MODULES
+ cinnamon-settings-daemon >= $CSD_REQUIRED_VERSION
+ xi >= 1.2 x11 libwacom >= $LIBWACOM_REQUIRED_VERSION
+ cinnamon-desktop
+- gtk+-3.0 >= 3.8.0],
+- [build_wacom="true" AC_DEFINE(HAVE_WACOM, 1, [Define if wacom is being build])], [build_wacom="false"])
+-
++ gtk+-3.0 >= 3.8.0])
++ build_wacom="true"
++ AC_DEFINE(HAVE_WACOM, 1, [Define if wacom is being build])]
++fi
+ AM_CONDITIONAL(BUILD_WACOM, test "x$build_wacom" = "xtrue")
++AC_SUBST(WACOM_PANEL_CFLAGS)
++AC_SUBST(WACOM_PANEL_LIBS)
+
+ # This is a hard-dependency for the region and user-accounts panels
+ PKG_CHECK_MODULES(ISOCODES, iso-codes)
+@@ -408,6 +443,13 @@ fi
+ #else
+ # AC_MSG_NOTICE([ Using ConsoleKit for session tracking])
+ #fi
++
++if test "x$build_color" = "xtrue"; then
++ AC_MSG_NOTICE([** Colord support (Color management panel)])
++else
++ AC_MSG_NOTICE([ Colord support disabled])
++fi
++
+ if test "x$build_wacom" = "xtrue"; then
+ AC_MSG_NOTICE([** Wacom support (Wacom panel)])
+ else
+diff --git a/panels/Makefile.am b/panels/Makefile.am
+index 76fbc88..466c2c6 100644
+--- a/panels/Makefile.am
++++ b/panels/Makefile.am
+@@ -18,6 +18,12 @@ else
+ disabled_panels += network
+ endif
+
++if BUILD_COLOR
++enabled_panels += color
++else
++disabled_panels += color
++endif
++
+ if BUILD_WACOM
+ enabled_panels += wacom
+ else
diff --git a/gnome-extra/cinnamon-control-center/metadata.xml b/gnome-extra/cinnamon-control-center/metadata.xml
new file mode 100644
index 000000000000..1d34d2fb151e
--- /dev/null
+++ b/gnome-extra/cinnamon-control-center/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome</herd>
+ <use>
+ <flag name="colord">Support color management using
+ <pkg>x11-misc/colord</pkg></flag>
+ </use>
+ <upstream>
+ <remote-id type="github">linuxmint/cinnamon-control-center</remote-id>
+ </upstream>
+</pkgmetadata>