summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-01-09 21:56:41 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-01-11 12:57:33 +0100
commitf6715ca3cbae4a86fa3d1bf06b8715ab9993b62d (patch)
tree72a0bfcfb86060aaa36f5f6f1fde215886025cce /gnome-extra
parentnet-analyzer/bwping: Old (diff)
downloadgentoo-f6715ca3cbae4a86fa3d1bf06b8715ab9993b62d.tar.gz
gentoo-f6715ca3cbae4a86fa3d1bf06b8715ab9993b62d.tar.bz2
gentoo-f6715ca3cbae4a86fa3d1bf06b8715ab9993b62d.zip
gnome-extra/gnome-color-manager: Fix build with exiv2-0.27
Using exiv2.hpp instead of individual includes is exiv2 recommendation for some time already while the headers are subject to refactoring. Standard fix as seen in other affected packages. Closes: https://bugs.gentoo.org/674086 Package-Manager: Portage-2.3.54, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-color-manager/files/gnome-color-manager-3.24.0-exiv2-0.27.patch41
-rw-r--r--gnome-extra/gnome-color-manager/gnome-color-manager-3.24.0.ebuild7
-rw-r--r--gnome-extra/gnome-color-manager/gnome-color-manager-3.30.0-r1.ebuild5
3 files changed, 51 insertions, 2 deletions
diff --git a/gnome-extra/gnome-color-manager/files/gnome-color-manager-3.24.0-exiv2-0.27.patch b/gnome-extra/gnome-color-manager/files/gnome-color-manager-3.24.0-exiv2-0.27.patch
new file mode 100644
index 000000000000..00878bc26a85
--- /dev/null
+++ b/gnome-extra/gnome-color-manager/files/gnome-color-manager-3.24.0-exiv2-0.27.patch
@@ -0,0 +1,41 @@
+Patch kindly borrowed from Mageia.
+
+https://gitlab.gnome.org/GNOME/gnome-color-manager/issues/4
+
+diff -Nru a/src/gcm-helper-exiv.cpp b/src/gcm-helper-exiv.cpp
+--- a/src/gcm-helper-exiv.cpp 2018-09-04 13:50:05.000000000 +0200
++++ b/src/gcm-helper-exiv.cpp 2018-12-31 15:39:52.288495398 +0100
+@@ -19,8 +19,7 @@
+ * Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+ */
+
+-#include <exiv2/image.hpp>
+-#include <exiv2/exif.hpp>
++#include <exiv2/exiv2.hpp>
+ #include <iostream>
+ #include <iomanip>
+
+@@ -51,7 +50,11 @@
+ if (argc == 2)
+ filename = argv[1];
+ if (filename.empty())
++#if EXIV2_TEST_VERSION(0,27,0)
++ throw Exiv2::Error(Exiv2::kerErrorMessage, "No filename specified");
++#else
+ throw Exiv2::Error(1, "No filename specified");
++#endif
+ image = Exiv2::ImageFactory::open(filename);
+ image->readMetadata();
+
+@@ -60,7 +63,11 @@
+ if (exifData.empty()) {
+ std::string error(argv[1]);
+ error += ": No Exif data found in the file";
++#if EXIV2_TEST_VERSION(0,27,0)
++ throw Exiv2::Error(Exiv2::kerErrorMessage, error);
++#else
+ throw Exiv2::Error(1, error);
++#endif
+ }
+
+ /* try to find make, model and serial number */
diff --git a/gnome-extra/gnome-color-manager/gnome-color-manager-3.24.0.ebuild b/gnome-extra/gnome-color-manager/gnome-color-manager-3.24.0.ebuild
index 441b966300cd..3ab3d64df806 100644
--- a/gnome-extra/gnome-color-manager/gnome-color-manager-3.24.0.ebuild
+++ b/gnome-extra/gnome-color-manager/gnome-color-manager-3.24.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -39,6 +39,11 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
"
+PATCHES=(
+ # https://gitlab.gnome.org/GNOME/gnome-color-manager/issues/4
+ "${FILESDIR}"/${P}-exiv2-0.27.patch # bug 674086
+)
+
src_configure() {
# Always enable tests since they are check_PROGRAMS anyway
# appstream does not want to be relax by default !
diff --git a/gnome-extra/gnome-color-manager/gnome-color-manager-3.30.0-r1.ebuild b/gnome-extra/gnome-color-manager/gnome-color-manager-3.30.0-r1.ebuild
index 5f035f751268..4048b8ef3bf5 100644
--- a/gnome-extra/gnome-color-manager/gnome-color-manager-3.30.0-r1.ebuild
+++ b/gnome-extra/gnome-color-manager/gnome-color-manager-3.30.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -42,6 +42,9 @@ DEPEND="${RDEPEND}
PATCHES=(
# https://bugzilla.gnome.org/show_bug.cgi?id=796428
"${FILESDIR}"/3.28-remove-unwvanted-check.patch
+
+ # https://gitlab.gnome.org/GNOME/gnome-color-manager/issues/4
+ "${FILESDIR}"/${PN}-3.24.0-exiv2-0.27.patch # bug 674086
)
src_prepare() {