summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-05-26 20:07:54 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-05-26 20:12:32 +0300
commit42c78621cb0db28ec47fe2701ce100e62354f126 (patch)
tree946e185994f9792c6fecf6f4a1f77f26313cfb00 /gui-apps
parentdev-python/numpy: Clean deselects up for 2.x (diff)
downloadgentoo-42c78621cb0db28ec47fe2701ce100e62354f126.tar.gz
gentoo-42c78621cb0db28ec47fe2701ce100e62354f126.tar.bz2
gentoo-42c78621cb0db28ec47fe2701ce100e62354f126.zip
gui-apps/mako: add 1.9.0
Closes: https://bugs.gentoo.org/920102 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/mako/Manifest1
-rw-r--r--gui-apps/mako/mako-1.9.0.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/gui-apps/mako/Manifest b/gui-apps/mako/Manifest
index 47e3b7079483..2255028c5408 100644
--- a/gui-apps/mako/Manifest
+++ b/gui-apps/mako/Manifest
@@ -1 +1,2 @@
DIST mako-1.8.0.tar.gz 63143 BLAKE2B da39c1d2a1748649432d2760831cee7c9b135114b8e36c48a87900d9a3610fc5103c15f2ed511344d84a3142aa76ddd3680177318d0e096ad0574952632dc0b7 SHA512 d187c00296f3c3d4fb2c5964a95e1ac6ab74deb7dc27633d8e8301d60d90e4dc92b0ee66953670c42a3c08160536a4126ee747214c4ea05a30a80fd5e2004ad0
+DIST mako-1.9.0.tar.gz 63415 BLAKE2B 932f045cede44f79e4039a40118cdd4283413f86524d74703e84a3bf999af58d9ee605054480d369a33f81c7fcaed60415cb203fd32a22333adc1e88876f6a33 SHA512 da9c89dc698e44100960c9911c9da59e6f3dd5e95c8c0fbc489c9597dd614bb46074170b9621eba6ff692eff140f7be11ecc9da1a285b8e5c0975b7b53daabee
diff --git a/gui-apps/mako/mako-1.9.0.ebuild b/gui-apps/mako/mako-1.9.0.ebuild
new file mode 100644
index 000000000000..29e50118f3ba
--- /dev/null
+++ b/gui-apps/mako/mako-1.9.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson systemd
+
+DESCRIPTION="A lightweight notification daemon for Wayland. Works on Sway"
+HOMEPAGE="https://github.com/emersion/mako"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/emersion/${PN}.git"
+else
+ SRC_URI="https://github.com/emersion/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="elogind +icons systemd"
+
+RDEPEND="
+ dev-libs/wayland
+ x11-libs/pango
+ x11-libs/cairo
+ || (
+ systemd? ( sys-apps/systemd )
+ elogind? ( sys-auth/elogind )
+ sys-libs/basu
+ )
+ sys-apps/dbus
+ icons? (
+ x11-libs/gdk-pixbuf
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ >=dev-libs/wayland-protocols-1.32
+"
+BDEPEND="
+ app-text/scdoc
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dicons=$(usex icons enabled disabled)
+ -Dzsh-completions=true
+ -Dfish-completions=true
+ -Dbash-completions=true
+ )
+
+ if use systemd ; then
+ emesonargs+=( -Dsd-bus-provider=libsystemd )
+ elif use elogind ; then
+ emesonargs+=( -Dsd-bus-provider=libelogind )
+ else
+ emesonargs+=( -Dsd-bus-provider=basu )
+ fi
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ systemd_douserunit contrib/systemd/mako.service
+}