summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-12-14 23:14:45 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-12-14 23:25:03 +0100
commit576fc933c81aa6e526d87290af95e8e898e70ecb (patch)
tree73f9a202bcb454043dbb6b731d9b56ed4c5f49eb /kde-apps/kdepim-runtime
parentdev-haskell/stack-bin: bump up to 1.6.1 (diff)
downloadgentoo-576fc933c81aa6e526d87290af95e8e898e70ecb.tar.gz
gentoo-576fc933c81aa6e526d87290af95e8e898e70ecb.tar.bz2
gentoo-576fc933c81aa6e526d87290af95e8e898e70ecb.zip
kde-apps: Add KDE Applications 17.12.0
Package-Manager: Portage-2.3.18, Repoman-2.3.6
Diffstat (limited to 'kde-apps/kdepim-runtime')
-rw-r--r--kde-apps/kdepim-runtime/Manifest1
-rw-r--r--kde-apps/kdepim-runtime/kdepim-runtime-17.12.0.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/kde-apps/kdepim-runtime/Manifest b/kde-apps/kdepim-runtime/Manifest
index 0548126fa613..ac281b3e0aa0 100644
--- a/kde-apps/kdepim-runtime/Manifest
+++ b/kde-apps/kdepim-runtime/Manifest
@@ -1 +1,2 @@
DIST kdepim-runtime-17.08.3.tar.xz 1507128 BLAKE2B 38e188c579f35a8f01d559e4333a75ec54f61815133047531db7bd3af31981a66f6d921e60dca75c825de6c8d760f1636ca790c267698f10f245f9402fabdab5 SHA512 fbc13a0b92d47d057ff94101485e9e76eddd002c51d1696146313f6fa5be412759b44c1f24e0a4d1282140b985926370310de77cec7f9281771d15e6d5c919f2
+DIST kdepim-runtime-17.12.0.tar.xz 1789740 BLAKE2B 5b70886235aec4c33f3126add2165bc22aedcb6f159b8eaf73a6fdd1a9059dbc12a93e18ffb7a17d00b93208938d2936e3cd00c3f2ffbd17c16b1a0765f44946 SHA512 12f40edc7842a9345a3f4364b9e9b6484d9cdcaf18803a11d1dc0ee5a918a4eaf95f84f21813600e32780c84e9119cbccf94e4cf89242006438469f5cae925c9
diff --git a/kde-apps/kdepim-runtime/kdepim-runtime-17.12.0.ebuild b/kde-apps/kdepim-runtime/kdepim-runtime-17.12.0.ebuild
new file mode 100644
index 000000000000..4db884e4963f
--- /dev/null
+++ b/kde-apps/kdepim-runtime/kdepim-runtime-17.12.0.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="forceoptional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Runtime plugin collection to extend the functionality of KDE PIM"
+LICENSE="GPL-2+ LGPL-2.1+"
+KEYWORDS="~amd64 ~x86"
+IUSE="speech"
+
+# TODO kolab
+CDEPEND="
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep knotifyconfig)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_kdeapps_dep akonadi)
+ $(add_kdeapps_dep akonadi-calendar)
+ $(add_kdeapps_dep akonadi-contacts)
+ $(add_kdeapps_dep akonadi-mime)
+ $(add_kdeapps_dep akonadi-notes)
+ $(add_kdeapps_dep kalarmcal)
+ $(add_kdeapps_dep kcalcore)
+ $(add_kdeapps_dep kcalutils)
+ $(add_kdeapps_dep kcontacts)
+ $(add_kdeapps_dep kdav)
+ $(add_kdeapps_dep kidentitymanagement)
+ $(add_kdeapps_dep kimap)
+ $(add_kdeapps_dep kmailtransport)
+ $(add_kdeapps_dep kmbox)
+ $(add_kdeapps_dep kmime)
+ $(add_kdeapps_dep libkgapi)
+ $(add_kdeapps_dep pimcommon)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwebengine 'widgets')
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ dev-libs/cyrus-sasl:2
+ dev-libs/libical:=
+ speech? ( $(add_qt_dep qtspeech) )
+"
+DEPEND="${CDEPEND}
+ $(add_qt_dep qtxmlpatterns)
+ dev-libs/libxslt
+ test? ( $(add_kdeapps_dep kimap 'test') )
+"
+RDEPEND="${CDEPEND}
+ !kde-apps/kdepim-l10n
+ $(add_frameworks_dep oxygen-icons)
+"
+
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package speech Qt5TextToSpeech)
+ )
+
+ kde5_src_configure
+}