summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-09-12 22:52:37 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-09-13 07:18:47 +0200
commit9b9e2943a43f23b7ad4818dfdd2ac43f11109c21 (patch)
tree75e2f7972b1f285202c309f03a11ce7cf597b86e /kde-frameworks/kcompletion
parentkde-frameworks/kauth: 5.86.0 version bump (diff)
downloadgentoo-9b9e2943a43f23b7ad4818dfdd2ac43f11109c21.tar.gz
gentoo-9b9e2943a43f23b7ad4818dfdd2ac43f11109c21.tar.bz2
gentoo-9b9e2943a43f23b7ad4818dfdd2ac43f11109c21.zip
kde-frameworks/kcompletion: 5.86.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kcompletion')
-rw-r--r--kde-frameworks/kcompletion/Manifest1
-rw-r--r--kde-frameworks/kcompletion/kcompletion-5.86.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/kde-frameworks/kcompletion/Manifest b/kde-frameworks/kcompletion/Manifest
index 4518ff2a1469..5ef787495471 100644
--- a/kde-frameworks/kcompletion/Manifest
+++ b/kde-frameworks/kcompletion/Manifest
@@ -1,2 +1,3 @@
DIST kcompletion-5.82.0.tar.xz 122088 BLAKE2B ce534393489d6ab980d3c093ef39b3d2341734e147231e6f22c5316091bafd40ef343432128926ec18e25ec8d3843018fa582bd2dc7475bb3c260e42452cc949 SHA512 19b76a46d09005ed5ab5b66ca48403f4bb0baade2b2f937ad6afdf5ef92adf7c94330502adc3aae29bb88fc5848469580319cbf4bba4bfa128537f4541fd9d24
DIST kcompletion-5.85.0.tar.xz 122020 BLAKE2B 064b6074827722ceb852faa93c0a1132ab8dfb7496eddcb951deb52d9b6acfbaaf0cf2ef5f74449889998b734b4db9d9114972ceb2017ccf26dcb1a25c1cf5d4 SHA512 c10cf1e5710dc7cabc107b8e9320f79a3eda28bc7ca386853043fbc229736ad10f1ea3bdd2cd77c4a1c0ffa4f0e7407bd400929d0d4bb8d61afa8832889b31a0
+DIST kcompletion-5.86.0.tar.xz 122128 BLAKE2B a7961e83c7d33acac6a38d0047bb77d06fa1092557ead25d777883f7dca70080e54741c2bdc8abc1c370652d61e1418e73c12ec0595a901b157169525f041912 SHA512 43a2a7a2af704d4e1f44ef053bb9d652a14497bdb3145336aed5636d8ecc2f7279f7e12eb0dde0f153e3a417cbd6ce1548e11133455754f19e4a00ec330bba19
diff --git a/kde-frameworks/kcompletion/kcompletion-5.86.0.ebuild b/kde-frameworks/kcompletion/kcompletion-5.86.0.ebuild
new file mode 100644
index 000000000000..f0f1b4037efe
--- /dev/null
+++ b/kde-frameworks/kcompletion/kcompletion-5.86.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_DESIGNERPLUGIN="true"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework for common completion tasks such as filename or URL completion"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="nls"
+
+BDEPEND="
+ nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
+"
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_PythonModuleGeneration=ON # bug 746866
+ )
+ ecm_src_configure
+}