summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-10-11 14:48:31 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-10-11 14:57:31 +0200
commit1eb0916445e9eb47c392eeda3a38977355aa2798 (patch)
treee8746f924518e5aa66dc8dd69f3aa4b965c4f7aa /kde-frameworks
parentkde-frameworks/kxmlgui: 6.7.0 version bump (diff)
downloadgentoo-1eb0916445e9eb47c392eeda3a38977355aa2798.tar.gz
gentoo-1eb0916445e9eb47c392eeda3a38977355aa2798.tar.bz2
gentoo-1eb0916445e9eb47c392eeda3a38977355aa2798.zip
kde-frameworks/purpose: 6.7.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks')
-rw-r--r--kde-frameworks/purpose/Manifest1
-rw-r--r--kde-frameworks/purpose/purpose-6.7.0.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/kde-frameworks/purpose/Manifest b/kde-frameworks/purpose/Manifest
index 28ca302ee533..ef3859dfff75 100644
--- a/kde-frameworks/purpose/Manifest
+++ b/kde-frameworks/purpose/Manifest
@@ -1,2 +1,3 @@
DIST purpose-5.116.0.tar.xz 181148 BLAKE2B 9b4b267128511929fe0e81256f046552a1d70654c9a3e46ca52c2e5035003f96bf42cebf91b2ff0c19d8ca846b3dbd9106d5fd2df5dda11ec17c16bb8c419447 SHA512 3447135ad33c725e0512c6b20a9be81082737146fa0c5a32b0c7d50a21cb5697b2b4796d1cbffc8661dd845ee3ef51bc57af0c94cce0ed14cc1542df822139d5
DIST purpose-6.6.0.tar.xz 176800 BLAKE2B ca9bf9a881935f2e20bc734d248a15a5fdfbd66cb953ec8284190c962369704093351199560e229caa6e7f5e0110bf1e2ed4447c7bb137562613d0a2d82ded2e SHA512 bc12591f5dccb322cd447a275fa6e35d68e2d7762b09464f10c6f63a8f66e47a45be3693eb289475c581e12d9c316ae8d288b7b29f671068c7b05f757d248811
+DIST purpose-6.7.0.tar.xz 177848 BLAKE2B ef67904e26edfec2cf19b461fd3060f134af17260ac483c7f893e6cc61afc12911cb587bcdd48034e0f49c87b46f394a8ad3cbb30f3786984d06312cd00bda02 SHA512 1366cdc84ae063ef07ff86f70f41b54f808b4a06d9a0864ef30c5457511254cc9c63c5521baa9dcfd1cc7ab066fc35c9acc11f41f94c799674a1e75b195d1d3b
diff --git a/kde-frameworks/purpose/purpose-6.7.0.ebuild b/kde-frameworks/purpose/purpose-6.7.0.ebuild
new file mode 100644
index 000000000000..696bfc2ba67d
--- /dev/null
+++ b/kde-frameworks/purpose/purpose-6.7.0.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="false"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-2)
+QTMIN=6.6.2
+inherit ecm frameworks.kde.org optfeature xdg-utils
+
+DESCRIPTION="Library for providing abstractions to get the developer's purposes fulfilled"
+
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="bluetooth webengine"
+
+# requires running environment
+RESTRICT="test"
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[dbus,gui,network,widgets]
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ =kde-frameworks/kconfig-${PVCUT}*:6
+ =kde-frameworks/kcoreaddons-${PVCUT}*:6
+ =kde-frameworks/ki18n-${PVCUT}*:6
+ =kde-frameworks/kio-${PVCUT}*:6
+ =kde-frameworks/kirigami-${PVCUT}*:6
+ =kde-frameworks/knotifications-${PVCUT}*:6
+ =kde-frameworks/kservice-${PVCUT}*:6
+ =kde-frameworks/prison-${PVCUT}*:6
+ webengine? (
+ kde-apps/kaccounts-integration:6
+ >=net-libs/accounts-qt-1.17[qt6(+)]
+ )
+"
+RDEPEND="${DEPEND}
+ >=kde-frameworks/kdeclarative-${PVCUT}:6
+ bluetooth? ( =kde-frameworks/bluez-qt-${PVCUT}*:6 )
+ webengine? (
+ >=kde-frameworks/purpose-kaccounts-services-${PVCUT}
+ >=net-libs/accounts-qml-0.7_p20231028[qt6(+)]
+ )
+"
+BDEPEND="webengine? ( dev-util/intltool )"
+
+src_prepare() {
+ ecm_src_prepare
+
+ use bluetooth ||
+ cmake_run_in src/plugins cmake_comment_add_subdirectory bluetooth
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package webengine KAccounts6)
+ )
+
+ ecm_src_configure
+}
+
+src_install() {
+ # Shipped by kde-frameworks/purpose-kaccounts-services package for shared use w/ SLOT 5
+ use webengine && ECM_REMOVE_FROM_INSTALL=(
+ /usr/share/accounts/services/kde/{google-youtube,nextcloud-upload}.service
+ )
+ ecm_src_install
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "Send through KDE Connect" kde-misc/kdeconnect
+ fi
+ ecm_pkg_postinst
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}