summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-08 20:58:12 +0100
committerSam James <sam@gentoo.org>2022-10-08 21:01:33 +0100
commit8156ffa479c4c0e8582393c1ec0bf5c1934fe6ec (patch)
tree5e75daf08008e0a9d9477c8450b11e49a4525a9a /media-gfx/cropgui/cropgui-0.5.ebuild
parentdev-util/goland: fix DeprecatedEclass (eutils) (diff)
downloadgentoo-8156ffa479c4c0e8582393c1ec0bf5c1934fe6ec.tar.gz
gentoo-8156ffa479c4c0e8582393c1ec0bf5c1934fe6ec.tar.bz2
gentoo-8156ffa479c4c0e8582393c1ec0bf5c1934fe6ec.zip
media-gfx/cropgui: drop 0.4.1, 0.5, 0.6
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx/cropgui/cropgui-0.5.ebuild')
-rw-r--r--media-gfx/cropgui/cropgui-0.5.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/media-gfx/cropgui/cropgui-0.5.ebuild b/media-gfx/cropgui/cropgui-0.5.ebuild
deleted file mode 100644
index ed810b818119..000000000000
--- a/media-gfx/cropgui/cropgui-0.5.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-inherit eutils python-r1 desktop xdg-utils
-
-DESCRIPTION="GUI for lossless cropping of jpeg images"
-HOMEPAGE="https://emergent.unpythonic.net/01248401946"
-SRC_URI="https://github.com/jepler/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="${PYTHON_DEPS}"
-RDEPEND="${PYTHON_DEPS}
- dev-python/pillow[${PYTHON_USEDEP}]
- dev-python/pygobject:3[${PYTHON_USEDEP}]"
-
-install_cropgui_wrapper() {
- python_domodule cropgtk.py cropgui_common.py filechooser.py cropgui.glade
- make_wrapper "${PN}.tmp" "${PYTHON} $(python_get_sitedir)/${PN}/cropgtk.py"
- python_newexe "${ED}/usr/bin/${PN}.tmp" "${PN}"
- rm "${ED}/usr/bin/${PN}.tmp" || die
-}
-
-src_install() {
- python_moduleinto "${PN}"
- python_foreach_impl install_cropgui_wrapper
-
- domenu "${PN}.desktop"
- doicon "${PN}.png"
-}
-
-pkg_postinst() {
- xdg_desktop_database_update
-}
-
-pkg_postrm() {
- xdg_desktop_database_update
-}