summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-09-30 02:12:15 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-09-30 06:37:03 -0400
commite01b668c85341d8f6f7ddb7dfad4ed8fbef447dc (patch)
tree575fe05a56c39a4fd92e9ec26caff9f8168369f4 /media-gfx/transfig
parentgames-misc/xcruiser: force gcc -E for imake's generation (diff)
downloadgentoo-e01b668c85341d8f6f7ddb7dfad4ed8fbef447dc.tar.gz
gentoo-e01b668c85341d8f6f7ddb7dfad4ed8fbef447dc.tar.bz2
gentoo-e01b668c85341d8f6f7ddb7dfad4ed8fbef447dc.zip
media-gfx/transfig: force gcc -E for imake's generation
Requires traditional cpp support and is broken in all sort of ways with clang-cpp / -E. Ideally these packages need to be built another way or last rited, imake will just accumulate more problems. wrt #870955 this gets further but is still broken with clang16 due to implicit declarations and likely more. Bug: https://bugs.gentoo.org/870955 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'media-gfx/transfig')
-rw-r--r--media-gfx/transfig/transfig-3.2.5e-r1.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/media-gfx/transfig/transfig-3.2.5e-r1.ebuild b/media-gfx/transfig/transfig-3.2.5e-r1.ebuild
index eba86b40a63e..51f33e7fd865 100644
--- a/media-gfx/transfig/transfig-3.2.5e-r1.ebuild
+++ b/media-gfx/transfig/transfig-3.2.5e-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -26,6 +26,7 @@ RDEPEND="
DEPEND="${RDEPEND}"
BDEPEND="
app-text/rman
+ sys-devel/gcc
>=x11-misc/imake-1.0.8-r1"
PATCHES=(
@@ -73,7 +74,7 @@ src_prepare() {
}
src_configure() {
- export IMAKECPP=${IMAKECPP:-$(tc-getCPP)}
+ export IMAKECPP=${IMAKECPP:-${CHOST}-gcc -E}
CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" xmkmf || die
}