summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-31 07:39:04 +0100
committerSam James <sam@gentoo.org>2023-05-31 07:56:27 +0100
commit1e355a878b25f04e312e370946575fab5a0a785e (patch)
tree39670e737a31eb72975c904ed110d0d5ff85fc2a /media-libs/dav1d
parentmedia-video/rav1e: add 0.6.6 (diff)
downloadgentoo-1e355a878b25f04e312e370946575fab5a0a785e.tar.gz
gentoo-1e355a878b25f04e312e370946575fab5a0a785e.tar.bz2
gentoo-1e355a878b25f04e312e370946575fab5a0a785e.zip
media-libs/dav1d: add 1.2.0
Bug: https://bugs.gentoo.org/906107 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/dav1d')
-rw-r--r--media-libs/dav1d/Manifest1
-rw-r--r--media-libs/dav1d/dav1d-1.2.0.ebuild61
-rw-r--r--media-libs/dav1d/dav1d-9999.ebuild12
3 files changed, 69 insertions, 5 deletions
diff --git a/media-libs/dav1d/Manifest b/media-libs/dav1d/Manifest
index e86337963637..ca7a24914b9a 100644
--- a/media-libs/dav1d/Manifest
+++ b/media-libs/dav1d/Manifest
@@ -1,3 +1,4 @@
DIST dav1d-0.9.2.tar.bz2 833722 BLAKE2B b05edd1ca627906e57923be08f1ecd73469f9a8e2ed585edf81f1fe1ffc173f1e4ba52eb766b82d9ea1349a6c1cf2a5a48cc9a5bcf2debeb9d640d9842e266f4 SHA512 adfb822734a3fc8b73e9cf5f757bfd78fb144b00d95f1e942254c5caf1d801b05438d39571486ef37a94d2226166937fc56160a862e8d6d45c4f6d790531dc3f
DIST dav1d-1.0.0.tar.bz2 960470 BLAKE2B 79355eeceea37df81e30be49dfea3dee9747fbbb82c0a08be3bbda525881112a8eb847afe3c3ccd0447fd6ee67ae540c5120ea00d4f891ac422850c611850c97 SHA512 86c6481e787fb6b8c28521e1efb1876d1be99f5fa5332cddab1111059b44775e05203cfc5c80a1b404ee00f35a1f5e1099e21b1f0851d77fb0101567e8b1a892
DIST dav1d-1.1.0.tar.bz2 994368 BLAKE2B 877fd315fb00cb37c80f128c871641b8dbc4a7c9edb3d81afe00e65cb907ed88bcc10e2f92855d1eef51e196a7ae6d189db16dcf0e151f7ca9db715451bd28f5 SHA512 2eb177b415d1ac7bd08d54b16375afedec61f0771a5181fa93e5e6215856fc26504a7cb47de08abbea5bf18fac5ff91ca31044e7054681c380e0ab152e53aabc
+DIST dav1d-1.2.0.tar.xz 866120 BLAKE2B f9c9ca8c48ba2cae8e2137bb46e9db9a2070b3fba35ca142fde836f20be8a0db11b3b0dc3f78d06780d5cf6d014b0a6b545368371f421864d3f30a35ca6fe5ef SHA512 1f1775bdcdbc38a0bb12d7f14f01ee321cc03f15d8b7c6fabe2ada3a3c46885b0eff5851ea912079a1519ef01278c3a192e3b0347b0ab9b25cafab4124f1ae6a
diff --git a/media-libs/dav1d/dav1d-1.2.0.ebuild b/media-libs/dav1d/dav1d-1.2.0.ebuild
new file mode 100644
index 000000000000..9fe8aea4d1ae
--- /dev/null
+++ b/media-libs/dav1d/dav1d-1.2.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://code.videolan.org/videolan/dav1d"
+ inherit git-r3
+else
+ SRC_URI="https://downloads.videolan.org/pub/videolan/dav1d/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+inherit meson-multilib
+
+DESCRIPTION="dav1d is an AV1 Decoder :)"
+HOMEPAGE="https://code.videolan.org/videolan/dav1d"
+
+LICENSE="BSD-2"
+# Check SONAME on version bumps!
+SLOT="0/6"
+IUSE="+8bit +10bit +asm test xxhash"
+RESTRICT="!test? ( test )"
+
+ASM_DEPEND=">=dev-lang/nasm-2.15.05"
+DEPEND="xxhash? ( dev-libs/xxhash )"
+BDEPEND="
+ asm? (
+ abi_x86_32? ( ${ASM_DEPEND} )
+ abi_x86_64? ( ${ASM_DEPEND} )
+ )
+"
+
+DOCS=( README.md doc/PATENTS THANKS.md )
+
+multilib_src_configure() {
+ local -a bits=()
+ use 8bit && bits+=( 8 )
+ use 10bit && bits+=( 16 )
+
+ local enable_asm
+ if [[ ${MULTILIB_ABI_FLAG} == abi_x86_x32 ]]; then
+ enable_asm=false
+ else
+ enable_asm=$(usex asm true false)
+ fi
+
+ local emesonargs=(
+ -Dbitdepths=$(IFS=,; echo "${bits[*]}")
+ -Denable_asm=${enable_asm}
+ $(meson_use test enable_tests)
+ $(meson_feature xxhash xxhash_muxer)
+ )
+ meson_src_configure
+}
+
+multilib_src_test() {
+ if multilib_is_native_abi ; then
+ meson_src_test
+ fi
+}
diff --git a/media-libs/dav1d/dav1d-9999.ebuild b/media-libs/dav1d/dav1d-9999.ebuild
index 9db50e7b2ff7..9fe8aea4d1ae 100644
--- a/media-libs/dav1d/dav1d-9999.ebuild
+++ b/media-libs/dav1d/dav1d-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -7,8 +7,8 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://code.videolan.org/videolan/dav1d"
inherit git-r3
else
- SRC_URI="https://code.videolan.org/videolan/dav1d/-/archive/${PV}/${P}.tar.bz2"
- KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+ SRC_URI="https://downloads.videolan.org/pub/videolan/dav1d/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
fi
inherit meson-multilib
@@ -23,11 +23,13 @@ IUSE="+8bit +10bit +asm test xxhash"
RESTRICT="!test? ( test )"
ASM_DEPEND=">=dev-lang/nasm-2.15.05"
-BDEPEND="asm? (
+DEPEND="xxhash? ( dev-libs/xxhash )"
+BDEPEND="
+ asm? (
abi_x86_32? ( ${ASM_DEPEND} )
abi_x86_64? ( ${ASM_DEPEND} )
)
- xxhash? ( dev-libs/xxhash )"
+"
DOCS=( README.md doc/PATENTS THANKS.md )