summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2024-08-12 12:24:52 -0400
committerMatt Turner <mattst88@gentoo.org>2024-08-12 12:25:41 -0400
commit26a945b951cde89cc861cd82d43d08b2203d0a44 (patch)
treec0199ac6ee84dc770ddf03fa4762b2379159b20b /media-libs/gmmlib/gmmlib-22.5.0.ebuild
parentx11-base/xwayland: Version bump to 24.1.2 (diff)
downloadgentoo-26a945b951cde89cc861cd82d43d08b2203d0a44.tar.gz
gentoo-26a945b951cde89cc861cd82d43d08b2203d0a44.tar.bz2
gentoo-26a945b951cde89cc861cd82d43d08b2203d0a44.zip
media-libs/gmmlib: Version bump to 22.5.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-libs/gmmlib/gmmlib-22.5.0.ebuild')
-rw-r--r--media-libs/gmmlib/gmmlib-22.5.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/media-libs/gmmlib/gmmlib-22.5.0.ebuild b/media-libs/gmmlib/gmmlib-22.5.0.ebuild
new file mode 100644
index 000000000000..2a09f24b8f3d
--- /dev/null
+++ b/media-libs/gmmlib/gmmlib-22.5.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+if [[ ${PV} == *9999 ]] ; then
+ : ${EGIT_REPO_URI:="https://github.com/intel/gmmlib"}
+ if [[ ${PV%9999} != "" ]] ; then
+ : ${EGIT_BRANCH:="release/${PV%.9999}"}
+ fi
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/intel/gmmlib/archive/intel-${P}.tar.gz"
+ S="${WORKDIR}/${PN}-intel-${P}"
+fi
+
+DESCRIPTION="Intel Graphics Memory Management Library"
+HOMEPAGE="https://github.com/intel/gmmlib"
+
+LICENSE="MIT"
+SLOT="0/12.3"
+IUSE="+custom-cflags test"
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-20.2.2_conditional_testing.patch
+ "${FILESDIR}"/${PN}-20.3.2_cmake_project.patch
+ "${FILESDIR}"/${PN}-22.1.1_custom_cflags.patch
+)
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING="$(usex test)"
+ -DOVERRIDE_COMPILER_FLAGS="$(usex !custom-cflags)"
+ )
+
+ cmake_src_configure
+}