summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2024-03-12 14:01:27 -0400
committerMatt Turner <mattst88@gentoo.org>2024-03-12 14:56:59 -0400
commite317cda42e045d35dfd852bca8025a8efca7d0d6 (patch)
tree05a584d53409b358da0ec18ae4efc20857d18585 /media-libs/gmmlib
parentmedia-libs/gmmlib: Update live ebuild (diff)
downloadgentoo-e317cda42e045d35dfd852bca8025a8efca7d0d6.tar.gz
gentoo-e317cda42e045d35dfd852bca8025a8efca7d0d6.tar.bz2
gentoo-e317cda42e045d35dfd852bca8025a8efca7d0d6.zip
media-libs/gmmlib: Version bump to 22.3.18
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-libs/gmmlib')
-rw-r--r--media-libs/gmmlib/Manifest1
-rw-r--r--media-libs/gmmlib/gmmlib-22.3.18.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/media-libs/gmmlib/Manifest b/media-libs/gmmlib/Manifest
index 0450985420d5..2963309adc53 100644
--- a/media-libs/gmmlib/Manifest
+++ b/media-libs/gmmlib/Manifest
@@ -1,2 +1,3 @@
DIST intel-gmmlib-22.3.14.tar.gz 845841 BLAKE2B b766ab36aa24d226a2299c68f47aaaa41341ae9f4d2a6366b68ee7b82669ac78f41097c572e28aa9cac69d06a5d7a246fd0f9cfacc33213423209b8c708e8075 SHA512 7474f3a4899bd4474e2856ff98dd434ee73a1f53b836224cb6fccaace48bd26940d7c907ce00ae5c6d31af9378f33460a9df4299cabdec6c9c233b5730bf31a6
DIST intel-gmmlib-22.3.17.tar.gz 845954 BLAKE2B d01a3b86c539fdeb4d2d66d81590b71dfca045f976f100ff53e0bc8da354c2311ff4c0ff6c371fa63ed97fba387611670a7a8d48eccdf0494824f4c48e4e4c43 SHA512 073cb2e9ec025ae32e2f33f51547083cd8425b0c7297e361b037c71b55a8d2322cd36ac7cabbf8c7a325f80f1cc97947c0aa8aa833dc5fbae5abe28e9c04451a
+DIST intel-gmmlib-22.3.18.tar.gz 846277 BLAKE2B 79485dfe33537053b9986f2f97771c551757da0f9ba721f82f5ff057bf230aa7ad79818d6915fb26cd354cb49d4da27c770c5adb61e530bdd39b51469fc4f9af SHA512 6dab0522a4d15bd5147cb72899a48170f441d5160dc11224809477380b3762ade845e7498a54df7de6673c0ad44bd037db754713697794e26106837f69eb0636
diff --git a/media-libs/gmmlib/gmmlib-22.3.18.ebuild b/media-libs/gmmlib/gmmlib-22.3.18.ebuild
new file mode 100644
index 000000000000..2a09f24b8f3d
--- /dev/null
+++ b/media-libs/gmmlib/gmmlib-22.3.18.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+if [[ ${PV} == *9999 ]] ; then
+ : ${EGIT_REPO_URI:="https://github.com/intel/gmmlib"}
+ if [[ ${PV%9999} != "" ]] ; then
+ : ${EGIT_BRANCH:="release/${PV%.9999}"}
+ fi
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/intel/gmmlib/archive/intel-${P}.tar.gz"
+ S="${WORKDIR}/${PN}-intel-${P}"
+fi
+
+DESCRIPTION="Intel Graphics Memory Management Library"
+HOMEPAGE="https://github.com/intel/gmmlib"
+
+LICENSE="MIT"
+SLOT="0/12.3"
+IUSE="+custom-cflags test"
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-20.2.2_conditional_testing.patch
+ "${FILESDIR}"/${PN}-20.3.2_cmake_project.patch
+ "${FILESDIR}"/${PN}-22.1.1_custom_cflags.patch
+)
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING="$(usex test)"
+ -DOVERRIDE_COMPILER_FLAGS="$(usex !custom-cflags)"
+ )
+
+ cmake_src_configure
+}