summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-11-28 13:25:02 +0100
committerDavid Seifert <soap@gentoo.org>2016-11-29 09:16:11 +0100
commitf083e79fd37604eec23c01e22ca578fe35487826 (patch)
tree15ef481857e2b5baa3dab9045d42b0ec47dfe95e /media-libs/libopenshot-audio/libopenshot-audio-0.1.2-r1.ebuild
parentdev-python/flask-nav: bump to 0.6 (diff)
downloadgentoo-f083e79fd37604eec23c01e22ca578fe35487826.tar.gz
gentoo-f083e79fd37604eec23c01e22ca578fe35487826.tar.bz2
gentoo-f083e79fd37604eec23c01e22ca578fe35487826.zip
media-libs/libopenshot-audio: fix dependencies
Gentoo-Bug: 594664 Package-Manager: portage-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/2944
Diffstat (limited to 'media-libs/libopenshot-audio/libopenshot-audio-0.1.2-r1.ebuild')
-rw-r--r--media-libs/libopenshot-audio/libopenshot-audio-0.1.2-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-libs/libopenshot-audio/libopenshot-audio-0.1.2-r1.ebuild b/media-libs/libopenshot-audio/libopenshot-audio-0.1.2-r1.ebuild
new file mode 100644
index 000000000000..7df2c69b9b18
--- /dev/null
+++ b/media-libs/libopenshot-audio/libopenshot-audio-0.1.2-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Audio library used by OpenShot"
+HOMEPAGE="http://www.openshot.org/ https://launchpad.net/libopenshot"
+SRC_URI="https://github.com/OpenShot/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ media-libs/alsa-lib
+ media-libs/freetype
+ x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXext
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ # fix under-linking
+ # https://github.com/OpenShot/libopenshot-audio/issues/3
+ sed -i 's/^\(target_link_libraries(.*\))$/\1 dl pthread)/' \
+ src/CMakeLists.txt || die
+ cmake-utils_src_prepare
+}